kpoirier

Cannot connect

9 posts in this topic

Windows 10 --> MacOSX Sierra - 10.12.6 beta  - With windows as the server/Mac as the client I see Warning Failed to connect to server: Timed out

When I switch to using Mac as the server and Windows as the client, I see lots of these messages in the log window

 

2017-06-29T19:15:55] ERROR: ipc connection error, connection refused

[2017-06-29T19:15:58] ERROR: ipc connection error, connection refused

[2017-06-29T19:16:01] ERROR: ipc connection error, connection refused

 

I realize I'm using a beta of Mac software - is that the reason?

Share this post


Link to post
Share on other sites

@kpoirier I am having the same exact issue just downloaded today, if you figure it out on your own post in here. Thanks

Share this post


Link to post
Share on other sites

Please provide more details about your machines (OS, 32/64 bit, Synergy version installed, connected to the network via Ethernet or Wi-Fi, specify which one is the server). Also, post a screenshot of both machine's Synergy interface and the Server Configuration interface on your server machine.

Share this post


Link to post
Share on other sites

Server: Windows 10 Pro 64-bit

Client: Mac OSX Sierra

screenshots below show the configuration both are running version 1.8.8 downloaded today.

win10.PNG

Screen Shot 2017-06-30 at 3.34.14 PM.png

Share this post


Link to post
Share on other sites

My setup:

MacOSX 10.12.6 - 64bit

Windows 10: 64bit

I've tried the released version of Synergy Pro - version 1.8.8 stable for both Mac/Windows but recently tried the RC version 1.9.0-rc3 on both Mac/Windows. This is the version I'm running now.

SSL is turned on.

Both systems are on WiFi.  I did have VMware installed on the windows 10 machine, which appeared to be causing Synergy to pick up that IP address, so, in the interests of troubleshooting, I've remove it so both systems have only the WiFi adapter loaded.

I receive different errors depending on which is the server and which is the client.

With Windows as server/Mac as client (with debug option on) I see on the Mac side:

Failed to connect to server: Connection refused

This repeats over and over every second.

Now, when I switch the Mac to be the server and windows to be the client, I see on the windows log:

[2017-06-30T15:55:58] INFO: watchdog status: ok

[2017-06-30T15:55:58] ERROR: ssl error occurred (generic failure)

[2017-06-30T15:55:58] ERROR: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol

[2017-06-30T15:55:58] ERROR: failed to connect secure socket

[2017-06-30T15:55:58] DEBUG: started process, session=1, elevated: no, command="C:/Program Files/Synergy/synergyc.exe" -f --no-tray --debug DEBUG --name KI14891774 --ipc --stop-on-desk-switch --enable-drag-drop --enable-crypto --profile-dir "C:\Users\poirier\AppData\Local" 192.168.7.25:24800

[2017-06-30T15:56:14] WARNING: failed to connect to server: Timed out

[2017-06-30T15:56:14] DEBUG: retry in 1 seconds

[2017-06-30T15:56:15] NOTE: connecting to '192.168.7.25': 192.168.7.25:24800

[2017-06-30T15:56:15] INFO: OpenSSL 1.0.2k 26 Jan 2017

[2017-06-30T15:56:15] ERROR: ssl error occurred (generic failure)

[2017-06-30T15:56:15] ERROR: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol

[2017-06-30T15:56:15] ERROR: failed to connect secure socket

 

 

Share this post


Link to post
Share on other sites

Stop and close and close Synergy on both machines, After that, reboot both. 

Share this post


Link to post
Share on other sites

Done. Same error as above - On the MAC (server) I see Accepted client connection but on the Windows (client) I see:

[2017-07-01T08:26:52] ERROR: ssl error occurred (generic failure)

[2017-07-01T08:26:52] ERROR: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol

[2017-07-01T08:26:52] ERROR: failed to connect secure socket

[2017-07-01T08:27:08] WARNING: failed to connect to server: Timed out

[2017-07-01T08:27:08] DEBUG: retry in 1 seconds

[2017-07-01T08:27:09] NOTE: connecting to '192.168.7.25': 192.168.7.25:24800

[2017-07-01T08:27:09] INFO: OpenSSL 1.0.2k 26 Jan 2017

[2017-07-01T08:27:09] ERROR: ssl error occurred (generic failure)

[2017-07-01T08:27:09] ERROR: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol

[2017-07-01T08:27:09] ERROR: failed to connect secure socket

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now