sethrax

Scroll Lock Key/Back Lighting Issue

21 posts in this topic

I just purchased Synergy Pro and got it installed and set up. It's working fine except that my keyboard has back lighting which is controlled by the Scroll Lock key. The keys are solid black without the lighting turned on, but when I press scroll lock to turn them on, I can no longer move my mouse between each computer. Is there a solution to this?

Share this post


Link to post
Share on other sites

Please provide more details about your machines (OS, 32/64 bit, Synergy version installed, connected to the network via Ethernet or Wi-Fi, specify which one is the server).

  • Like 1

Share this post


Link to post
Share on other sites

Desktop:

  • Configured as Synergy server
  • Has the keyboard with back lighting
  • Windows 10 Pro 64-bit
  • Synergy v1.8.8-stable 64-bit
  • Connected via Ethernet

Laptop:

  • Configured as Synergy client
  • Windows 7 64-bit
  • Synergy v1.8.8-stable 64-bit
  • Connected via Wi-Fi

Share this post


Link to post
Share on other sites

What's the brand and model of that keyboard you are using? Have you installed a software that would manage your keyboard?

Share this post


Link to post
Share on other sites

It's the Cooler Master Devastator II. No keyboard management software installed.

Share this post


Link to post
Share on other sites

I think it would be best if you switch the backlit control of your keyboard to a different button or a different hotkey. We can try disabling the scroll lock however I personally suggest to have the backlit control on a different key since scroll lock is very useful.

Share this post


Link to post
Share on other sites

I don't know how to change the hotkey. I searched Google, but wasn't able to find anything. Cooler Master's website doesn't appear to have any documentation on this keyboard either. Perhaps we should try your other method?

Share this post


Link to post
Share on other sites

Hi @sethrax. I did a further research on this and find this comment from a Cooler Master staff.

Quote

Hello Everyone,
Unfortunately there is no way to remap the LED on/off so you will have to use the scroll lock key.
Our Mechanical keyboard do not function this way and have a separate key to control the LED's. This may be a better option for you since you are using excel.
I apologize for any inconvenience and please let us know if you have any other questions.
 
Patrick
CMUSA Support

Comment Link

I also found out that the toggling of the lights is done on the hardware side of the keyboard. Thus, we can try turning the scroll lock off using the on screen keyboard after you have switched it on using the keyboard's scroll lock key.

  1. On you desktop, click Start > Settings > Ease of Access > Keyboard
  2. Click the switch for On Screen Keyboard  to turn it on
  3. When the on-screen keyboard appears on your screen, click the ScrLk button

***Check if the scroll lock was disabled while the keyboard's lights are still on.

Additionally you can Also switch the Toggle Keys on to hear a tone when you press Caps, Num, and Scroll Lock

Share this post


Link to post
Share on other sites

I've actually already tried that and it doesn't work. Pressing the Scroll Lock button on the on-screen keyboard turns the back lighting on the keyboard on/off.

Share this post


Link to post
Share on other sites

I see. One question though, when you turn your computer on and keyboard is already connected to the computer, does it normally have your keyboard's light turned on? or is it switched off after booting?

Share this post


Link to post
Share on other sites

No, I always have to turn it back on after powering off and back on.

Share this post


Link to post
Share on other sites

How about, while your computer is on (already booted) and you have already switched the back light on, then you unplug the USB cable and re-plug it? Is it still turned on?

Share this post


Link to post
Share on other sites

I see. Try having that again "computer is on (already booted) and you have already switched the back light on," then open the on-screen keyboard. Unplug the USB cable for your keyboard. Click the scroll lock key on the on-screen keyboard. Try to plug the keyboard's USB cable. 

Share this post


Link to post
Share on other sites

Okay I tried that and the keyboard light is on if I turn on scroll lock on the on-screen keyboard and off if i turn off scroll lock on the on-screen.

Share this post


Link to post
Share on other sites

Wait, what? After doing the steps I told you to do, do you have the keyboard's light switched on or off?

Share this post


Link to post
Share on other sites

Sorry, let me clarify.

Test 1:

  1. Computer on.
  2. Keyboard light on.
  3. Opened on-screen keyboard.
  4. Unplugged keyboard.
  5. Turned off scroll lock with on-screen keyboard.
  6. Plugged keyboard in and lights are off.

Test 2:

  1. Computer still on.
  2. Keyboard light off.
  3. On-screen keyboard still open.
  4. Unplugged keyboard.
  5. Turned on scroll lock with on-screen keyboard.
  6. Plugged keyboard in and lights are on.

Share this post


Link to post
Share on other sites

Hello, i have the exact same problem. I also have the cm storm devestator 2. I was wondering if you found a fix for it?

Share this post


Link to post
Share on other sites
On 9/17/2017 at 3:55 PM, NGHTMRE said:

Hello, i have the exact same problem. I also have the cm storm devestator 2. I was wondering if you found a fix for it?

I ended up assigning hotkeys to switch between each computer. I don't think there is any other way since this keyboard model uses the Scroll Lock key for back lighting. 

Share this post


Link to post
Share on other sites
8 hours ago, sethrax said:

I ended up assigning hotkeys to switch between each computer. I don't think there is any other way since this keyboard model uses the Scroll Lock key for back lighting. 

i have found a way to fix it. You just assign a hotkey to unlock the cursor screen lock. My hotkey is set to alt+z. Where you can assign a function to the hotkey there is a option called "Lock mouse to screen" and you just select that and change the dropdown menu to off. That is how i fixed it. I hope it helps you

  • Like 1

Share this post


Link to post
Share on other sites
5 hours ago, NGHTMRE said:

i have found a way to fix it. You just assign a hotkey to unlock the cursor screen lock. My hotkey is set to alt+z. Where you can assign a function to the hotkey there is a option called "Lock mouse to screen" and you just select that and change the dropdown menu to off. That is how i fixed it. I hope it helps you

Nice! Thank you for sharing.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now