Ryan.

ERROR: ipc connection error, connection refused

14 posts in this topic

After upgrading to the latest "stable" firmware offering... I have received this error on the server side of things. I have spent hours attempting to correct the issue without resolution. Please advise on what i need to do here... the error i receive is (ERROR: ipc connection error, connection refused).  Here are the specs on my machines

Server: Windows 10 Pro (version 1703) 64 bit

Client: Windows 10 Home (version 1703) 64 bit

screen shot.jpg

Share this post


Link to post
Share on other sites

Please provide more details about your machines (OS, 32/64 bit, Synergy version installed, connected to the network via Ethernet or Wi-Fi, specify which one is the server). Also, post a screenshot of both machine's Synergy interface and the Server Configuration interface on your server machine.

Share this post


Link to post
Share on other sites

specs are lined out in the first post... 

both machines are connected via ethernet.

server and client are lined out int he first post...

below is the server screen shots:

 

 

SERVER INTERFACE and CONFIGURATION.jpg

Share this post


Link to post
Share on other sites

another note... these two machines have been working together for years without fault, until this last update!

Share this post


Link to post
Share on other sites

Have you tried rebooting both machines already? If so, please try pinging the other machine from the other one. Do the same thing from the other machine. Post screenshots of the results. It'll also be helpful if you can post a screenshot of each machine's Settings screen. You can go to Edit> Settings.

Share this post


Link to post
Share on other sites

yes, i have rebooted several times (both restarting, and shutting down) on both machines

Server ping test towards client, and settings below:

SERVER PING and SETTINGS.jpg

Share this post


Link to post
Share on other sites

I am seeing two IP addresses on your server machine that could be on the same network (192.168.1.x) but seeing only one your server side. I think that could be due to having the client on Wi-Fi and wired network at the same time.

Do you have your server connected to Wi-Fi or via Ethernet cable? or is it also connected to both? How about your client machine?

Share this post


Link to post
Share on other sites

i really don't understand what you mean, as the sentence doesn't make sense... also both wireless cards are disabled, still i have the same issue.  regardless... i have been using synergy on both machines for years without issue, up until this last update.  it has never made a difference wired, wireless, or both on and connected at the same time.  

Share this post


Link to post
Share on other sites

Since you have switched the Wi-Fi on both machines off, post a new set of screenshots of both machine's Synergy interface.

Share this post


Link to post
Share on other sites

well.... i have it working again!!!

my server is a laptop and my client is a desktop.

my server (laptop) is plugged into a docking stating.  I am using the NIC in the docking station to connect to my network.  When i disabled the internal NIC on the laptop, I became up between both the server and client machines, and everything seems to be working fine now.  i went ahead and enabled the internal NIC card again, and after doing so i am still connected between server and client.  SO... something you guys might want to look into during the next upgrade.  I have as stated before been working with this setup for years on the same machines with ZERO issues.  I have never had to to disable the internal NIC before, and frequently take it with me utilizing its internal card.  So something in this last update changed that.

If you want to work further with me to better deep dive into the issue, i would be happy to assist.  

appreciate the assistance in figuring this out.

Ryan

Share this post


Link to post
Share on other sites

I'd love to work further with you on this @Ryan..

Can you open an elevated command prompt and enter ipconfig /all command while you have the internal NIC disabled? Copy it and paste your results on Pastebin or Gist then send me the link through direct message here in forums.

Do the same thing while you have the internal NIC enabled.

***It would be better to set as unlisted when using Pastebin and secret gist for Gist.***

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now