Filibogado

"Server Refused Client" & "Failed to Connect"

17 posts in this topic

Synergy has been running smoothly for the last several days until this morning when I turned it on and got the following message"

1. "ERROR: server refused client with name "Fernandos-Mini.fios_router.home"

2. "Failed to connect to server: server refused client with our name"

On the server screen, I notice the mouse would fall off the right edge but would not enter the second PC's screen.

Attached is my log file.

I would appreciate help. This is used for stock market trading so your usual prompt reply would be appreciated.

 

Thank you,

 

Fernando

 

Share this post


Link to post
Share on other sites

Hi @Filibogado. Please provide more details about your machines (OS, 32/64 bit, Synergy version installed, connected to the network via Ethernet or Wi-Fi, specify which one is the server). Also, post a screenshot of both machine's Synergy interface and the Server Configuration interface on your server machine.

Share this post


Link to post
Share on other sites

Paul:

Server is Windows 10 PC 64- bit running latest Synergy version

Client is Apple Mac Mini running MACOS Sierra V. 10.12.5 and latest Synergy

The symptoms are:

1. On the MAC client, Synergy says "starting" and is stuck, never going to "running"

2. When I opened the server configuration, I noticed only one screen(server) - the 2nd screen (client) had disappeared so I added a new client screen which is on the attached screen shot.

I wonder what caused the client screen icon to vanish from the server configuration layout without me doing anything to it.

MacMini Screen Shot - Client.png

Windows PC Screen Shot - server.png

Windows PC Screen Shot PC.png

Share this post


Link to post
Share on other sites

Also connected to the Verizon FIOS router using CAT5 Ethernet fiber optic cable. All other programs run normally except Synergy.

Share this post


Link to post
Share on other sites

Are you trying to connect them with SSL switched on?

Share this post


Link to post
Share on other sites

I never change the SSL certificate. I do not even know where or how to turn it on or off. I will follow whatever your recommendation is.

Share this post


Link to post
Share on other sites

On both machines, open settings. Edit> Settings
Send me a screenshot for each machine.

Share this post


Link to post
Share on other sites

Attached is a screenshot of the server settings for the Windows 10 PC server.  There is no "settings'' tab for the Edit drop-down menu on the MAC client. The only choice is "Emoji & Symbols".

Both MAC and Windows computers are running Synergy Version 1.8.8-stable-25a8cb2 with Build Date of Thursday, March 16, 2017.

Windows 10 PC Server Settings.png

Share this post


Link to post
Share on other sites

What options do you have on your menu bar when you have Synergy opened on Mac?

Share this post


Link to post
Share on other sites

File

Start

Activate

Save Configuration File

Edit

Emoji & Symbols

 

That's it.

 

Share this post


Link to post
Share on other sites

What do options do you get after clicking Edit or File?

Share this post


Link to post
Share on other sites

Just like I said above:

When I click "Edit", the only option is: :

1. "Emoji & Symbols"

Wen I click "File", the options are:

1."Start"

2. "Activate"

3. "Save Configuration File"

That's it - no more options other than the above.

Share this post


Link to post
Share on other sites

Can you try to check each option on your Mac and look for Settings or any button that would lead you to have another box opened that looks the same as what you have posted from your windows machine?

Share this post


Link to post
Share on other sites

What I gave you are all the options I found on the MAC. Maybe the program got corrupted. I will do a clean reinstall by deleting the program and reinstalling it. Should I do the reinstall on both machines or just on the MAC? Do I need to do extra steps like deleting any configuration files separately or will the reinstallation process take care of that?

Share this post


Link to post
Share on other sites

For Mac machines, configuration files are saved on a separate location, though it mostly shouldn't matter.

Share this post


Link to post
Share on other sites

I did a clean re-install of Synergy on both machines. Synergy is back up and running again after the re-install. I suspect that it was the program on the Windows 10 PC server that was corrupted because I remember seeing the configuration screen icon representing the MAC client screen vanishing from the server grid when I first encountered the problem.

Thank you for your support nd assistance.

Fernando

 

 

 

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now