ShadowofReason

Synergy isn't starting up.

14 posts in this topic

Hi @Paul Suarez !

After a reboot Synergy server isn't working for me. 

The error I'm getting is: [2017-06-27T12:17:56] ERROR: ipc connection error, remote host closed

I tried reinstalling synergy ( remove, confirm that services are gone, deleted registry entries, reboot and tried to install again) but that didn't help.

My workflow has been heavily affected by this.

 

Still rocking windows 7 for the serverside.

I can provide some sort of remote access, because I cannot seem to figure this one out.

 

 

 

 

Share this post


Link to post
Share on other sites
7 hours ago, ShadowofReason said:

ERROR: ipc connection error, remote host closed

Usually means it's either the machine that you're on is not connected to the network, or the other machine is not connected to the same network. Please post a screenshot of both machine's Synergy interface.

Share this post


Link to post
Share on other sites

@Paul Suarez

I'm only getting this on the serverside. The client side is okay, that i know.
and the serverside is 24/7 on the network because it's my main hub.

Could it be a issue due to network interfaces coming and going?  (VPN) . I use VPN alot to many different points, so I see maybe like 50-60 different subnets per day.

 

SC3.JPG

Edited by ShadowofReason
Forgot a little little

Share this post


Link to post
Share on other sites
10 minutes ago, ShadowofReason said:

I use VPN alot to many different points

This depends on how you are using VPN or how and what changes your VPN does on your network settings. Is that a software type VPN or a hardware based VPN?

Share this post


Link to post
Share on other sites
10 minutes ago, ShadowofReason said:

I use VPN alot to many different points

This depends on how you are using VPN or how and what changes your VPN does on your network settings. Is that a software type VPN or a hardware based VPN?

Share this post


Link to post
Share on other sites
2 minutes ago, Paul Suarez said:

This depends on how you are using VPN or how and what changes your VPN does on your network settings. Is that a software type VPN or a hardware based VPN?

I have HW VPN (IPSEC Site-to-Site tunnel), but I can't really see how that can affect anything on my computer since it doesn't appear as an interface but the actual packet forwarding is done on the fw side.

But yes, I do have Cisco VPN client and OpenVPN  software rocking for me ( I mainly use OpenVPN (tap adapter) for connecting to client sites ).

Share this post


Link to post
Share on other sites
14 minutes ago, ShadowofReason said:

I mainly use OpenVPN (tap adapter) for connecting to client sites

This sounds likely to be a possible culprit. But we can try to check other things that might affect or help us.

Do you have desktops? or are those laptops?
If they're desktops, can you connect them to wireless networks (Wi-Fi)?

18 minutes ago, ShadowofReason said:

but I can't really see how that can affect anything on my computer

Some VPN tend to encapsulate/hide the actual LAN IP address of a machine/device. Since Synergy relies on IP to find the machine and screen names(and SSL key if SSL is on) to authenticate clients, this would give confusion when it sees the data packets from your machines that uses VPN. It might read the encapsulated data instead of the actual local IP.

Share this post


Link to post
Share on other sites

Well the internal network (10.0.0.0/24) is just passed without any filtering since it is LAN.. 
All WAN traffic just goes out from the FW. ( Doing NAT-T with my connection speed would be stupid ).

None of the VPN servers i use do NAT-T, so packets do not get forwarded.

I am quite sure that as soon as I do a system restore I'll be able to get back on my feet, but that ain't the solution.

As I mentioned before, that I'm willing to allow  remote access using teamviewer or some vnc service. (I prefer teamviewer).

I would need this fixed asap because my productivity is smacked to the ground currently.

Share this post


Link to post
Share on other sites

Let's try setting up a primary interface for each machine.

  1. On Synergy's user interface, click Edit
  2. Click Settings
  3. Use the IP address of that machine where you want it to listen or look for the other machine, type it in the box next to Interface
  4. Click OK
  5. Click Apply or Start

Share this post


Link to post
Share on other sites

@Paul Suarez

 

That didn't work either, so I gave up and came back to it today. 
I managed to get it running by doing this:

1)Uninstalling synergy through the control panel.
2)Opened up regedit, deleted all keys that came up with 'synergy' through the search.
3)Downloaded rc3 from the forums ... Reinstalled.
4)Repeated steps 1-3 on client pc.
5) Got it running only until I pressed stop on the server side(Windows 7)...Now i'm stuck at "Synergy is starting" again.... 

Share this post


Link to post
Share on other sites

Had to reinstall it on the server side again (following steps 1-3) to get it running..

Seems like I have to batch this temporarely... 

The synergyd.exe freezes ( Doesn't accept commands ) and eats up 25% CPU ( 1 entire core )  

Share this post


Link to post
Share on other sites

Hmm apparently it doesn't even start anymore.. This is getting on my nerves quite a bit already.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now