Andrew

No scroll wheel at all

18 posts in this topic

Mac OS X as the server, Windows 10 as the client. No scrolling at all, either with my apple track pad or Logitech mouse. Clipboard and everything else seems to work fine. Any suggestions?

Share this post


Link to post
Share on other sites

Have you installed Logitech's software for your mouse? What's the model of it? Have you tried uninstalling Synergy and checking if scroll works with that mouse?or the track pad?

Share this post


Link to post
Share on other sites

Yes, I have installed the Logitech software. It's a "Perforamance MX".

Scrolling works perfectly on the Mac, for what that's worth. It's only on the remote computer—the Windows client—

that there is no scrolling. 

8 minutes ago, Paul Suarez said:

Have you installed Logitech's software for your mouse? What's the model of it? Have you tried uninstalling Synergy and checking if scroll works with that mouse?or the track pad?

 

Share this post


Link to post
Share on other sites

Can you try to disable or uninstall Logitech's software first? After uninstalling, reboot your server. After rebooting try to check if mouse scroll works on the client.

  • Like 1

Share this post


Link to post
Share on other sites

I have now uninstalled the Logitech software and rebooted. Still no scrolling on the client.

Edited by Andrew

Share this post


Link to post
Share on other sites

And scrolling still works on the server with both mouse and track pad?

  • Like 1

Share this post


Link to post
Share on other sites

Yes. With the mouse is very slow now, due to no Logitech driver.

I have also disabled the couple of other utility things that I thought might be interfering with grabbing input:

  • Copy'em Paste
  • Alfred

...even though they were pretty much just looking at keyboard events.

Share this post


Link to post
Share on other sites

I am having the same issue! Server is MacBook Pro and 2 clients are Linux and Mac Server and sometimes another Linux box. Mouse scrolling does not work on any of the clients! Only the Synergy server does mouse scrolling work. I do not have any Logitech software installed nor have I ever. I have tried Logitech mouse, Microsoft mouse, Magic Mouse, track pads etc and all have the same issue where mouse scrolling only works on the server. Copy and paste work fine. Left and right click work fine, its just mouse scrolling that does not work!

From what I am seeing when I Google this issue this is a pretty common issue, THUS why hasn't this issue been resolved/fixed?!? If it cannot be resolved/fixed then I want a refund and I will switch back over to a KVM for at least it works!

Very disappointed! To only have support via this forum is just plain terrible service! Used to be a big fan of this software for I liked being able to manage numerous machines without the need of a KVM. Was going to pitch the software to our CIO for 40+ servers but not till this is fixed!

Ugh... such a disappointment!

 

Share this post


Link to post
Share on other sites

FYI - I even tried making the Linux box the server and get same results so its not a Mac issue.

Share this post


Link to post
Share on other sites

I was considering trying to make my Windows computer the server, to see if that would fix it. (Although I really don't want to..Windows will boot without a keyboard/mouse but the Mac not so much.) Now I'm doubting if that's worth trying either.

Share this post


Link to post
Share on other sites

Not an option for me for I do not use Windows as a workstation, but I have tried various Linux versions, MacOS versions and OSX Server. No luck.

Share this post


Link to post
Share on other sites

Hi @Andrew. Can you verify if your Windows machine is a laptop? or is it a desktop?

Share this post


Link to post
Share on other sites

The Windows machine is a desktop, running the latest version of 10 with the "Creators" update.

Share this post


Link to post
Share on other sites

Can you try and set your Windows machine as the server?

Share this post


Link to post
Share on other sites

Okay, the Windows machine was too far away for the keyboard cord to reach, so I've had to get a new extension cable. Setting up the Windows computer as the server does, in fact, fix the scroll wheel. 

This is a bit of a pain, as the Mac will not boot without a keyboard attached, but the PC is happy to do so. If you manage to fix this bug, I would like to switch them back.

-a

Share this post


Link to post
Share on other sites

I have the same issue, too. Mac 10.12.6 as the server, Windows 10 (the latest) as the client. But when I tried to create a new account on Mac, scrolling worked. Strange enough. I tried to reinstall synergy, tried 2.0.With old account ( domain account controlled by the company, LDAP), can't fix the problem.

Share this post


Link to post
Share on other sites
On 6/27/2017 at 2:45 PM, Paul Suarez said:

Can you try and set your Windows machine as the server?

Alright, I've been using it with Windows as the server, and suddenly: CRAZY! I have a couple of Linux VMs that run in Parallels Desktop on my Mac. They normally just run in the background and I SSH into them (since I like iTerm better than the VM window). Today I notice that when I *do* use the VM window, or a Windows VM, the shift key does not work through Synergy. I have to plug a keyboard directly into the Mac in order to type capital letters. Both odd and extremely frustrating! (Why, oh, why is it not accepting my password!?!?)

Is the Mac version only officially supported (but unofficially abandoned) or something? This is ridiculous!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now