jammermass

Mac client fail to connect to Win 10 server

16 posts in this topic

Hey there,

I just downloaded Synergy and was hoping to quick start moving files seemlessly between by macBook Pro (os 10.11.6) and my windows 10 machine, but keep getting this error on the client (Mac) computer:

[2017-06-22T13:57:20] WARNING: failed to connect to server: Connection refused
[2017-06-22T13:57:21] NOTE: connecting to '192.168.0.11': 192.168.0.11:24800
[2017-06-22T13:57:21] INFO: OpenSSL 1.0.2 22 Jan 2015

My windows machine is running the server side fine, but there are no additional monitors appearing the Server Config. window, so there is nothing to add in for sharing.

What am I doing wrong here?

Cheers!

James

Share this post


Link to post
Share on other sites

Yes, I do see that...and I dragged the Unnamed Computer in the top right corner to the left side of the Server Monitor in the center (image attached). Still again, when I go to runt the Mac client, it gives me this:

 

[2017-06-22T16:17:15] WARNING: failed to connect to server: Connection refused

[2017-06-22T16:17:16] NOTE: connecting to '192.168.0.11': 192.168.0.11:24800

[2017-06-22T16:17:16] INFO: OpenSSL 1.0.2 22 Jan 2015

[2017-06-22T16:17:17] WARNING: failed to connect to server: Connection refused

[2017-06-22T16:17:17] INFO: stopping synergy desktop process

[2017-06-22T16:17:17] INFO: process exited normally

 

unnamed.png

Share this post


Link to post
Share on other sites

That's because the server can't identify your client's screen name since you haven't changed the screen name on that unnamed screen. Please check Getting started with Synergy knowledge base article for steps on how to do an initial configuration.

Share this post


Link to post
Share on other sites

I changed the client's name in the Server Config. screens window to match the Screen Name on the client computer. I clicked Apply then Start on the server machine. The server pc runs fine, waiting for client to connect. When I go to the Mac, client machine, and confirm again that the Client box is checked, the Screen name matches the Server Config. screen name, the Server IP matches the IP address (in bold), I still get this message:

 

[2017-06-23T12:12:02] INFO: OpenSSL 1.0.2 22 Jan 2015

[2017-06-23T12:12:03] WARNING: failed to connect to server: Connection refused

[2017-06-23T12:12:04] NOTE: connecting to '192.168.0.11': 192.168.0.11:24800

[2017-06-23T12:12:04] INFO: OpenSSL 1.0.2 22 Jan 2015

[2017-06-23T12:12:04] INFO: stopping synergy desktop process

[2017-06-23T12:12:04] INFO: process exited normally

 

Here are screenshots attached as ref. What am i doing wrong here?

Screen Shot 2017-06-23 at 12.13.58 PM.png

IMG_0743.JPG

Share this post


Link to post
Share on other sites

Please make sure that both machines has their SSL switched on if you want them to connect with SSL. You can switch them both off if you want them not to use SSL.

Share this post


Link to post
Share on other sites

I checked and they were both set to use SSL, but to check I switched the SSL off, and I still got this similar error message:

 

[2017-06-23T18:43:43] NOTE: connecting to '192.168.0.11': 192.168.0.11:24800

[2017-06-23T18:43:43] WARNING: failed to connect to server: Connection refused

[2017-06-23T18:43:44] NOTE: connecting to '192.168.0.11': 192.168.0.11:24800

[2017-06-23T18:43:44] WARNING: failed to connect to server: Connection refused

[2017-06-23T18:43:45] NOTE: connecting to '192.168.0.11': 192.168.0.11:24800

[2017-06-23T18:43:45] WARNING: failed to connect to server: Connection refused

[2017-06-23T18:43:46] INFO: stopping synergy desktop process

[2017-06-23T18:43:46] INFO: process exited normally

Share this post


Link to post
Share on other sites

Make sure that before you switch SSL settings, both machine's Synergy is not running/not started. After switching SSL off on both, restart Synergy one each by closing and re-opening it.

Share this post


Link to post
Share on other sites

yup. did all that. same message:

 

[2017-06-23T19:06:41] NOTE: connecting to '192.168.0.11': 192.168.0.11:24800

[2017-06-23T19:06:41] WARNING: failed to connect to server: Connection refused

[2017-06-23T19:06:42] NOTE: connecting to '192.168.0.11': 192.168.0.11:24800

[2017-06-23T19:06:42] WARNING: failed to connect to server: Connection refused

[2017-06-23T19:06:43] INFO: stopping synergy desktop process

[2017-06-23T19:06:43] INFO: process exited normally

Share this post


Link to post
Share on other sites

pc Server log says:

[2017-06-23T19:13:12] INFO: starting new process

[2017-06-23T19:13:12] INFO: activeDesktop:Default

[2017-06-23T19:13:12] INFO: starting new process

[2017-06-23T19:13:12] INFO: drag and drop enabled

[2017-06-23T19:13:12] NOTE: started server, waiting for clients

[2017-06-23T19:13:12] INFO: watchdog status: ok

Share this post


Link to post
Share on other sites

Please post a screenshot of both machine's Synergy interface and the Server Configuration interface on your server machine again.

Share this post


Link to post
Share on other sites

Hi @jammermass. It shows there that your server now has 192.168.0.3. This happens when your server machine's IP lease expires. The DHCP server (mostly your router) will then provide your computer a different set of IP address. If you'd want to have the same IP address every time, you might need to set DHCP reservation on your router's user interface.

For now, you can just set the Server IP on your mac with that 0.3 address as shown on your server machine.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now