Ian C

Cursor stuck in iTerm2 even when my mouse pointer has moved to Windows display

4 posts in this topic

If I am working in iTerm2 and move my mouse pointer to a Windows system and start typing, the cursor is still in iTerm2 and the characters I type appear in iTerm2. I've tried changing a number of different settings in iTerm2 but nothing works.

If I switch to a different application on my Mac before going to the Windows display, the cursor is not trapped on the Mac side and I can type into any field on the Windows side.

Has anyone else encountered this problem? Does anyone know of a solution?

Share this post


Link to post
Share on other sites

It sounds like a scroll lock problem to me. If you're using it on full-screen mode, then you'd really need to switch over to a different application. If you have the option minimize and set a little gap from the end off the monitor where your Windows machine is linked, then you can have a spot to click first before getting in to your screen for Windows machine.

You can also try to set a hotkey either on iterm2 or Synergy to try and toggle the scroll lock on your Mac machine.

Share this post


Link to post
Share on other sites

Hey @Ian C , you're not alone! I've run into this issue a couple of times myself. However, it seems to be a quirk of iTerm forcing focus when the cursor is "hidden" by programs such as Synergy, as I've found the same behaviour while using a few other apps on the local machine (1password and IntelliJ seem to cause it to happen quite a lot). As a workaround, I have a global hotkey trigger set (under keys in preferences) and whenever input focus is stolen by iTerm a double tap of the hotkey brings things back to normal. Hope this helps.

596197d23810a_ScreenShot2017-07-09at03_39_22.thumb.png.7ac1850035cafb17573035806b6b6b64.png

  • Like 1

Share this post


Link to post
Share on other sites

Thank you both for your advice! It's helped alleviate the issue with switching screens.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now