alangley

Just Purchased, Multiple problems (Service can't be stopped, etc.)

11 posts in this topic

Windows 7

I just purchased and installed Synergy and having numerous problems getting it to work. Spent over an hour on this already...

First, it wouldn't let me install Bonjour, so I searched forums for a solution, and found a newer build to install (May 10, 1.9.0-rc3...)

I uninstalled the app (via Add/Remove programs) and reinstalled the newer build. It allowed me to install Bonjour. But now it won't actually start when I try to start the server.  It just hangs at "Starting". 

I quit and restarted the app: same issue.

Now I just tried to uninstall the program completely again, but it won't allow me to because it can't stop the Synergy Service.

I restarted the PC, and tried to uninstall again: still can't stop the service.

I suspect the Synergy service is at the root of the problem. Any ideas how to shut this down?

Share this post


Link to post
Share on other sites

Can you open services.smc on your computer and look for the Synergy service? You can follow the steps below.

  1. Press and hold  button and press R
  2. Type "services.msc" and click OK or just press Enter
  3. Search for Synergy under Name (click any name and quickly press S and then Y)
  4. Double click Synergy and check if you can Stop or at least Pause it.
  5. If it allows you, click Apply and OK
  6. You can proceed in trying to uninstall it.

Let us know how it goes @alangley.;)

Share this post


Link to post
Share on other sites

That's what I've been trying to do. No, it won't let me stop the service that way. The service was frozen in the "Stopping" status. After another half hour of research/troubleshooting I figured out how to stop the process.

Solution for Stopping the Service and Uninstall:

I did a force kill following these instructions:

  1. Click the Start menu
  2. Click Run or in the search bar type services.msc
  3. Press Enter
  4. Look for the service and check the Properties and identify its service name
  5. Once found, open a command prompt. Type sc queryex [servicename].
  6. Press Enter
  7. Identify the PID
  8. In the same command prompt type taskkill /pid [pid number] /f
  9. Press Enter

After doing that, the service just restarted and changed to "Running" status.

Then I opened the Service and changed the Startup Type to "Disabled":

  1. Press and hold WIN button and press R
  2. Type "services.msc" and click OK or just press Enter
  3. Search for Synergy under Name (click any name and quickly press S and then Y)
  4. Double click Synergy. Change "Startup Type" to "Disabled". Apply.

Then it allowed me to Uninstall.

Now trying to re-install and see if I can get it to connect to the client...

Share this post


Link to post
Share on other sites

Still having the same problem.  When I try to start the Server (on the same Win7 PC mentioned above re: Service problem), it does not complete the start process. It only says "Synergy is Starting" and only gets to:

[2017-06-14T18:12:36] INFO: connecting to service...

[2017-06-14T18:12:39] INFO: connection established

[2017-06-14T18:13:07] INFO: starting server

[2017-06-14T18:13:07] INFO: config file: C:/Users/Adam/AppData/Local/Temp/Synergy.l14376

[2017-06-14T18:13:07] INFO: log level: INFO

Share this post


Link to post
Share on other sites

Please post a screenshot of both machine's Synergy interface and the Server Configuration interface on your server machine.

Share this post


Link to post
Share on other sites

I uninstalled the newer build (now that Bonjour is installed) and reinstalled v1.8.8. Now it is no longer hanging on "Starting."

However, now I'm getting the following on the Server:

[2017-06-14T18:42:29] NOTE: accepted client connection

[2017-06-14T18:42:29] WARNING: unrecognised client name "Inspiron-17", check server config

[2017-06-14T18:42:29] NOTE: disconnecting client "Inspiron-17"

[2017-06-14T18:42:29] NOTE: client "Inspiron-17" has disconnected

 

 

How do I get my Server to recognize my client?

Share this post


Link to post
Share on other sites

Client side is giving the following messages upon attempt to connect:

[2017-06-14T18:42:35] NOTE: connecting to '192.168.0.5': 192.168.0.5:24800

[2017-06-14T18:42:35] ERROR: server refused client with name "Inspiron-17"

[2017-06-14T18:42:35] WARNING: failed to connect to server: server refused client with our name

 

I'm not receiving any kind of notification or popup or anything to accept the client connection. Am I supposed to be?

Share this post


Link to post
Share on other sites

Nevermind... I've spent over 4 hours on this and can't get it to work. I purchased Multiplicity and got it working in less than 5 minutes.

Can I please be refunded for my purchase?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now