PioneerX

Incorrect Interface selected

4 posts in this topic

I have multiple LAN interfaces on my machine and unfortunately I seem to have an issue where Synergy connects to the wrong one. I cant find any settings that would force it to the correct interface. I was looking for a GUI setting but cant find one, I also reviewed the textual configuration file and cant find a setting int here to select the correct interface. Can you advice how get Synergy Pro to connect to the correct interface?

Thanks

2017-06-11_08h59_02.png.f6ef2d3c08c1a400326627788df76a00.png

Interface in use is 192.168.56.1 (VirtualBox NAT LAN) interface that should be used is 172.21.1.150

2017-06-11_09h02_30.png.63814c0141be6695195504d9ff83d553.png

Thanks for your help.

Share this post


Link to post
Share on other sites

Currently, you can disable or disconnect from all other network adapters you have on your machine and restart Synergy for it to recognize that interface as the primary. After connecting you can re-enable all of the other network adapters. There's a coming interface selection feature that will be included in v2.

Share this post


Link to post
Share on other sites
6 minutes ago, Paul Suarez said:

Currently, you can disable or disconnect from all other network adapters you have on your machine and restart Synergy for it to recognize that interface as the primary. After connecting you can re-enable all of the other network adapters. There's a coming interface selection feature that will be included in v2.

Hi Paul,

Thanks for getting back to me. I have actually got this to work ok despite the selected interface issue. I used the 'interface' field located in the settings of the server to hard code an IP address. This seems to force the server to use the correct interface (although does not change the highlighted IP in the GUI which remains on the wrong interface)......

2017-06-13_19h21_08.png.b10861a9ec3a67792c6df8d101ab8228.png

......and then turned off 'auto config' on the client and hard coded the same IP address. I'm not sure if this is meant to work but once I did that everything worked as expected on the 172.21.1.150 address.

I hope this helps anyone else struggling with the issue.

Share this post


Link to post
Share on other sites
9 minutes ago, PioneerX said:

Hi Paul,

Thanks for getting back to me. I have actually got this to work ok despite the selected interface issue. I used the 'interface' field located in the settings of the server to hard code an IP address. This seems to force the server to use the correct interface (although does not change the highlighted IP in the GUI which remains on the wrong interface)......

2017-06-13_19h21_08.png.b10861a9ec3a67792c6df8d101ab8228.png

......and then turned off 'auto config' on the client and hard coded the same IP address. I'm not sure if this is meant to work but once I did that everything worked as expected on the 172.21.1.150 address.

I hope this helps anyone else struggling with the issue.

Yes, that is the main purpose of that box. Although, I have seen some instances that it doesn't work that's why I have provided you a different solution. But it's a good thing that the Interface box works for you. ^_^

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now