therring

Connecting a Nvidia TX1 and Windows 10 Machine

7 posts in this topic

New to the forum and Linux. Trying to connect a Windows 10 machine to my Nvidia TX1 (which has an ARM 64 processor). After buying the pro version of the software, I downloaded the client onto my windows machine. I tried downloading the Ubuntu install file from the website. However, the file wouldn't install (which is generally my experience with Ubuntu install files and probably caused by the ARM 64 architecture). After that didn't work, I did an apt-get for Synergy. It installed correctly and the GUI launched. However, it won't detect the Windows machine while it's running a Synergy in server mode (with encryption turned off). I inputted the IP displayed by Synergy on the server side into the client on the TX1 but, it seemed to time out every time. After checking the versions on both devices, it seems that even though the Windows 10 server is running the latest build, 1.8.8, but the version on the TX1 is 1.6.2 (which appears to be from 2012).

 

I tried to compile the files from source to see if that would help support ARM 64 with the latest build. I seem to have been able to do something with it? I was able to compile and build the source successfully. I tried to execute one of the files created by the source inputting the IP displayed on the server on the windows machine but found the same result as with the 1.6.2 version install, connection time out.

 

Not sure where to go from here. Thanks in advance y'all! I'm new to Linux, so this can all be confusing.

Share this post


Link to post
Share on other sites

The TX1 runs a modified version of Ubuntu provided by Nvidia called Linux for Tegra (L4T). I've got L4T 24.2.1 running on my TX1 which is based on Ubuntu 16.04 I believe.

Share this post


Link to post
Share on other sites

Not sure what to do. This is still an issue I can't seem to solve.

Share this post


Link to post
Share on other sites

Hi @therring. It should work with Windows using v1.8.8.8 and Ubuntu using v1.6.2. Just make sure that SSL is switched off on Windows machine. Also, please check the firewall rules on the Windows machine.

Share this post


Link to post
Share on other sites

Hi again Paul,

I tried doing what you suggested, installing the versions you were talking about on the respective computers. Made sure that SSL was disabled and made sure that there were firewall rules on the Windows machine to allow all outgoing and incoming communications with synergy.exe.

I've got the newest version of Windows (Creator edition), and I noticed that others on the forum were having troubles getting the Windows Firewall to work properly with it. I'm wondering if there are some firewall settings that I've got to enable on my Windows 10 machine. Could this be an issue?

On the client side, I'm seeing it timeout, which gives me the feeling that this may be the case.

Share this post


Link to post
Share on other sites

Hi @therring. Can you try to ping the other machine from the other one and do it the other way around? You can post a screenshot(s) of it.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now