asuthar

Win10 Server to Win10 Client problems

8 posts in this topic

Hello all,

I was directed to post in the forums for help. I had just purchased Synergy Pro and wanted to get my desktop configured as a server and my laptop as a client, they are both win 10. I keep having an error that states my client accepts the secure socket, then states the client name is unrecognized and then drops the connection. When I check the server config, my client does not even show up in the Configure Server GUI but my server is there. If you would like me to provide logs from my client and/or server, or any other information, please let me know and I'l do so right away. 

Share this post


Link to post
Share on other sites

I forgot to mention that my server is win 10 pro (desktop), and my client is win 10 enterprise (laptop). I own the machine but I brought my own device in for work. Not sure if the enterprise version of windows changes things.

Share this post


Link to post
Share on other sites

Here are the logs in that are presented from the synergy application from the server:

Quote

[2017-06-08T09:49:20] INFO: watchdog status: error

[2017-06-08T09:49:39] INFO: starting server

[2017-06-08T09:49:39] INFO: config file: C:/Users/Arth/AppData/Local/Temp/qt_temp.H35200

[2017-06-08T09:49:39] INFO: log level: INFO

[2017-06-08T09:49:39] INFO: service command updated

[2017-06-08T09:49:39] INFO: service command updated

[2017-06-08T09:49:40] INFO: starting new process

[2017-06-08T09:49:40] INFO: activeDesktop:Default

[2017-06-08T09:49:40] INFO: starting new process

[2017-06-08T09:49:40] INFO: drag and drop enabled

[2017-06-08T09:49:40] NOTE: started server, waiting for clients

[2017-06-08T09:49:40] INFO: watchdog status: ok

[2017-06-08T09:49:50] INFO: downloading 64-bit Bonjour

[2017-06-08T09:55:08] INFO: OpenSSL 1.0.2 22 Jan 2015

[2017-06-08T09:55:09] INFO: accepted secure socket

[2017-06-08T09:55:09] INFO: AES256-GCM-SHA384 TLSv1.2 Kx=RSA Au=RSA Enc=AESGCM(256) Mac=AEAD

[2017-06-08T09:55:09] NOTE: accepted client connection

[2017-06-08T09:55:10] NOTE: new client disconnected

[2017-06-08T09:55:22] INFO: OpenSSL 1.0.2 22 Jan 2015

[2017-06-08T09:55:22] INFO: accepted secure socket

[2017-06-08T09:55:22] INFO: AES256-GCM-SHA384 TLSv1.2 Kx=RSA Au=RSA Enc=AESGCM(256) Mac=AEAD

[2017-06-08T09:55:22] NOTE: accepted client connection

[2017-06-08T09:55:22] WARNING: unrecognised client name "ARTH-HOMEPC", check server config

[2017-06-08T09:55:22] NOTE: disconnecting client "ARTH-HOMEPC"

[2017-06-08T09:55:22] NOTE: client "ARTH-HOMEPC" has disconnected

 

Here are the logs from the client: 

Quote

 

[2017-06-08T10:07:06] INFO: log level: INFO

[2017-06-08T10:07:06] INFO: service command updated

[2017-06-08T10:07:07] INFO: starting new process

[2017-06-08T10:07:07] INFO: activeDesktop:Default

[2017-06-08T10:07:07] INFO: starting new process

[2017-06-08T10:07:07] INFO: drag and drop enabled

[2017-06-08T10:07:07] NOTE: started client

[2017-06-08T10:07:07] NOTE: connecting to '192.168.0.104': 192.168.0.104:24800

[2017-06-08T10:07:07] INFO: OpenSSL 1.0.2 22 Jan 2015

[2017-06-08T10:07:07] INFO: watchdog status: ok

[2017-06-08T10:07:07] NOTE: server fingerprint: F4:EA:EC:93:31:7B:D5:17:B8:31:2C:08:6A:D5:14:89:37:56:2A:DC

[2017-06-08T10:07:07] INFO: connected to secure socket

[2017-06-08T10:07:07] INFO: server ssl certificate info: /CN=Synergy

[2017-06-08T10:07:07] INFO: AES256-GCM-SHA384       TLSv1.2 Kx=RSA      Au=RSA  Enc=AESGCM(256) Mac=AEAD

[2017-06-08T10:07:07] ERROR: server refused client with name "ARTHHOMEPC"

[2017-06-08T10:07:08] WARNING: failed to connect to server: server refused client with our name

 

synergyServer.jpg

Share this post


Link to post
Share on other sites

Hi @asuthar. Your server machine uses SSL while your client machine doesn't. You need to either turn the SSL on for both computers or turn SSL off for both.

  1. Click the Edit menu
  2. Click the Settings menu item
  3. Either check or uncheck SSL
  4. Make sure it's the same on both machines

You can also check these steps in SSL generic failure knowledge base article.

Share this post


Link to post
Share on other sites

Thanks for your reply Paul.

I made sure both use SSL and I got errors.

I made sure both do not use SSL and I get errors 

Server Errors with SSL Off:

Quote

[2017-06-08T12:58:55] INFO: log level: INFO

[2017-06-08T12:58:55] INFO: service command updated

[2017-06-08T12:58:56] INFO: starting new process

[2017-06-08T12:58:56] INFO: activeDesktop:Default

[2017-06-08T12:58:56] INFO: starting new process

[2017-06-08T12:58:56] INFO: drag and drop enabled

[2017-06-08T12:58:56] NOTE: started server, waiting for clients

[2017-06-08T12:58:56] INFO: watchdog status: ok

[2017-06-08T12:59:01] NOTE: accepted client connection

[2017-06-08T12:59:01] WARNING: unrecognised client name "ARTH-HOMEPC", check server config

[2017-06-08T12:59:01] NOTE: disconnecting client "ARTH-HOMEPC"

[2017-06-08T12:59:01] NOTE: client "ARTH-HOMEPC" has disconnected

[2017-06-08T12:59:02] NOTE: accepted client connection

[2017-06-08T12:59:02] WARNING: unrecognised client name "ARTH-HOMEPC", check server config

[2017-06-08T12:59:02] NOTE: disconnecting client "ARTH-HOMEPC"

[2017-06-08T12:59:02] NOTE: client "ARTH-HOMEPC" has disconnected

[2017-06-08T12:59:03] NOTE: accepted client connection

[2017-06-08T12:59:03] WARNING: unrecognised client name "ARTH-HOMEPC", check server config

[2017-06-08T12:59:03] NOTE: disconnecting client "ARTH-HOMEPC"

Client Errors with SSL Off:

Quote

[2017-06-08T12:58:51] INFO: starting new process

[2017-06-08T12:58:51] INFO: activeDesktop:Default

[2017-06-08T12:58:51] INFO: starting new process

[2017-06-08T12:58:51] INFO: drag and drop enabled

[2017-06-08T12:58:51] NOTE: started client

[2017-06-08T12:58:51] NOTE: connecting to '192.168.0.104': 192.168.0.104:24800

[2017-06-08T12:58:51] INFO: watchdog status: ok

[2017-06-08T12:59:00] ERROR: server refused client with name "ARTH-HOMEPC"

[2017-06-08T12:59:00] WARNING: failed to connect to server: server refused client with our name

[2017-06-08T12:59:01] NOTE: connecting to '192.168.0.104': 192.168.0.104:24800

[2017-06-08T12:59:01] ERROR: server refused client with name "ARTH-HOMEPC"

[2017-06-08T12:59:01] WARNING: failed to connect to server: server refused client with our name

[2017-06-08T12:59:02] NOTE: connecting to '192.168.0.104': 192.168.0.104:24800

[2017-06-08T12:59:02] ERROR: server refused client with name "ARTH-HOMEPC"

[2017-06-08T12:59:02] WARNING: failed to connect to server: server refused client with our name

[2017-06-08T12:59:03] NOTE: connecting to '192.168.0.104': 192.168.0.104:24800

[2017-06-08T12:59:04] ERROR: server refused client with name "ARTH-HOMEPC"

[2017-06-08T12:59:04] WARNING: failed to connect to server: server refused client with our name

[2017-06-08T12:59:05] NOTE: connecting to '192.168.0.104': 192.168.0.104:24800

[2017-06-08T12:59:05] ERROR: server refused client with name "ARTH-HOMEPC"

[2017-06-08T12:59:05] WARNING: failed to connect to server: server refused client with our name

[2017-06-08T12:59:06] NOTE: connecting to '192.168.0.104': 192.168.0.104:24800

[2017-06-08T12:59:06] ERROR: server refused client with name "ARTH-HOMEPC"

[2017-06-08T12:59:06] WARNING: failed to connect to server: server refused client with our name

[2017-06-08T12:59:07] NOTE: connecting to '192.168.0.104': 192.168.0.104:24800

 

Share this post


Link to post
Share on other sites

@Paul Suarez 

Thanks so much for your help thus far. I've actually fixed the issue myself. I didn't realize that I had to drag and drop a new monitor in the icon. Once I did that and named it as the same screen name as my client it works with both SSL and unencrypted. 

Thanks again for your help! I'm loving Synergy already!

Share this post


Link to post
Share on other sites

Thanks for the update too @asuthar. I was about to tell you that. But it seems that you got it first. :D

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now