DrPrizza

Can not get inital connection to work

8 posts in this topic

Hello! Trying to set up Synergy for the first time. I want to use my desktop PC as my server and my MacBook Pro as the client. I have installe synergy on both devises, tried to connect using autoconfig and manual entry of IP addresses. I got as far as the server acknowledging that a client wanted to connect. I assigend the macbook to a slot but when they try to connect the server keeps giving "WARNING: failed to connect to server; Connection was refused." As I stated this message is coming from the desktop that is check boxed for server configuration. The Client MacBook states "WARNING: failed to connect to serve: Timed out." I added Synergy to all firewall exceptions on my MacBook. The PC Firewall also has the all exceptions noted for synergy both inbound and outbound. What am I doing wrong and how can I get these to connect?

 

Thanks!

Share this post


Link to post
Share on other sites

Please provide more details about your machines (OS, 32/64 bit, Synergy version installed, connected to the network via Ethernet or Wi-Fi, specify which one is the server). Also, post a screenshot of both machine's Synergy interface and the Server Configuration interface on your server machine.

Share this post


Link to post
Share on other sites

Of course!

 

Mac OS X El Capitan 10.11.6

Windows 10

Both computers are WiFi

 

Thank You for your help!

Screen Shot 2017-06-07 at 8.17.16 PM.png

Synergy Creenshot.PNG

Share this post


Link to post
Share on other sites

Sorry for the late reply @DrPrizza. Screenshot shows that the client machine doesn't use SSL while the server has SSL turned on. To fix this, you may turn turn on client's SSL or turn off server's SSL.

  1. Click the Edit menu
  2. Click the Settings menu item
  3. Either check or uncheck SSL
  4. Make sure it's the same on both machines

Steps also in SSL generic failure knowledge base article. Let us know how it goes. ;)

Share this post


Link to post
Share on other sites

Tbanks for helping Paul! When I opened the settings both boxes for SSL on the client and server were checked. I tried unchecking them both and could not connect then tried rechecking both boxes and trying again without success. Now the prompts that I get are as shown below and I am still unable to connect.

 

 

Screen Shot 2017-06-08 at 7.53.20 PM.png

Synergy second.PNG

Share this post


Link to post
Share on other sites

It's weird that your server is trying to connect to 0.17 when in fact it is the 0.17. Can you click on Edit and click Settings on your server machine? Then post a screenshot of that interface it'll open.

Share this post


Link to post
Share on other sites

Can you try switching that in to a client first then uncheck the auto config. After that, switch it back as a server and try connecting again.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now