tilted

Numpad issues

26 posts in this topic

Numpad hotkeys are showing up as normal 1-0 keys when using them for keybindings.

 

I've tried 1.8 and 1.9, issue is still there.

 

Any insight ?

Share this post


Link to post
Share on other sites

Is it happening on both server and client(s) machines? If so, which machine has a keyboard with a numpad?

Share this post


Link to post
Share on other sites

I've not tried it on the client, only on the server. 

 

I got this to work by editing the config manually, but when you're interactively trying to configure it shows up as basic 1-0 instead of kp_*

I would really like to use alt+kp_#, but when I try this the program doesn't recognize anything is being pushed.

Share this post


Link to post
Share on other sites

So you are using the native keyboard and mouse connected on that same machine(server)? Does that happen when you're not using Synergy?

Share this post


Link to post
Share on other sites

My keyboard and mouse are hooked up to my server box yes, and no this does not happen when I'm not using synergy. My numpad works just fine.

Share this post


Link to post
Share on other sites

What do you mean 'locality' I don't see that setting? If you're referring to the 'location' of where my boxes are, they are both here in front of me. Server is set to server, client is set to client. How do I get it to accept alt+keypad commands?

Share this post


Link to post
Share on other sites

What I meant was the keyboard layout set on each machine. Also, when your numpad doesn't work while using Synergy, have you tried pressing the NumLock key if it makes any difference?

Share this post


Link to post
Share on other sites

Here's my config

section: screens
    streambox:
        halfDuplexCapsLock = false
        halfDuplexNumLock = false
        halfDuplexScrollLock = false
        xtestIsXineramaUnaware = false
        switchCorners = none 
        switchCornerSize = 0
    GlaDOS:
        halfDuplexCapsLock = false
        halfDuplexNumLock = false
        halfDuplexScrollLock = false
        xtestIsXineramaUnaware = false
        switchCorners = none 
        switchCornerSize = 0
end


section: aliases
end

section: links
    streambox:
    GlaDOS:
end

section: options
    relativeMouseMoves = false
    screenSaverSync = false
    win32KeepForeground = false
    clipboardSharing = true
    switchCorners = none 
    switchCornerSize = 0
    keystroke(Alt+Up) = switchToScreen(streambox)
    keystroke(Alt+Down) = switchToScreen(GlaDOS)
    keystroke(Alt+KP_1) = keystroke(F11,streambox)
    keystroke(Alt+KP_2) = keystroke(F10,streambox)
    keystroke(Alt+KP_3) = keystroke(F12,streambox)
    keystroke(Alt+KP_7) = keystroke(F7,streambox)
    keystroke(Alt+KP_8) = keystroke(F8,streambox)
    keystroke(Alt+KP_9) = keystroke(F6,streambox)

end

Edited by tilted

Share this post


Link to post
Share on other sites

Please provide more details about your machines (OS, 32/64 bit, Synergy version installed, connected to the network via Ethernet or Wi-Fi, specify which one is the server).

Share this post


Link to post
Share on other sites

Both are running Windows 10.1 x64 and are connected via ethernet. 

Server: 1.9.0-rc3 (I changed versions to try and fix the issue, it was running 1.8.7-stable before)

Client: 1.8.7-stable

Share this post


Link to post
Share on other sites
18 hours ago, tilted said:

Both are running Windows 10.1

What version of Windows 10.1? 

Have you tried using v1.8.8 on both? If so, please try using v1.9 on both and check if it does the same thing.

Share this post


Link to post
Share on other sites

1703 (OS Build 15063.413)

It's as if I'm never even pressing a button, the logs on the server never show anything being pressed or sent.

Share this post


Link to post
Share on other sites
24 minutes ago, tilted said:

1703 (OS Build 15063.413)

It's as if I'm never even pressing a button, the logs on the server never show anything being pressed or sent.

Is this even when both machine's logging level are set to debug1 or debug2?

Also, as shown on your configuration, you're using Streambox. Which Streambox product are you using? Are you trying to send the hotkeys to control a Streambox product?

Share this post


Link to post
Share on other sites

When I turn on debugging it shows the button being pressed on the server, but nothing is being sent to the client.

I should also state that I use alt+up / alt+down no problem. It's just alt + any KP number that doesn't work.

I updated the client to 1.9.0-rc3 and it's still happening.

Share this post


Link to post
Share on other sites

[2017-06-29T14:39:06] DEBUG1: onKeyDown id=61417 mask=0x0004 button=0x0038

[2017-06-29T14:39:06] DEBUG1: hook: 0x00000024 0x20470001

[2017-06-29T14:39:06] DEBUG1: hook: 0x00000024 0xa0470001

[2017-06-29T14:39:06] DEBUG1: hook: 0x00000024 0x20470001

[2017-06-29T14:39:06] DEBUG1: hook: 0x00000024 0xa0470001

[2017-06-29T14:39:07] DEBUG1: hook: 0x00000024 0x20470001

[2017-06-29T14:39:07] DEBUG1: hook: 0x00000024 0xa0470001

[2017-06-29T14:39:07] DEBUG1: hook: 0x00000024 0x20470001

[2017-06-29T14:39:07] DEBUG1: hook: 0x00000024 0xa0470001

[2017-06-29T14:39:07] DEBUG1: hook: 0x000000a4 0x80380001

[2017-06-29T14:39:07] DEBUG1: hook: 0x060000a4 0x80380001

[2017-06-29T14:39:07] DEBUG1: hook: 0x070000a4 0x80380001

[2017-06-29T14:39:07] DEBUG1: event: Key char=0, vk=0xa4, nagr=0, lParam=0x80380001

This is what I get when trying to type Alt + any keypad number from my server. 

Share this post


Link to post
Share on other sites

When I try interactively configuring the server and creating a hot key that uses any numpad key it's registered as a normal number 1-0 -- Ex: keystroke(Alt+Control+7) instead of alt+control+kp_7

Edited by tilted

Share this post


Link to post
Share on other sites

Looks like it may be trying to type some alt + KP character? ex: alt+151 = ù ??

Share this post


Link to post
Share on other sites

Are those machines, both desktops? What keyboard layouts do you have on each machine(mechanical and virtual)? I apologize for the delayed replies on this. I am actually trying to reproduce the same thing on my end, thus the delay on my replies.

Share this post


Link to post
Share on other sites

They're both desktops, yes... and keyboard layout I already answered above, they're both running ENG. 

Share this post


Link to post
Share on other sites

How about using the regular numbers on top @tilted? Can we try that? Starting from setting the hotkeys and actually performing the hotkeys.

Share this post


Link to post
Share on other sites

After digging deeper on this issue @tilted, I found out that there's an existing open issue in GitHub for this. This is still being worked on by our developers. 

Server hotkey sets non-numpad key with numpad input #4326

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now