Valdemar

ERROR: ipc connection error, remote host closed

45 posts in this topic

Can't connect at all, and it gives me this error message: ERROR: ipc connection error, remote host closed

System information and so on is in this thread, where I had one problem that was fixed, a new problem appeared and I have been waiting for help on that one for a good 10 days now.

 

Share this post


Link to post
Share on other sites

Please provide more details about your machines (OS, 32/64 bit, Synergy version installed, connected to the network via Ethernet or Wi-Fi, specify which one is the server). Also, post a screenshot of both machine's Synergy interface and the Server Configuration interface on your server machine.

Share this post


Link to post
Share on other sites

The server is running windows 10 (Home) 64 bit on synergy v1.9.0. The client is running macOS  Sierra 10.12.4 with synergy  version 1.8.8. They are both on WiFi. 

server.PNG

Share this post


Link to post
Share on other sites
12 minutes ago, Paul Suarez said:

Please provide more details about your machines (OS, 32/64 bit, Synergy version installed, connected to the network via Ethernet or Wi-Fi, specify which one is the server). Also, post a screenshot of both machine's Synergy interface and the Server Configuration interface on your server machine.

 

Share this post


Link to post
Share on other sites

That machine is on 192.168.1.x network but it's connecting to a machine which is on 192.168.137.x network. That could only be done if the gateway/router that they are connected to is configured to let those subnets communicate with each other.

Share this post


Link to post
Share on other sites
3 minutes ago, Paul Suarez said:

That machine is on 192.168.1.x network but it's connecting to a machine which is on 192.168.137.x network. That could only be done if the gateway/router that they are connected to is configured to let those subnets communicate with each other.

Okay, what do I do about it?

Share this post


Link to post
Share on other sites

Have them on the same network. You need to make sure that they are connected on the same network. If you're on a work network, you need to contact your network administrator or if you have an IT department.

Share this post


Link to post
Share on other sites
6 hours ago, Paul Suarez said:

Have them on the same network. You need to make sure that they are connected on the same network. If you're on a work network, you need to contact your network administrator or if you have an IT department.

They are on the same network. I'm not really into the whole configuring network thing. But it seems to me that my pc (the server) is on 192.168.1.x network and synergy isn't picking that up. I've taken some screen shots of everything I thought looked useful. And it should show that they are indeed on the same network. I've also taken a picture of my router. I live in a share house, so it's limited what I can do about the router. 

 

internet 2.PNG

internet 3.PNG

internet.PNG

Screen Shot 2017-06-03 at 11.15.21.png

Screen Shot 2017-06-03 at 11.15.28.png

Share this post


Link to post
Share on other sites
7 hours ago, Paul Suarez said:

Have them on the same network. You need to make sure that they are connected on the same network. If you're on a work network, you need to contact your network administrator or if you have an IT department.

 

Share this post


Link to post
Share on other sites

It's actually your server machine that doesn't try to communicate on that network. It communicates on the 192.168.137.x network. What you can do is to disable any other network adapters on your server machine first and connect Synergy. After it connects, you can re-enable the other network adapters you need.

Share this post


Link to post
Share on other sites
2 hours ago, Paul Suarez said:

It's actually your server machine that doesn't try to communicate on that network. It communicates on the 192.168.137.x network. What you can do is to disable any other network adapters on your server machine first and connect Synergy. After it connects, you can re-enable the other network adapters you need.

How would one go about doing that? 

Share this post


Link to post
Share on other sites
12 hours ago, Paul Suarez said:

It's actually your server machine that doesn't try to communicate on that network. It communicates on the 192.168.137.x network. What you can do is to disable any other network adapters on your server machine first and connect Synergy. After it connects, you can re-enable the other network adapters you need.

Okay google was of use. I've turned of a network adaptor, so now it is in 192.168.1.x. But it just gives me a new error: ERROR: ipc connection error, remote host closed

I also tried flipping what is server and what is client again (the PC HAVE to be the server in my final setup, I did it just to see what happens). Now the mac recognises the PC, and it shows up in configuration, but besides that it doesn't work and it gives of a lot of error massages on the PC side.

 

Capture.PNG

Capture1.PNG

Share this post


Link to post
Share on other sites
1 hour ago, Paul Suarez said:

IP on your Mac is hidden.

IP on my Mac is hidden? How would that have happened. I've never done anything to hid it, and wouldn't that fuck up a bunch of functions if I did?

But Paul, couldn't you do me a Giant giant favour. Tell me how I fix my problems straight away and not only what is wrong. I clearly can't fix this on my own and it is sort of tiring to spend hours googling everything when you could just tell me.

Share this post


Link to post
Share on other sites
1 hour ago, Paul Suarez said:

IP on your Mac is hidden.

I also live in Australia, so I'm asleep when ever you are actually answering back. That means one message back and forth a day, would be nice if you could make it count. That is of course with the exceptions of the few times I've stayed up to 4am, in a desperate attempt to fix the faulty program I've payed money for. 

Share this post


Link to post
Share on other sites

Hey @Valdemar. What I meant was the IP address of your mac is hidden when you took a screenshot. I'd love to help you with it, as long as I can see everything I need to diagnose the problem.

Share this post


Link to post
Share on other sites
14 hours ago, Paul Suarez said:

Hey @Valdemar. What I meant was the IP address of your mac is hidden when you took a screenshot. I'd love to help you with it, as long as I can see everything I need to diagnose the problem.

Here. 

Screen Shot 2017-06-08 at 23.01.39.png

Share this post


Link to post
Share on other sites

On your Windows machine please click on Help on top and click About Synergy. Post a screenshot of it.

Share this post


Link to post
Share on other sites
21 hours ago, Paul Suarez said:

On your Windows machine please click on Help on top and click About Synergy. Post a screenshot of it.

 

Capture.PNG

Share this post


Link to post
Share on other sites

@Valdemar Click Edit and click Settings on your Windows machine and post a screenshot of it. I just need to check something on that interface. Hopefully this will be the last screenshot I'll need to ask from you.

Share this post


Link to post
Share on other sites
13 minutes ago, Paul Suarez said:

@Valdemar Click Edit and click Settings on your Windows machine and post a screenshot of it. I just need to check something on that interface. Hopefully this will be the last screenshot I'll need to ask from you.

As many screenshots as needed, as long as what I need to do is clear I'm fine.

 

Share this post


Link to post
Share on other sites
6 minutes ago, Paul Suarez said:

What did you do to have this drop-down @Valdemar?

autoconfig-weird.JPG.ada08c84bd778dad4a11677a9a8211b1.JPG

I don't know, it wasn't something I was trying to do, and it isn't there now. I didn't notice it before you pointed it out right now

Edited by Valdemar

Share this post


Link to post
Share on other sites

Also when I just opened synergy and tried to connect it gave me the error: ERROR: ipc connection error, code=7
I stopped it, tried again and then it gave me the error from before: ERROR: ipc connection error, remote host closed

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now