15 posts in this topic

Hey, i got two computers running windows 10, one stationary and one surface pro 4. I got synergy working perfectly yesterday, but upon launching it today the host (stationary computer) gives these messages ;

INFO: watchdog status: error

INFO: starting server

INFO: config file: C:/Users/MAXIMI~1/AppData/Local/Temp/qt_temp.gq9672

INFO: log level: INFO

ERROR: ipc connection error, remote host closed

INFO: watchdog status: error

 

I have tried reinstalling the program and restarting the computer and messed with port setting and such, but to no avail! The strange thing is nothing else on the computers has changed from when it was working just 24 hours ago. Wondering how i could get rid of this problem! 

Share this post


Link to post
Share on other sites

Please post a screenshot of both machine's Synergy interface and the Server Configuration interface on your server machine.

Share this post


Link to post
Share on other sites

Here is the server screen;

synergyproblemhost.thumb.png.cab1ac4dc72df1ecbe9329a4c08df826.png

Server screen with configuration up (hope this was right)

synergyproblemhost2.thumb.png.744347e9a6c2a5e6fee696fbc28202a3.png

and finally the screen of my client (surface pro4) intentionally stopped it btw

synergyproblem.thumb.png.38ebdc7601325d78ca27944624032fb4.png

i hope its ok that the ip shows? if i could face security risks please notify me :)

 

Share this post


Link to post
Share on other sites
52 minutes ago, Paul Suarez said:

Please post a screenshot of both machine's Synergy interface and the Server Configuration interface on your server machine.

Didn't know if i had to do the "quote" thing to make you see it, so doing that now, actual reply is over this one ^

 

Share this post


Link to post
Share on other sites

Can you check if Synergy service is running on your server machine? For the IP address, those are private IP addresses from routers. I actually have the same IP address pool myself. That would not be a a security risk.;)

Share this post


Link to post
Share on other sites
16 minutes ago, Paul Suarez said:

Can you check if Synergy service is running on your server machine? For the IP address, those are private IP addresses from routers. I actually have the same IP address pool myself. That would not be a a security risk.;)

yeah, ive checked and tried restarting the services too, on both machines that is! I also tried flipping it around and using the stationary computer as a client and the surface as a server, but the same issue persists even when flipping the roles! 

Share this post


Link to post
Share on other sites

Hey @MaximilianLS! I think I got a better view of your concern now.

multinetworkadapter.JPG.b9134d031fe69e81a5bdf6543985962f.JPGIf you can see on the IP address part, you have two sets of IP address. One is an invalid IP address (169.254.x.x) and the other one which is valid (192.168.0.12)

Since the other IP address is invalid, there's a possibility that the server machine is trying to look for your client machine on that invalid network.

One better proof of that is the invalid IP address populated on the Server IP box as well which is 169.254.x.x.

Now, do this to force your machines to skip or not use that invalid IP address anymore. On your machines go to Network and Sharing Center> Change Adapter settings> Right click on those network adapters that you're not using and hit Disable. After that, restart your Synergy interface. Do the same steps on both.

Let me know how it goes. ^_^

Share this post


Link to post
Share on other sites
11 minutes ago, Paul Suarez said:

Hey @MaximilianLS! I think I got a better view of your concern now.

multinetworkadapter.JPG.b9134d031fe69e81a5bdf6543985962f.JPGIf you can see on the IP address part, you have two sets of IP address. One is an invalid IP address (169.254.x.x) and the other one which is valid (192.168.0.12)

Since the other IP address is invalid, there's a possibility that the server machine is trying to look for your client machine on that invalid network.

One better proof of that is the invalid IP address populated on the Server IP box as well which is 169.254.x.x.

Now, do this to force your machines to skip or not use that invalid IP address anymore. On your machines go to Network and Sharing Center> Change Adapter settings> Right click on those network adapters that you're not using and hit Disable. After that, restart your Synergy interface. Do the same steps on both.

Let me know how it goes. ^_^

I've looked over the adapters, and all the extra ones (hamachi and ethernet)are already disabled unfortunatly. Now the app wont open and says "this application has requested the Runtime to terminate it in an unusual way. please contact the application's support team for more information!

Share this post


Link to post
Share on other sites

What network adapter have you left enabled then?

Share this post


Link to post
Share on other sites
4 minutes ago, Paul Suarez said:

What network adapter have you left enabled then?

ASUS PCE-AC56 802.11ac Network Adapter is its name, and it says "Wi-Fi 3" under adapter name. 

Share this post


Link to post
Share on other sites

Are you running Windows 10 on that machine?

Share this post


Link to post
Share on other sites

 

15 minutes ago, Paul Suarez said:

Are you running Windows 10 on that machine?

yeah, running win10 on both the client and the server! It worked just yesterday, and i did not fiddle with the settings after it started working, so i dont understand what changed

Share this post


Link to post
Share on other sites

If you go to Windows 10 settings> Network & Internet> Status, you'll find an option to do a Network reset. Please do that network reset. After pressing that, your machine will reboot after 5 minutes. Please be advised that it'll wipe any information you had to manually input for your network(s).

Share this post


Link to post
Share on other sites
48 minutes ago, Paul Suarez said:

If you go to Windows 10 settings> Network & Internet> Status, you'll find an option to do a Network reset. Please do that network reset. After pressing that, your machine will reboot after 5 minutes. Please be advised that it'll wipe any information you had to manually input for your network(s).

i did a sfc /scannow in cmd and that seems to have fixed the problem! Thanks for the help anyways, impressed with both the program and now the customer service! :)

Share this post


Link to post
Share on other sites

Hey @MaximilianLS. Thanks for the update and for sharing this. I must say, I am more impressed with how you handled that. ^_^

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now