Johannes Frank

Xubuntu -> Xubuntu Link issue with german keyboard layout.

26 posts in this topic

Hello!
 

I have Issues with synergy when connecting from a Xubuntu 17.04 to a Xubuntu 17.04.

1) I start the host process first, then the slave process -> The synergy keyboard layout on my slaved machine is QWERTY (both the host and the slave's native keyboard are QWERTZ german so this is horribly confusing)

2) If I THEN stop and restart the Host process, the Synergy Keyboard layout on the slave switches to QWERTZ, HOWEVER it covers only US characters (i.e. no äöüß, AltGr+Q produces a "2" and no @ etc.)

I'm currently running on 1.8.7-stable-debian on the host and

1.8.8-stable-25a8cb2 on the Slave.

 

Any recommendations?

Share this post


Link to post
Share on other sites

I just updated to 1.9.0-rc3 out of curiosity, this did not fix my issue but verified my finding from my initial post: If a freshly started client connects to an already running server, the slave keyboard layout is QWERTY, whereas re-connecting a running client to a freshly started server sets the keyboard layout to QWERTZ (with the limitations as described above)

Share this post


Link to post
Share on other sites

Yep (sorry, only saw your message now). Both runing the exact same version of Synergy - 1.9.0-rc3-f987381

Share this post


Link to post
Share on other sites

Hi @Johannes Frank. Please set both machine's logging level to Debug. You can then send us a copy of the logs it'll generate when it does the same thing again.

Share this post


Link to post
Share on other sites

Ok I did the following:

Started synergy on host

Connected synergy-client to host

Moved mouse over, pressed Windows+R, entered mousepad, pressed enter, entered 'y' on the host a couple of times -> led to 'zzzz' in the client.

Then I clicked on 'Stop' and 'Start' in the synergy app on the client, using the client's mouse.

Moved the host mouse over again, pressed 'y' again a couple of times -> led to 'yyyyy' in the client.

Pressed 'ä' 'ö' 'ü' on the host -> No output on the client.

The logs can be found in the accompanying zip file

synergy-logs.7z

Share this post


Link to post
Share on other sites

I'll check with dev team on this. Please bear with us. :)

Share this post


Link to post
Share on other sites

Just for clarification (I re-read your post from wednesday) - this behavior is not something that happens "from time to time" - the behavior I described in my last comment (and have documented with logs) is 100% reproducible every single time I use Synergy. As a person that heavily depends on key-short-cuts and special characters this greatly diminishes the value of using Synergy at the moment (For every special character, I need to use the client's physical keyboard anyways, I even started having a document with all the special characters open and copying them over from there when I needed them...)

Share this post


Link to post
Share on other sites

Hi @Johannes Frank. Sorry for the late reply on this. Do you have modifier keys set? If so, what are the modifier keys for?

Also, are you connecting with SSL switched on? If so, have you tried it while SSL is switched off?

Share this post


Link to post
Share on other sites

I have no modifier keys set. In the example, I used SSL on. I will try with SSL off, bear with me (hehehe)

Share this post


Link to post
Share on other sites

Hi @Johannes Frank. Just to verify, both of your machines are using English as their language right? It's just the keyboard layout that that's De-QWERTZ, correct?

Share this post


Link to post
Share on other sites

Hey @Paul Suarez! Yes this is correct, Both Systems have en_US as System language and de_DE as Keyboard layout. Specifically "Romanian (Germany, eliminate dead keys)"

Keyboard model is "Generic 105-key (Intl) PC" in both cases.

Share this post


Link to post
Share on other sites

Key composing is deactivated on my machines (both of them).

Also note that I'm actually using Xubuntu, not Ubuntu (Same Core, different Windowmanager, XFCE4 instead of Unity).

I have many of the same tools but not all of them.

Also, I don't know if this is actually relevant, one of the machines is running compiz window manager instead of xfwm4.

Edited by Johannes Frank

Share this post


Link to post
Share on other sites

I see. Another clarification....

1 hour ago, Johannes Frank said:

Hey @Paul Suarez! Yes this is correct, Both Systems have en_US as System language and de_DE as Keyboard layout. Specifically "Romanian (Germany, eliminate dead keys)"

Keyboard model is "Generic 105-key (Intl) PC" in both cases.

The keyboard layout for both is "Romanian (Germany, eliminate dead keys)" on QWERTY keyboard. Though your actual physical keyboard is QWERTZ, right? If so, can you send us a screenshot of your keyboard layout preview on your machines and a picture of your keyboard? This is for us to better understand the issue.

Share this post


Link to post
Share on other sites

"Romanian Germany eliminate dead keys" is a QWERTZ Layout.

I don't really know what you mean with keyboard layout preview, Will  have to search for that, give me a second.

Edited by Johannes Frank

Share this post


Link to post
Share on other sites
2 hours ago, Paul Suarez said:

By the way, I found another page for key composing on Xubuntu. Though it says all versions to 14.04, I'm hoping that it could be the same thing on that version you have.

Compose key for Xubuntu with XFCE and LXDE [all versions to 14.04]

Damn I missed that post. I do not really understand what you want me to do regarding composing? Shouldn't that be unnecessary? As far as I can tell I have all composing sequences off and only use the "standard" composing (no modifier, Shift and AltGR). Using AltGR + Q (German composing for @, see photo) prints a "2" on the client machine (see one of my early posts in this thread). I did not try the level 4 modifier (Shift+AltGr), though since I never used that without synergy before I don't actually know what to expect (or what it would give you).

Bottom line is that for äöüß I don't need any modifiers since these are printed on my keyboard, work locally and do not produce any output in the synergy client if I restart the server after connecting the client.

The fact alone that I get different results after first connecting (QWERTY) and restarting the server afterwards (QWERTZ with dead special keys) shows that there must be a bug that is not really related to my setup but to the way the transfer encoding is negotiated upon connection establishing.

Share this post


Link to post
Share on other sites

I understand that @Johannes Frank. In fact there's an existing open issue on GitHub about this. I wanted to add it now but I'm seeing similar issues when I try to search it online. A lot users asking how to type umlauts have been advised about using the compose method instead.This is why I'm trying to break it down to a point that we can confidently say that it's something in Synergy that makes it not possible to execute properly. I hope you understand. I just want to make sure that it's just only when using Synergy that users get that limitation/bug. I don't want you to wait for nothing if someone else finds out that it's not something about Synergy that does it.

That being said , let me ask you other questions. When you initially installed Xubuntu 17.04, have you been able to set your default keyboard layout before setting your system encryption password?

I also found this thread - Keyboard layout changes when I unplug and re-plug external keyboard

Says there that the problem seems to be that system-wide setting sare not saved. And that using 

sudo dpkg-reconfigure keyboard-configuration

allowed him/her to set the system-wide keyboard lay-out.

Share this post


Link to post
Share on other sites
8 hours ago, Paul Suarez said:

I understand that @Johannes Frank. In fact there's an existing open issue on GitHub about this. I wanted to add it now but I'm seeing similar issues when I try to search it online. A lot users asking how to type umlauts have been advised about using the compose method instead.This is why I'm trying to break it down to a point that we can confidently say that it's something in Synergy that makes it not possible to execute properly. I hope you understand. I just want to make sure that it's just only when using Synergy that users get that limitation/bug. I don't want you to wait for nothing if someone else finds out that it's not something about Synergy that does it.

That being said , let me ask you other questions. When you initially installed Xubuntu 17.04, have you been able to set your default keyboard layout before setting your system encryption password?

I also found this thread - Keyboard layout changes when I unplug and re-plug external keyboard

Says there that the problem seems to be that system-wide setting sare not saved. And that using 

sudo dpkg-reconfigure keyboard-configuration

allowed him/her to set the system-wide keyboard lay-out.

No sweat I didn't want imply anything, just did not really understand where you were heading.

Regarding your question about keyboard layout and system encryption password I honestly do not remember. However, neither of my xubuntus are fresh installs, both of them were installed as 16.10s and then updated to 17.04.

dpkg-reconfigure keyboard-configuration brings me to a curses application in which the generic 105 key (Intl) PC keyboard is selected

 

However there is one thing I want to point out. While Synergy is running (including the issues with the keyboard), I still can use my physical keyboards just fine on both the server and the client. This means that even though I can't type äöüß on the client using the host keyboard via synergy, I still was able to type these characters on my host machine using my host keyboard and my client machine using my client keyboard.

Regarding composing umlauts like advised in the threads you found, this is going a bit off track in my opinion. This thread is not really about me not being able to print umlauts (as said, I can "easily" write these few letters using my client keyboard) but about the fact that pressing german special characters and composed keys such as AltGr+Q (@) does not create the expected outcome.

I do not know how synergy operates but I see two options

- simulating keystrokes on the keyboard already registered to X
- simulating a separate keyboard to X and sending keystrokes through that device.

If you're using alternative 1 I am fairly certain that the issue must be inside the way synergy parses the keycodes and maps them to the signals to be sent to the client keyboard driver.

If you're using alternative 2 I'm out of my depth and can't rule out that I have a configuration issue.

Share this post


Link to post
Share on other sites

Have you tried setting both machine's keyboard layout to QWERTZ German to check if it behaves more stable than having it on a QWERTY layout?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now