Flathers

Synergy Server 1.8.8 on Windows 7 crashes when installers run

4 posts in this topic

I'm running Synergy 1.8.8 server on Windows 7-64 with a 1.8.8 client on Ubuntu 16.04-64.  Everything works perfectly except when I run the installer for a new program (not the Synergy installer... anything else) in Windows.  As soon as an installer starts, "synergys.exe has stopped working" pops up.  Sure enough, I am unable to access my client system with mouse or keyboard.  I choose "close program," and within a short amount of time, the server apparently restarts itself and I am able to use Synergy normally again.

Share this post


Link to post
Share on other sites

Hi @Flathers. The closest thing that could cause that is when you set UAC settings to notify you when you install a new program. When the UAC pops-up asking if you allow the app to make changes on your computer, it stops the Synergy service. Same thing happens when your computer is locked and asks you to log-in. Currently, we haven't seen a workaround for that since it is the machine's OS security itself that triggers that.

Share this post


Link to post
Share on other sites

Hi, Paul.  It's true that the UAC message interrupts the function of Synergy.  The crash happens immediately after I dismiss the UAC dialog, regardless of whether I say yes or no.  If I disable UAC, the crash doesn't happen.  (Although it does crash when the UAC message comes up to verify that I want to disable UAC.)  So it looks like it's a conflict with UAC rather than installers.

Share this post


Link to post
Share on other sites

Exactly @Flathers. Our developers are tirelessly looking for ways on how we can prevent that from happening. I guess the question there is, would Windows OS allow a third party service be exempted from UAC's interruption? :)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now