Bernd

can't install most recent rpm on sles 11 sp1

5 posts in this topic

Hi,

we want to run synergy on a SLES 11 SP1 box, 64bit.
I downloaded the most recent version. I have installed libcrypt.so.10 which is needed by it.
But installation still fails:

===================================================================
pc56846:/mnt/idg2/SysAdmin_AG_Wurst/software_und_treiber/synergy_seamless # zypper -v in synergy-v1.8.8-stable-25a8cb2-Linux-x86_64.rpm
Verbosity: 1
Non-option program arguments: 'synergy-v1.8.8-stable-25a8cb2-Linux-x86_64.rpm'
'synergy-v1.8.8-stable-25a8cb2-Linux-x86_64.rpm' looks like an RPM file. Will try to download it.
Initializing Target
Refreshing service 'nu_novell_com'.
Retrieving: repoindex.xml [done]
Checking whether to refresh metadata for Plain RPM files cache
Checking whether to refresh metadata for SLES11-Extras
Checking whether to refresh metadata for SLES11-SP1-Pool
Checking whether to refresh metadata for SLES11-SP1-Updates
Checking whether to refresh metadata for nvidia
Loading repository data...
Reading installed packages...
Force resolution: No
Resolving package dependencies...
Force resolution: No

Problem: nothing provides libcrypto.so.10()(64bit) needed by synergy-1.8.8-1.x86_64
Solution 1: do not ask to install a solvable providing synergy = 0:1.8.8-1
Solution 2: break synergy by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c): 2
Applying solution 2
Resolving dependencies...
Resolving package dependencies...
Force resolution: No

The following NEW package is going to be installed:
synergy  1.8.8-1

The following package is not supported by its vendor:
synergy  1.8.8-1

1 new package to install.
Overall download size: 3.0 MiB. After the operation, additional 13.8 MiB will be used.
Continue? [y/n/?] (y):
committing
Retrieving package synergy-1.8.8-1.x86_64 (1/1), 3.0 MiB (13.8 MiB unpacked)
Installing: synergy-1.8.8-1 [error]
Installation of synergy-1.8.8-1 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: unpacking of archive failed: cpio: Bad magic

==========================================================================================================

There seems to be something wrong with the rpm file. I made a fresh download, same error. I tried with "rpm -iv --nodeps", same problem.

Can you please help me ?

Thanks in advance.

Bernd

 

 

Share this post


Link to post
Share on other sites

Unfortunately same problem:

=================================

zypper -v in ./Synergy-1.9.0_rc3-1.x86_64.rpm
Verbosity: 1
Non-option program arguments: './Synergy-1.9.0_rc3-1.x86_64.rpm'
'./Synergy-1.9.0_rc3-1.x86_64.rpm' looks like an RPM file. Will try to download it.
Initializing Target
Refreshing service 'nu_novell_com'.
Retrieving: repoindex.xml [done]
Checking whether to refresh metadata for Plain RPM files cache
Checking whether to refresh metadata for SLES11-Extras
Checking whether to refresh metadata for SLES11-SP1-Pool
Checking whether to refresh metadata for SLES11-SP1-Updates
Checking whether to refresh metadata for nvidia
Loading repository data...
Reading installed packages...
Force resolution: No
Resolving package dependencies...
Force resolution: No

Problem: nothing provides libcrypto.so.10()(64bit) needed by synergy-1.9.0-1.x86_64
 Solution 1: do not ask to install a solvable providing synergy = 0:1.9.0-1
 Solution 2: break synergy by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c): 2
Applying solution 2
Resolving dependencies...
Resolving package dependencies...
Force resolution: No

The following NEW package is going to be installed:
  synergy  1.9.0-1


The following package is not supported by its vendor:
  synergy  1.9.0-1


1 new package to install.
Overall download size: 609.0 KiB. After the operation, additional 2.5 MiB will be used.
Continue? [y/n/?] (y):
committing
Retrieving package synergy-1.9.0-1.x86_64 (1/1), 609.0 KiB (2.5 MiB unpacked)
Installing: synergy-1.9.0-1 [error]
Installation of synergy-1.9.0-1 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: unpacking of archive failed: cpio: Bad magic
==========================================================

There seems to be s.th. wrong with the rpm file ...

Bernd

Share this post


Link to post
Share on other sites

Maybe i should try an elder version ? SLES 11 SP1 is a bit outdated. Is there an archive for elder versions ?

Bernd

Share this post


Link to post
Share on other sites

Can you try to check #5439 open issue on GitHub first and see if any of those workaround works for your machine?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now