Alessandro Rizzo

Issues with | (pipe/bar) in putty

8 posts in this topic

I have come across an odd one to which I have found the follow [url]https://github.com/synergy/synergy/issues/3732[/url] but no resolve. The server is running on Windows 7 client is Windows 8. I'm unable to use the | symbol in a putty window (mRemoteNG to be exact) on the client. In any other window it is fine Chrome, Notepad++. The | works fine on the keyboard on the device it seems to just be with Synergy. I was looking at the following [url]https://github.com/synergy/synergy/issues/4055[/url] tried a few things but no joy. Anyone have any thoughts on this one?

Share this post


Link to post
Share on other sites
Currently, there aren't any solutions for this. Perhaps just keep following the page to see if there's any updates.

Share this post


Link to post
Share on other sites
Alessandro, does any character print when you try to use | at the server on the client in PuTTY? Nothing at all happens at the cursor? Would you mind telling us this info?: * what is the Synergy version on each system? * language setting for OS on each system involved (important to give exact name)? * language setting in Synergy on each system? * if keyboard is not designed for US-English, then what language/country? * what is the keyboard brand/model, and is there any key between left Shift and Z keys? * what version of mRemoteNG are you using? Have you checked whether this happens in PuTTY (latest version with no wrapper)? (even if you do not intend to use PuTTY, this could shed light on the source of the problem) * do you have any custom key maps (in your OSes keyboard settings or any type of keyboard manager)? * are there any non-default settings affecting keys in mRemoteNG? This might be easy to resolve with more info. - Brian

Share this post


Link to post
Share on other sites
Just to say I have this exact problem as well. Server is Windows 10 Pro, Client is Windows 10 Home. Both are running Synergy 1.7.5 64 bit. My keyboard is a UK layout, it's a Dell SK-8135. As far as I can tell both machines are set up to use "English (United Kingdom)" languages, keyboard layouts, etc... The key between left shift and Z contains backslash and pipe, that is \ normally and | when shift is applied. It may be helpful to know that when I try to type a pipe into putty on the client, Windows does give me a beep - almost as if there's a console beep generated. In fact, if I run 'cat' with no parameters inside my ssh session then type a pipe, I see the following output on the client: ^[^^ Doing the same thing on the server shows me a | as expected. I hope that's of use, anything else I can offer, please let me know. Cheers, Justin

Share this post


Link to post
Share on other sites
Hey, Would you mind telling us this info?: * what is the Synergy version on each system? 1.7.6 just updated the latest. * language setting for OS on each system involved (important to give exact name)? Both using English (United Kingdom) * language setting in Synergy on each system? English * if keyboard is not designed for US-English, then what language/country? Its a UK layout Keyboard. * what is the keyboard brand/model, and is there any key between left Shift and Z keys? Steelseries Apex Yes the key between left shift and key is the | symbol * what version of mRemoteNG are you using? Have you checked whether this happens in PuTTY (latest version with no wrapper)? (even if you do not intend to use PuTTY, this could shed light on the source of the problem) mRemoteNG is version 1.72.5064.32737 it just uses putty in it I have tried putty separately I get t he same thing. * do you have any custom key maps (in your OSes keyboard settings or any type of keyboard manager)? I do not. * are there any non-default settings affecting keys in mRemoteNG? Not that I know of. As Justin said below I do have the same windows beep when I try to do it.

Share this post


Link to post
Share on other sites
Just an update worth mentioning forget mRemoteNG this application is not the issue. This is something with putty (as mRemoteNG just pulls this into the the app) it seems if I edit say an object in the management side of mRemoteNG I can use the | symbol. Its just when I connect to a device in there it is purely in the putty window that the | does not work. Also if it use Alt + 124 this allows me to put the | symbol in the putty window. This is how I have been getting around this. Bit further information \ doesn't work in the putty window. Again using the keyboard on the device work and if I plug the Steelseries into the Device both the | and \ work. They work in a notepad it seems just in putty which is strange.

Share this post


Link to post
Share on other sites
Hi, So me and a colleague at work were looking at this morning as he is using Mac server to windows Client he had the same problem. After us playing around within putty we found an option if you turn this off so it is un ticked then the | symbol works! Under Putty > Terminal > Keyboard > "Control-Alt is diffrent from AltGr" this needs to be un ticked. This works for Mac to Windows. When I get home later I need to test with my own and see if this works windows to windows but looks promising. I attached a screenshot of the setting I'll update later with results.

Share this post


Link to post
Share on other sites
Good news for me un-ticking the Under Putty > Terminal > Keyboard > "Control-Alt is different from AltGr" Has works for Windows 10 to Windows 10. Strange it seem that in a putty session over Synergy the | acts as a Alt. Hope this helps in working out why this happens over Synergy. At least for others there is a quick fix. Now saves me using Alt + 124 when troubleshooting Juniper and Cisco devices where I use the | symbol quite a bit.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now