jblane001

"zeroconf client detected"

45 posts in this topic

Are you being humorous?  If it only has one screen on it, you can't connect a second computer.  What do you see that's wrong... that would be corrected by reconfig?  ..and what does the zeroconf message mean?  I've been answering all the questions and you're not sharing your thinking.  I want to understand what you suspect or what your thinking is.  This has gone on too long to continue very much longer.

Share this post


Link to post
Share on other sites

Just for grins, I removed the client from the config screen as you saw it in the screen shot above and re-added it according to the instructions in the link you sent.  No change.

Share this post


Link to post
Share on other sites

Hi @jblane001. Can you try to ping the server from the client machine again. By the way, the zeroconf means zero configuration. It could be the program itself can't or don't have access to the configuration or it could be a firewall that blocks the request of your client machine which is supposedly be knocking on the server machine.

Share this post


Link to post
Share on other sites

It still returns request timed out like it did the last time you asked me to do this.

Share this post


Link to post
Share on other sites

Are you using a third party firewall? If not, please check your client machine's firewall settings and verify that the firewall rules for Synergy is properly set.

Share this post


Link to post
Share on other sites

Please remove me from this thread, I've had so many mails and notifications!

Share this post


Link to post
Share on other sites
8 minutes ago, Hiten said:

Please remove me from this thread, I've had so many mails and notifications!

@Hiten you can unfollow this thread by clicking the Following/Follow button on the upper right hand side of this page just above the "Reply to this topic" button.
 

Share this post


Link to post
Share on other sites

On the client machine, I am using whatever came with Windows.

Share this post


Link to post
Share on other sites

I guess I will also ask, how should they be set?

Share this post


Link to post
Share on other sites

Okay, please go to Control Panel\All Control Panel Items\Windows Firewall\Allowed apps. Look for Synergy in the list of apps and features and put a check mark on either Public or Private (make sure that the network you are connected to right now matches the type of network you put a check mark on). You can also check both to avoid confusion but please consider the risk(s) if you do.

Share this post


Link to post
Share on other sites

You think this is a problem on the client side, not the server side?  ...just to be clear, I'm going to go try that.

 

Share this post


Link to post
Share on other sites

Synergy was enabled on the client system (for private networks) and I left it enabled.

Share this post


Link to post
Share on other sites

Okay then, let's check the server machine.

Share this post


Link to post
Share on other sites

On the server, I use AVG's firewall.  AVG shows four synergy apps: Synergy.exe and Synergyc.exe, Synergyd.exe, and Synergys.exe.  All set to all connections.

Share this post


Link to post
Share on other sites

Can you try to disable AVG temporarily and try to ping each machines from the other one?

Share this post


Link to post
Share on other sites

With AVG disabled on server, the ping from server to client worked.  Still cannot ping from client to server even with AVG off.

 

Share this post


Link to post
Share on other sites

Have you set the network it is connected to as a private network?

Share this post


Link to post
Share on other sites

No.  In Network and Sharing Center it shows this, my home network, as being public.  Where do I change that?  Also, in settings, the setting "Make this PC discoverable" is set to off (it's not discoverable).  

Share this post


Link to post
Share on other sites

OK, I figured that out on my own.  I changed the network from public to private, I'm not sure how that got set to public to begin with, and then I shut down Synergy on both systems.  I brought up the client first and then the server and now it works.  For those of you reading this thread for a solution to the "zeroconf client detected:" message, I received that message when my Windows 10 server was set to a public network instead of private.  Apparently, the public setting caused the server PC to reject all requests to connect from the client.  This was also apparent via ping, which failed from the client to the server, but worked from the server to the client, because the client had the network set as private as it should be since it's my home network.

 

Thanks Paul.  I appreciate your help.

Share this post


Link to post
Share on other sites
1 hour ago, jblane001 said:

OK, I figured that out on my own.  I changed the network from public to private, I'm not sure how that got set to public to begin with, and then I shut down Synergy on both systems.  I brought up the client first and then the server and now it works.  For those of you reading this thread for a solution to the "zeroconf client detected:" message, I received that message when my Windows 10 server was set to a public network instead of private.  Apparently, the public setting caused the server PC to reject all requests to connect from the client.  This was also apparent via ping, which failed from the client to the server, but worked from the server to the client, because the client had the network set as private as it should be since it's my home network.

 

Thanks Paul.  I appreciate your help.

You're welcome! Just want to add though, when you connect to a network it is automatically set as public. It needs you to manually change it in to a private network at your own discretion. Also, network type is not the only reason for the zeroconf error. There could be other reasons for zeroconf. In the world of computing, multiple dependencies exist. Therefore, other factors may really affect it.

Anyways, thanks for the update. ^_^

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.