ntq

Synergy 1.9 rc3 Server does not listen on port

18 posts in this topic

Hi,

I just downloaded synergy 1.9 rc3 from the General Discussion Thread for Windows and Ubuntu. I use Windows as the server and configured it like version 1.8.8 before. But it seems that after starting the server it does not open port 24800 for listening. I uninstalled and reinstalled synergy several times and also restarted Windows in between. I also deactivated my Virus scanner for testing purposes. I tried with and without ssl encryption. Nothing works. I am using Windows 7.

Here is a screenshot of the task manager, netstat and synergy itself.

 

Synergy screenshot.png

Edited by ntq
Screenshot was not working

Share this post


Link to post
Share on other sites

Please post a screenshot of your client machine's Synergy interface while it tries to connect to your server machine please.

Share this post


Link to post
Share on other sites

This will not help you. It just times out. And from the netstat command you can see that the server does not even listen on its port (24800). So every connection from an other machine to the server will time out.

Share this post


Link to post
Share on other sites
On 5/27/2017 at 5:02 AM, Paul Suarez said:

Please post a screenshot of your client machine's Synergy interface while it tries to connect to your server machine please.

 

Share this post


Link to post
Share on other sites

Are you serious? If you are a developer you know that it will not help you knowing what the client machine's interface says. It just can not connect because there is no open port to connect to. Start a client without a server and you see the same error as I see.

Please stop quoting yourself again. I am a developer myself and you can believe me with what I am saying. Even netcat is not able to connect to the server.

Thank you.

Share this post


Link to post
Share on other sites

I won't be asking for it if I don't need it @ntq. Also, I have noticed that the Synergy interface on the server does not have the confirmation that the server is started. It only has "starting server."

Share this post


Link to post
Share on other sites

I also noticed it. How can I debug that issue. At the moment I am running 1.8.8. as server on Windows 7 and 1.90 rc3 as client on Ubuntu. It seems that even DEBUG2 does not show sufficient information about the issue.

Share this post


Link to post
Share on other sites
On 5/31/2017 at 0:14 AM, Paul Suarez said:

I won't be asking for it if I don't need it @ntq. Also, I have noticed that the Synergy interface on the server does not have the confirmation that the server is started. It only has "starting server."

 

Share this post


Link to post
Share on other sites

I still do not know what this will help you. The server does not listen so it is irrelevant what the client says. It's just a timeout. Are you a developer?

Here is your log. It's exactly the same as when you don't start a server but then try to connect with a client.

[2017-06-20T10:21:24] DEBUG: starting process
[2017-06-20T10:21:24] INFO: starting client
[2017-06-20T10:21:24] INFO: command: /usr/bin/synergyc -f --no-tray --debug DEBUG --name tp-w530 --enable-crypto 192.168.1.xxx:24800
[2017-06-20T10:21:24] INFO: config file: /tmp/Synergy.h25419
[2017-06-20T10:21:24] INFO: log level: DEBUG
[2017-06-20T10:21:24] DEBUG: XOpenDisplay(":1")
[2017-06-20T10:21:24] DEBUG: xscreensaver window: 0x00000000
[2017-06-20T10:21:24] DEBUG: screen shape: 0,0 1920x1080 
[2017-06-20T10:21:24] DEBUG: window is 0x05a00004
[2017-06-20T10:21:24] DEBUG: adopting new buffer
[2017-06-20T10:21:24] DEBUG: opened display
[2017-06-20T10:21:24] NOTE: started client
[2017-06-20T10:21:24] NOTE: connecting to '192.168.1.xxx': 192.168.1.xxx:24800
[2017-06-20T10:21:24] INFO: OpenSSL 1.0.2g  1 Mar 2016
[2017-06-20T10:21:24] DEBUG: event queue is ready
[2017-06-20T10:21:40] DEBUG: retry in 1 seconds
[2017-06-20T10:21:40] WARNING: failed to connect to server: Timed out
[2017-06-20T10:21:41] NOTE: connecting to '192.168.1.xxx': 192.168.1.xxx:24800
[2017-06-20T10:21:41] INFO: OpenSSL 1.0.2g  1 Mar 2016
[2017-06-20T10:21:42] DEBUG: stopping process
[2017-06-20T10:21:42] INFO: stopping synergy desktop process
[2017-06-20T10:21:42] ERROR: process exited with error code: 9

 

Share this post


Link to post
Share on other sites

It's 1.0.2g-1ubuntu4.6. And libssl has version 1.0.2g. It works well together with the version 1.8.8. But that all does not help when the server doesn't listen on a port. Are you a developer?

Share this post


Link to post
Share on other sites

I am not a developer @ntq. But I'm working with our developers. We've tracked it down to a spinning loop in the service but we're still trying to figure out what could be causing it. We've also verified that it only happens in v1.9 and only in release mode.

Share this post


Link to post
Share on other sites

We hope so @ntq, and we hope it'll be sooner. We will be posting it here, or update the featured thread once we implement a fix for it.

Share this post


Link to post
Share on other sites

Hi Paul,

is there anything new here? At the moment I am using Synergy in version 1.8.8 and can not activate it properly because of this nasty bug: https://github.com/symless/synergy/issues/3752

But it seems that nobody of your developers care. I don't understand why I even paid for this if such simple bugs don't get fixed. I bought it and I want to able to use my licence.

Share this post


Link to post
Share on other sites

Hi @ntq. @Andrew Nelless already replied on that open issue that the bug has already been fixed with v1.9.

nlyan commented on May 25 • edited

Quote

This bug is fixed in the v1.9 release candidate builds, which are available on the forum under General Discussion

 

Share this post


Link to post
Share on other sites

Somehow I am no longer able to find the thread announcing v1.9 and the search function of the board does not help me either when searching for "1.9". Is there a new version available already?

Thank you

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now