Bgwing

Hotkey to lock both machines - Windows 10 64bit

18 posts in this topic

Is there a way to lock both computers with a single key stroke or key combination?

 

Share this post


Link to post
Share on other sites

Please provide more details about your machines (OS version, 32/64 bit, Synergy version installed).

Share this post


Link to post
Share on other sites

Windows 10 Professional 64 bit on both computers.  Active Directory Domain members.  Synergy(64 bit) is version 1.8.8-stable-25a8cb2

 

 

Share this post


Link to post
Share on other sites

For sending a CTRL+ALT+DEL to the client machine, you need to use CTRL+ALT+Pause/Break instead. That being said, you can try setting a hotkey on your Server Configuration as shown below.

lockbothmachines.JPG.c3b36be9c09c3060ebe7419b67250f53.JPG

Let me know how it goes.

Share this post


Link to post
Share on other sites

I tried CTRL-ALT-Pause and it didn't lock the client computer.  Any other suggestions?

 

Share this post


Link to post
Share on other sites

Have you tried it before adding the hotkey in the Server Configuration?

Share this post


Link to post
Share on other sites

In this case, I'd recommend the following steps: Why doesn't Ctrl+Alt+Del work on secondary screens?

If you use a Windows Vista or newer machine as a client: With the default Windows settings you can not enter a Ctrl+Alt+Del SAS (Secure Attention Sequence) over Synergy on the Windows lock screen.

You can allow this behavior by allowing Services to issue the SAS in the Windows Logon Options. These are found in the Local Group Policy Editor.

  1. Go to the Local Group Policy Editor (Type gpedit.msc in the run menu)
  2. Dig down to Computer Configuration --> Administrative Templates --> Windows Components --> Windows Logon Options
  3. Open up the Disable or enable software Secure Attention Sequence option
  4. Set it to Enabled and then select Services and Ease of Access applications below, click OK

You should now be able to issue a Ctrl+Alt+Del to Windows over Synergy while on the lock screen. Please note: Sometimes the Ctrl and Alt keys stick, so just press them each once to un-stick them.

On Windows servers, Ctrl+Alt+Del is always intercepted by Windows and is never passed to Synergy. We have implemented Ctrl+Alt+Pause/Break as a workaround, which will send a Ctrl+Alt+Del sequence across to the client. Please note that the cursor must still be moved over to the client system for this to work.

On Macbooks, the key labeled Delete is actually backspace and Ctrl+Cmd+Del won't work. However Fn+Delete actually is "Delete", so Fn+Ctrl+Cmd+Delete will act as Ctrl+Alt+Del on a windows secondary screen.

I hope this works for you! Let me know how you get on :)

Share this post


Link to post
Share on other sites

I have the individual workstations locking, but when I set up a Hot Key, Neither one works with the hot key. 

 

Capture.PNG

Edited by Bgwing

Share this post


Link to post
Share on other sites

Can you try removing the "only on these screen" option?

Share this post


Link to post
Share on other sites

I am getting a fail to register error:

 

Here are the log entries:

 

10] ERROR: failed to get desktop path, no drop target available, error=2

[2017-06-08T08:52:10] WARNING: failed to register hotkey Control+Alt+l (id=006c mask=0006)

[2017-06-08T08:52:10] NOTE: started server, waiting for clients

[2017-06-08T08:52:10] INFO: watchdog status: ok

[2017-06-08T08:52:11] NOTE: accepted client connection

[2017-06-08T08:52:11] NOTE: client "odf0369-GB" has connected

Share this post


Link to post
Share on other sites

That is the combination I chose to use to lock both computers. 

 

Share this post


Link to post
Share on other sites

Yes.  I am getting a failure to register Hot Key error.  That could be the root of the issue.  What can I do to resolve it?

Share this post


Link to post
Share on other sites

Hi @Bgwing. I found an open issue in GitHub for this. This issue should have a solution when v1.10 comes out. Please bear with us as we strive to make your Synergy experience more seamless. 

Link to #3084 open issue.

Share this post


Link to post
Share on other sites

What about the Hotkey errors I am getting?  is that normal?

 

Share this post


Link to post
Share on other sites

Hi @Bgwing. Sorry for the late reply on this. That might be due to the rules you apply for that hotkey. What rules have you added for that hotkey by the way?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now