GnaXi

Synergy not registering or remembering keypress

4 posts in this topic

Hi,

As a Scandinavian I use the following letters quite a lot: öä
To enter these on a non-Scandinavian keyboard, I have to press one key followed by either o or a, to put the two dots above the letter.

Pressing that button is apparently not always remembered or registered, when running Synergy as server.

These are my test results without Synergy running:
öööööööööööööööööööööööööööööööööööööööööööööööööööööööööööö

These are my test results with Synergy running:
ööoöööoöooooooöööööööoöooooöööoooöoöooööoööoööooöööoöoöööoöö

As you can see, it only sometimes registers me pressing the button pressed before the letter, which is very frustrating.
Any idea what could be causing this issue?

I've got Synergy running as server from another machine, where I'm not experiencing this issue, so it seems to be system specific.
And the issue is not occurring on the client connected to the affected server.

Share this post


Link to post
Share on other sites

@GnaXi. We are still currently working to improve the support for international keyboards. Please bear with us as we try to make improvement to make Synergy better for all.

Share this post


Link to post
Share on other sites

This has nothing to do with an international keyboard.
It's working fine on one setup, but not on another.

If we take a Danish keyboard:
danish-keyboard-550x183.png

You'll see that there is a key right next to the Enter key with ^"~ on it
If you press this key followed by on o, it becomes an ö and if you press it followed by an a, it will become an ä.

On one specific setup it seems to forget that i press that button before o or a. And this issue only occurs when synergy server is enabled.
This is a bug that I would highly recommend looking into, as it could happen with any other key combination as well.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now