Geoffrey Ghose

Compiling on OS X

4 posts in this topic

I’m trying to compile a Universal (including PPC) synergys binary from the 1.7.2 source. BTW I’m using Xcode 5, and the instructions for creating links in /Developer are slightly wrong, it should read cd / sudo ln -s /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer . After that woozle:/ geoff$ ls /Developer/SDKs/ MacOSX10.5.sdk MacOSX10.6.sdk MacOSX10.7.sdk MacOSX10.8.sdk MacOSX10.9.sdk So that part looks fine. But woozle:synergy-1.7.2-Source geoff$ ./hm.sh conf -g 1 --mac-sdk 10.5 --mac-identity test Mapping command: conf -> configure cmake version 3.2.2 CMake suite maintained and supported by Kitware (kitware.com/cmake). Entering dir: build/release CMake command: cmake -G "Unix Makefiles" -DCMAKE_BUILD_TYPE=Release ../.. – OSX_TARGET_MAJOR= – OSX_TARGET_MINOR= CMake Error at CMakeLists.txt:172 (message): Mac OS X target must be 10.x – Configuring incomplete, errors occurred! See also "/Users/geoff/Downloads/synergy-1.7.2-Source/build/release/CMakeFiles/CMakeOutput.log". Going back to: /Users/geoff/Downloads/synergy-1.7.2-Source Error: CMake encountered error: 256 In other words, I specified 10.5 and got the message: Mac OS X target must be 10.x Any ideas?

Share this post


Link to post
Share on other sites
[quote]CMake Error at CMakeLists.txt:172 (message): Mac OS X target must be 10.x[/quote] That conf line should work. Could you try deleting the build dir?

Share this post


Link to post
Share on other sites
[quote="Nick Bolton"][quote]CMake Error at CMakeLists.txt:172 (message): Mac OS X target must be 10.x[/quote] That conf line should work. Could you try deleting the build dir?[/quote] Yup. Deleted the build directory and got the same result. ty test Mapping command: conf -> configure Running setup... Setup complete. ....... -- Found CURL: /usr/lib/libcurl.dylib (found version "7.37.1") -- OSX_TARGET_MAJOR= -- OSX_TARGET_MINOR= CMake Error at CMakeLists.txt:172 (message): Mac OS X target must be 10.x -- Configuring incomplete, errors occurred! See also "/Users/geoff/Downloads/synergy-1.7.2-Source/build/release/CMakeFiles/CMakeOutput.log". Going back to: /Users/geoff/Downloads/synergy-1.7.2-Source Error: CMake encountered error: 256

Share this post


Link to post
Share on other sites
This is frustrating. I just commented out all the offending lines on CMakeFiles.txt and got hm.sh conf to work. But now ./hm.sh build fails: woozle:synergy-1.7.3-Source geoff$ ./hm.sh build Entering dir: build/release Scanning dependencies of target arch [ 0%] Building CXX object src/lib/arch/CMakeFiles/arch.dir/Arch.cpp.o error: unable to create target: 'No available targets are compatible with this triple, see -version for the available targets.' 1 error generated. make[2]: *** [src/lib/arch/CMakeFiles/arch.dir/Arch.cpp.o] Error 1 make[1]: *** [src/lib/arch/CMakeFiles/arch.dir/all] Error 2 make: *** [all] Error 2 Going back to: /Users/geoff/Downloads/synergy-1.7.3-Source Error: make failed: 512 All I want is a ppc build. Is there anyone out there that has a functional compiling setup that could make one for me?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now