hiphopbros

Configuration in ubuntu 16.04 and windows 10

11 posts in this topic

I purchased the pro version.

I have gui program on both OS.

Server: Ubuntu 16.04, Client: Windows 10

I put the right ips and screen names. However it is not working. I've got the error saying:"Warning: failed to connect to server: Timed out" in client. "started server, waiting for clients" in server.

Please help me.

 

Share this post


Link to post
Share on other sites

Please try this.

  1. Click the Edit menu
  2. Click the Settings menu item
  3. Uncheck SSL
  4. Make sure it's the same on both machines

Try the starting Synergy.

You can also view that on this knowledge base article.

Share this post


Link to post
Share on other sites

There has been no problem while I'm using the configuration, server for windows 10 and client for ubuntu 16.04.

As soon as I changed the configuration vice versa, the issue came out.

Share this post


Link to post
Share on other sites
Just now, Paul Suarez said:

Please try this.

  1. Click the Edit menu
  2. Click the Settings menu item
  3. Uncheck SSL
  4. Make sure it's the same on both machines

Try the starting Synergy.

You can also view that on this knowledge base article.

I paid for the SSL. Why do you say uncheck the paid options?? 

Share this post


Link to post
Share on other sites

nope. not working. The server is waiting for the client whereas the client is connecting to the server.

Share this post


Link to post
Share on other sites
2 minutes ago, hiphopbros said:

nope. not working. The server is waiting for the client whereas the client is connecting to the server.

BTW watchdog status is okay, it says, anyway.

Share this post


Link to post
Share on other sites
8 minutes ago, hiphopbros said:

I paid for the SSL. Why do you say uncheck the paid options?? 

Sorry for the confusion. That was just to check if it works without SSL enabled. 

 

9 minutes ago, hiphopbros said:

There has been no problem while I'm using the configuration, server for windows 10 and client for ubuntu 16.04.

As soon as I changed the configuration vice versa, the issue came out.

This could be an issue of trying to look for that machine on a different network. That's because I'm seeing multiple network adapters are enabled on your Windows machine. Can you try disabling all other network adapters on that machine aside from the one with 172.16.x.x address before starting Synergy? If it connects that, way you can just proceed with re-enabling the adapter you disabled.

Share this post


Link to post
Share on other sites

Network was not the issue since I put the address on it. 

I allowed the port on ubuntu by using ufw command. Then it is working now. The thing is when the configuration was vice versa there was no need to allow the port. That is the confusion came from. 

BTW would you remove the screenshot for me? I don't feel good for exposing my addresses. please. I can't find the option to delete the pic. Thanks in advance.

Share this post


Link to post
Share on other sites
9 minutes ago, hiphopbros said:

Network was not the issue since I put the address on it. 

I allowed the port on ubuntu by using ufw command. Then it is working now. The thing is when the configuration was vice versa there was no need to allow the port. That is the confusion came from. 

BTW would you remove the screenshot for me? I don't feel good for exposing my addresses. please. I can't find the option to delete the pic. Thanks in advance.

Screenshots deleted @hiphopbros. Thanks for the update by the way.:)

Share this post


Link to post
Share on other sites

 

Do you know why there was no need to allow the port when Ubuntu was the client ???

Edited by hiphopbros

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now