Kurtis Lewis

Mac Server and PC Client Issue

4 posts in this topic

I am having an issue with Synergy crashing when I use my mac as a server and my PC as a client. They connect just fine but when I move the mouse from the mac to the pc the client disconnects. Here is the system info: iMac: OSX 10.10.3 PC: Windows 7 Synergy version: 1.7.2 on both computers Here is the log from the PC (client) from starting it to it shutting down: INFO: starting new process activeDesktop:Default INFO: starting new process INFO: drag and drop enabled NOTE: started client NOTE: connecting to [IP Address] INFO: watchdog status: ok NOTE: server fingerprint: **** INFO: connected to secure socket INFO: server ssl certificate info: /CN=Synergy NOTE: connected to server INFO: entering screen INFO: leaving screen NOTE: disconnected from server NOTE: connecting to [IP Address] WARNING: failed to connect to server: Connection was refused INFO: service command updated INFO: process started but command is empty, shutting down INFO: got ipc shutdown message NOTE: stopped client INFO: process 7152 was shutdown gracefully In the system preferences - security and privacy - privacy tab synergy is listed as an app allowed to control the computer and the firewall is turned off. If anyone can provide assistance to fix this issue I would greatly appreciate it. Kurtis

Share this post


Link to post
Share on other sites
Hi Kurtis, From the log output its sounds like Synergy is trying really hard. So you have an iMac 10.10 server and Win7 client. Anything else you can tell us about your setup? Maybe screen resolution or custom network configurations? You never know what weird little thing you overlooked that someone here will catch. Let us know your - client/server screen resolutions ( iMacs are usually widesceen. Is your client also?) - wifi or wired network? From there someone should be able to offer suggestions as to why it disconnects.

Share this post


Link to post
Share on other sites
My iMac is a late 2009 27 inch model. I am not sure of the resolution. The PC is an Acer 15" model. Again, not sure what the resolution is. The network is a wireless network. Let me know if any other information is needed.

Share this post


Link to post
Share on other sites
There is a bug related to having some amount of data in the clipboard at the time you go to switch screens. If you clear your clipboard (just copy a single letter or something), does the problem still happen? Alternatively, try turning off encryption and then see if the problem still happens. You would need to turn it off on both the client and the server.

Share this post


Link to post
Share on other sites
That worked for me (clearing the clipboard). I am on Windows 7 (server) and Macbook Pro (client). Thank you!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now