Aytan72

macOS crash after sleep

22 posts in this topic

I have an issue on macOS Sierra (version 10.12.4), where Synergy crashes after the computer goes to sleep. Synergy version 1.8.8-stable-25a8cb2.

Share this post


Link to post
Share on other sites

Please provide details of both client and server machines. Specify which one is the server.

Share this post


Link to post
Share on other sites
2 hours ago, Aytan72 said:

I have an issue on macOS Sierra (version 10.12.4), where Synergy crashes after the computer goes to sleep. Synergy version 1.8.8-stable-25a8cb2.

Only the server crashes after sleep. 

Server: macOS Sierra, Version 10.12.4, iMac
Client: macOS Sierra, Version 10.12.4, MacBook Pro

Share this post


Link to post
Share on other sites
3 minutes ago, Paul Suarez said:

Is SSL turned on for both machines?

The SSL fingerprint on the server is blank, but on the client it has a value.

Share this post


Link to post
Share on other sites
3 minutes ago, Paul Suarez said:

Can you check this work around from GitHub?

I ran the one-liner and the file looks good, so it did not remove it.

Share this post


Link to post
Share on other sites
12 minutes ago, Aytan72 said:

I ran the one-liner and the file looks good, so it did not remove it.

Have you checked step 2?

Share this post


Link to post
Share on other sites
14 minutes ago, Aytan72 said:

The SSL fingerprint on the server is blank, but on the client it has a value.

Can you try connecting with SSL both turned off on each machine? Also, have you activated Synergy on your server?

Share this post


Link to post
Share on other sites
Just now, Paul Suarez said:

Can you try connecting with SSL both turned off on each machine?

How do I do that?

Share this post


Link to post
Share on other sites
  1. Click the Edit menu
  2. Click the Settings menu item
  3. Uncheck SSL
  4. Make sure it's the same on both machines

You can also view these steps from this knowledge base article.

Share this post


Link to post
Share on other sites
6 minutes ago, Paul Suarez said:
  1. Click the Edit menu
  2. Click the Settings menu item
  3. Uncheck SSL
  4. Make sure it's the same on both machines

You can also view these steps from this knowledge base article.

Apparently, I had to re-activate once I installed the 1.9 rc. After that I the SSL options was visible.

Share this post


Link to post
Share on other sites

This may not be related but there are a bunch of these errors in the log: [2017-05-15T15:54:59] WARNING: unknown quartz event type: 0x1d

I can confirm that the sleep issue only occurs using the SSL option.

Share this post


Link to post
Share on other sites

That is noted on this comment in a GitHub open issue. I'll add this scenario on that open issue. Are both machines updated to V1.9.0rc now?

Share this post


Link to post
Share on other sites
Just now, Paul Suarez said:

That is noted on this comment on a GitHub open issue. I'll add this scenario on that open issue. Are both machines updated to V1.9.0rc now?

Yes, both machines are using the same V1.9.0rc.

Share this post


Link to post
Share on other sites

I couldn't reply to this post from my computer before. I can confirm the issue with the serial key is now fixed, but everytime I use the scroll on my magic mouse I get the same warning about quartz stated by Aytan72

Share this post


Link to post
Share on other sites
18 minutes ago, aristizabal95 said:

I couldn't reply to this post from my computer before. I can confirm the issue with the serial key is now fixed, but everytime I use the scroll on my magic mouse I get the same warning about quartz stated by Aytan72

Does it prevent you from scrolling?

Share this post


Link to post
Share on other sites

Not at all, even though I do feel a subtle change on the scrolling effect on my client (Windows) as I mentioned on the github issue. I must say that my client does not have the updated version of synergy.

Share this post


Link to post
Share on other sites
4 minutes ago, aristizabal95 said:

Not at all, even though I do feel a subtle change on the scrolling effect on my client (Windows) as I mentioned on the github issue. I must say that my client does not have the updated version of synergy.

Would it be an option for you to update your client to v1.9.0?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now