Yann David

Mouse/Keyboard lock

20 posts in this topic

So I'm having this weird issue which is not really the same as all the other (from what I can tell). Client (Mac Sierra Wireless) connect correctly to Server (Windows 10 Wired) but every 10-15 seconds mouse lock (can't move it anymore), same for keyboard input. It comes back after a second or two but damn that's annoying... I've just install the 1.9.0-RC3 because one github issue stated to fix some mouse lag but my stuff still happen.

Any ideas? 

PS: I could try wiring my mac but again.. Pretty sure wireless should work and I can't run a second cable anyway.

Share this post


Link to post
Share on other sites

Can you try switching your Mac as the server and check if it still does that? Also, is it being locked while the mouse cursor is on the client's screen?

Share this post


Link to post
Share on other sites

Sorry for the delay. So I just tested and it doesn't seem to happen with MacOS being the Server (or it takes WAYYYY much time).

Share this post


Link to post
Share on other sites

Ok I think I was able to narrow it down to a precise event: Gain/Lose Focus.

When my MacOS gain focus (using alt-tab or first entering the screen from Windows) it freeze for like a second then I can type all I want until I alt-tab again or do something that makes be lose focus of my terminal.

Edited by Yann David

Share this post


Link to post
Share on other sites

Hi @Yann David. Are you running Synergy with SSL enabled? Also, are they connected to the network through Wi-Fi or wired?

Share this post


Link to post
Share on other sites

No SSL. The Windows machine is Wired and the MacOS is wireless as stated in my first post.

Share this post


Link to post
Share on other sites

My apologies @Yann David. Please set both machines to Debug1 and send us a copy of the logs it generates when you locks your mouse.

Share this post


Link to post
Share on other sites

NVM found out. I let it ran for a while but nothing came out different then when it's not locking. I'll try Debug2 I guess?

Share this post


Link to post
Share on other sites

[2017-05-12T21:08:19] DEBUG2: find neighbor on up of "Yann-D-MBP.local"

[2017-05-12T21:08:19] DEBUG2: "DESKTOP-GA115KD" is on up of "Yann-D-MBP.local" at 0.430208

[2017-05-12T21:08:19] DEBUG1: try to leave "Yann-D-MBP.local" on up

[2017-05-12T21:08:19] INFO: switch from "Yann-D-MBP.local" to "DESKTOP-GA115KD" at 2478,1074

[2017-05-12T21:08:19] DEBUG1: send leave to "Yann-D-MBP.local"

 

Ok so this happens when I do alt-tab why would alt-tab (or in that case lose focus) make Synergy think I leave the MacOS screen ?

Share this post


Link to post
Share on other sites

Can we try to change your screen names to something that does not have any special characters (@, #, %, -, etc...)?

Share this post


Link to post
Share on other sites

Tried with Windows10 and MacOS and still the same thing

Share this post


Link to post
Share on other sites

Are there any software(s) running one either of the machines? If yes, can you try it without any software(s) running?

Share this post


Link to post
Share on other sites

Nothing notable, I tried stopping my antivirus (windows) and little snitch (mac os) but other than that I have nothing outstanding.

Share this post


Link to post
Share on other sites

Can you try elevating synergy on both machines?

  1. Click Edit
  2. Click Settings
  3. Set Elevate to Always
  4. Click OK
  5. Click Apply or Start

Share this post


Link to post
Share on other sites

Can't find the Elevate option on MacOS (normal?) But with Elevate to always on Windows10 it changes nothing.

Share this post


Link to post
Share on other sites

So just to close this thread @Paul Suarez ... Yesterday I changed ISP, got a new router and BAM no more issues... So I guess the problem was my previous ISP Wifi router 

Edited by Yann David
PIng support

Share this post


Link to post
Share on other sites

Could be @Yann David. Continue using it for now and mention me here, when it occurs again(hope not though :D).

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now