sss

cannot connect - vpn subnet conflict

6 posts in this topic

Hi,

I'm trying to connect my mac client to my pc server.  pc server is currently connected to a vpn.  vpn is using same subnet as my local network.  I don't have the option of reconfiguring the network to use a different subnet.

Thanks

Share this post


Link to post
Share on other sites

@sss That'll depend on what type of VPN you are connected to. Only split-tunnel VPN supports accessing LAN while connected to it.

Share this post


Link to post
Share on other sites

It looks like traffic is being sent through vpn.  Can I create a separate connection via hardwired connection? My pc is on wireless as is my Mac.  Could I use Mac to PC over Ethernet on a different subnet and use those interfaces?

Share this post


Link to post
Share on other sites

@sss that might be possible. Can you try and test it now? If it won't work while VPN is running before starting Synergy, you can try disabling VPN first, connect Synergy and try starting VPN again.

Share this post


Link to post
Share on other sites

That worked like a charm.  For those who need this setup:

PC = server, Mac = client

Existing home network is 10.0.0.0, work network is 10.0.0.0.  Mac and PC on wifi.

I set my pc laptop's NIC to 192.168.168.1 and my Mac's NIC to 192.168.168.2.

Went to my Mac and put in 192.168.168.1 for the server IP, and voila.  I worked.

 

Share this post


Link to post
Share on other sites
12 minutes ago, sss said:

That worked like a charm.  For those who need this setup:

PC = server, Mac = client

Existing home network is 10.0.0.0, work network is 10.0.0.0.  Mac and PC on wifi.

I set my pc laptop's NIC to 192.168.168.1 and my Mac's NIC to 192.168.168.2.

Went to my Mac and put in 192.168.168.1 for the server IP, and voila.  I worked.

 

That's great to hear @sss. Did you need to disable VPN first? Or is it running while you set the machine's NIC?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now