Bernard Schendstok

Synergy on Debian 9 Stretch

16 posts in this topic

I can't get Synergy v1.8.8 (= latest) working with the pre-compiled .deb file or get it compiled for Debian 9.

If I install the .deb file and run the program, I get this error:
/usr/bin/synergys: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory

Seems that the problem is because synergy isn't compatible with the newer libssl 1.0.2 in Stretch. I tried compiling from source but also run into problems because of the ssl library.

I found multiple other topics that mention the problem also:

I do not like the "workaround" mentioned in one of the topics of installing the Debian Jessie libSSL 1.0.0 package as that might break other stuff on my system.

I did find another workaround by wrapping Synergy inside a CDE package created on Jessie (http://www.pgbovine.net/cde.html), and hence including the correct SSL library only used for running Synergy. But I would prefer a real solution that allows me to install Synergy on Debian 9 and have it available for all users. 

Do you have a solution for me?

 

Share this post


Link to post
Share on other sites

Hi @Bernard Schendstok. v1.9 is compiled for Ubuntu 16.04 LTS, and the deb files for that will be soon posted on the forum. It will work on Debian 9.

Share this post


Link to post
Share on other sites
On 09/05/2017 at 8:45 AM, Paul Suarez said:

Hi @Bernard Schendstok. v1.9 is compiled for Ubuntu 16.04 LTS, and the deb files for that will be soon posted on the forum. It will work on Debian 9.

Nice. How/where can I download the 1.9 version? I only have access to links which are pointing to a 1.8.8 version. The links for Ubuntu and Debian versions are the same.

Thanks

Share this post


Link to post
Share on other sites
7 minutes ago, Paul Suarez said:

Neither the Ubuntu one, nor the Debian one is installing on my fresh Debian stretch box.

What are my options to re-gain the control over my computer?

Salutations

Share this post


Link to post
Share on other sites
[email protected]:~$ sudo aptitude search libssl
i   libssl-dev                                                                                        - Secure Sockets Layer toolkit - development files                                                           
i A libssl-doc                                                                                        - Secure Sockets Layer toolkit - development documentation                                                   
p   libssl-ocaml                                                                                      - OCaml bindings for OpenSSL (runtime)                                                                       
v   libssl-ocaml-4e458                                                                                -                                                                                                            
p   libssl-ocaml-dev                                                                                  - OCaml bindings for OpenSSL                                                                                 
v   libssl-ocaml-dev-4e458                                                                            -                                                                                                            
p   libssl1.0-dev                                                                                     - Secure Sockets Layer toolkit - development files                                                           
i   libssl1.0.2                                                                                       - trousse à outils SSL - bibliothèques partagées                                                             
i   libssl1.1                                                                                         - trousse à outils SSL - bibliothèques partagées       


[email protected]:~$ sudo aptitude show openssl
Paquet : openssl                                        
Version : 1.1.0f-3
État: installé
Automatiquement installé: oui
Multiarchitecture : étranger
Priorité : optionnel
Section : utils
Responsable : Debian OpenSSL Team <pkg-openssl-devel@lists.alioth.debian.org>
Architecture : amd64
Taille décompressée : 1 273 k
Dépend: libc6 (>= 2.15), libssl1.1 (>= 1.1.0)
Suggère: ca-certificates
Description : boîte à outils SSL - outils de cryptographie
 Ce paquet fait partie de l'implémentation du projet SSL des protocoles cryptographiques SSL et TLS pour communiquer de façon sécurisée sur internet. 
 
 Il fournit le binaire de ligne de commande généraliste /usr/bin/openssl, utiles pour des tâches de cryptographie telles que : 
 * créer des paramètres de clés RSA, DH et DSA ; 
 * créer des certificats X.509, CSR et CRL ; 
 * calculer des empreintes numériques ; 
 * crypter et décrypter par des algorithmes de chiffrement ; 
 * tester des clients et serveurs SSL/TLS ; 
 * gérer le courriel signé par S/MIME ou crypté.
Site : https://www.openssl.org/
Étiquettes: implemented-in::c, interface::commandline, protocol::ssl, role::program, scope::utility, security::cryptography, security::integrity, use::checking

 

Edited by Ttamttam

Share this post


Link to post
Share on other sites

Are you getting an error message(s) when it fails to install?

Share this post


Link to post
Share on other sites

Here is what I tried:

$ wget https://binaries.symless.com/v1.9.0-rc3/xenial/Synergy_1.9.0~rc3_amd64.deb
$ sudo dpkg -i Synergy_1.9.0~rc3_amd64.deb 
Sélection du paquet synergy précédemment désélectionné.
(Lecture de la base de données... 171642 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de Synergy_1.9.0~rc3_amd64.deb ...
Dépaquetage de synergy (1.9.0~rc3) ...
dpkg: des problèmes de dépendances empêchent la configuration de synergy :
 synergy dépend de libssl1.0.0 (>= 1.0.0) ; cependant :
  Le paquet libssl1.0.0 n'est pas installé.
 synergy dépend de qml-module-qtquick-controls (>= 5.0.2) ; cependant :
  Le paquet qml-module-qtquick-controls n'est pas installé.
 synergy dépend de qml-module-qtquick-layouts (>= 5.0.2) ; cependant :
  Le paquet qml-module-qtquick-layouts n'est pas installé.
 synergy dépend de qml-module-qtquick-dialogs (>= 5.0.2) ; cependant :
  Le paquet qml-module-qtquick-dialogs n'est pas installé.
 synergy dépend de qml-module-qtquick2 (>= 5.0.2) ; cependant :
  Le paquet qml-module-qtquick2 n'est pas installé.

dpkg: erreur de traitement du paquet synergy (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-9) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.60) ...
Des erreurs ont été rencontrées pendant l'exécution :
 synergy

Some translations:

Quote

synergy dépend de libssl1.0.0 (>= 1.0.0) ; cependant :
  Le paquet libssl1.0.0 n'est pas installé.

means

Quote

synergy depends on libssl1.0.0 (>= 1.0.0); but:

   libssl1.0.0 package is not installed

aptitude does not have any solution to this.

Salutations

Share this post


Link to post
Share on other sites

Here is what I tried:

$ wget https://binaries.symless.com/v1.9.0-rc3/xenial/Synergy_1.9.0~rc3_amd64.deb
$ sudo dpkg -i Synergy_1.9.0~rc3_amd64.deb 
Sélection du paquet synergy précédemment désélectionné.
(Lecture de la base de données... 171642 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de Synergy_1.9.0~rc3_amd64.deb ...
Dépaquetage de synergy (1.9.0~rc3) ...
dpkg: des problèmes de dépendances empêchent la configuration de synergy :
 synergy dépend de libssl1.0.0 (>= 1.0.0) ; cependant :
  Le paquet libssl1.0.0 n'est pas installé.
 synergy dépend de qml-module-qtquick-controls (>= 5.0.2) ; cependant :
  Le paquet qml-module-qtquick-controls n'est pas installé.
 synergy dépend de qml-module-qtquick-layouts (>= 5.0.2) ; cependant :
  Le paquet qml-module-qtquick-layouts n'est pas installé.
 synergy dépend de qml-module-qtquick-dialogs (>= 5.0.2) ; cependant :
  Le paquet qml-module-qtquick-dialogs n'est pas installé.
 synergy dépend de qml-module-qtquick2 (>= 5.0.2) ; cependant :
  Le paquet qml-module-qtquick2 n'est pas installé.

dpkg: erreur de traitement du paquet synergy (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-9) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.60) ...
Des erreurs ont été rencontrées pendant l'exécution :
 synergy

Some translations:

Quote

synergy dépend de libssl1.0.0 (>= 1.0.0) ; cependant :
  Le paquet libssl1.0.0 n'est pas installé.

means

Quote

synergy depends on libssl1.0.0 (>= 1.0.0); but:

   libssl1.0.0 package is not installed

aptitude does not have any solution to this.

Salutations

Share this post


Link to post
Share on other sites

And when I try to compile from source:

Scanning dependencies of target net
[ 25%] Building CXX object src/lib/net/CMakeFiles/net.dir/IDataSocket.cpp.o
[ 26%] Building CXX object src/lib/net/CMakeFiles/net.dir/NetworkAddress.cpp.o
[ 26%] Building CXX object src/lib/net/CMakeFiles/net.dir/SecureListenSocket.cpp.o
[ 27%] Building CXX object src/lib/net/CMakeFiles/net.dir/SecureSocket.cpp.o
/home/matt/projets/synergy/src/lib/net/SecureSocket.cpp: In member function ‘void SecureSocket::showSecureCipherInfo()’:
/home/matt/projets/synergy/src/lib/net/SecureSocket.cpp:810:46: error: invalid use of incomplete type ‘SSL {aka struct ssl_st}’
  STACK_OF(SSL_CIPHER) * cStack = m_ssl->m_ssl->session->ciphers;
                                              ^~
In file included from /usr/include/openssl/crypto.h:31:0,
                 from /usr/include/openssl/comp.h:16,
                 from /usr/include/openssl/ssl.h:47,
                 from /home/matt/projets/synergy/src/lib/net/SecureSocket.cpp:27:
/usr/include/openssl/ossl_typ.h:144:16: note: forward declaration of ‘SSL {aka struct ssl_st}’
 typedef struct ssl_st SSL;
                ^~~~~~
src/lib/net/CMakeFiles/net.dir/build.make:134 : la recette pour la cible « src/lib/net/CMakeFiles/net.dir/SecureSocket.cpp.o » a échouée
make[2]: *** [src/lib/net/CMakeFiles/net.dir/SecureSocket.cpp.o] Erreur 1
CMakeFiles/Makefile2:549 : la recette pour la cible « src/lib/net/CMakeFiles/net.dir/all » a échouée
make[1]: *** [src/lib/net/CMakeFiles/net.dir/all] Erreur 2
Makefile:83 : la recette pour la cible « all » a échouée
make: *** [all] Erreur 2
Going back to: /home/matt/projets/synergy
Error: make failed: 512

 

Share this post


Link to post
Share on other sites

OK. I compiled from source. Just had to replace libssl-dev with libssl-1.0-dev package.

And now:  what is the magical invocation to produce one nice installable debian package?

Share this post


Link to post
Share on other sites

Answering to myself:

[email protected]:~/projets/synergy$ ./hm.sh package deb
Mapping command: package -> dist
Entering dir: build/deb
Command: fakeroot dpkg-deb --build synergy-master-stable-ec56ac44-Linux-x86_64
dpkg-deb: building package 'synergy' in 'synergy-master-stable-ec56ac44-Linux-x86_64.deb'.
Command: lintian synergy-master-stable-ec56ac44-Linux-x86_64.deb
W: synergy: package-contains-timestamped-gzip usr/share/doc/synergy/changelog.gz
W: synergy: binary-without-manpage usr/bin/synergy
W: synergy: binary-without-manpage usr/bin/synergyc
W: synergy: binary-without-manpage usr/bin/synergyd
W: synergy: binary-without-manpage ... use --no-tag-display-limit to see all (or pipe to a file/program)
Moving *.deb to ../../bin/synergy-master-stable-ec56ac44-Linux-x86_64.deb
Going back to: /home/matt/projets/synergy
[email protected]:~/projets/synergy$ cd bin
[email protected]:~/projets/synergy/bin$ ls
integtests  synergy  synergyc  synergyd  synergy-master-stable-ec56ac44-Linux-x86_64.deb  synergys  syntool  unittests  usynergy
[email protected]:~/projets/synergy/bin$ sudo dpkg -i synergy-master-stable-ec56ac44-Linux-x86_64.deb 
[sudo] Mot de passe de matt : 
Sélection du paquet synergy précédemment désélectionné.
(Lecture de la base de données... 188670 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de synergy-master-stable-ec56ac44-Linux-x86_64.deb ...
Dépaquetage de synergy (1.8.8) ...
Paramétrage de synergy (1.8.8) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-9) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.60) ...
[email protected]:~/projets/synergy/bin$ 

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now