Brian Chandler

Constantly losing connection to Mac

8 posts in this topic

After the last two releases (through 1.7.3), I'm constantly losing the connection to my Mac. It may also be related to the Pro version. My Mac is located to the right of my PC, and regularly when I move my mouse over to the Mac, it jumps back to the left side of my PC screen. I seem to have control of the Mac for a split second, then I lose it. I also then can't control my Mac from the Mac because the mouse cursor disappears. I also noticed that everytime I move my mouse to my Mac, the following information cycles in the log: NOTE: server fingerprint: <FINGERPRINT INFO> INFO: connected to secure socket INFO: server ssl certificate info: /CN=Synergy WARNING: cursor may not be visible NOTE: connected to server I never had these types of problems previous to the last two releases and my upgrade to Pro. I'd appreciate any help as Synergy isn't responding to my tech support requests.

Share this post


Link to post
Share on other sites
I have a similar problem and it is a big issue. I recently migrated to a new laptop from an older model and synergy worked out of the box, but is now dropping connection several times a day. When I look on the mac (which takes several steps and is a major PITA, it indicates that Synergy is not running. I click Start and I'm back on my way, but it drops again ..... a few minutes later.

Share this post


Link to post
Share on other sites
Same problem here after updating to 1.7.2 on both computers running 10.10.3. The log reports that they are connected, but once moving the mouse from server to client, the app reports disconnection and immediate reconnection. I tried downgraded, but had no luck even with restarts. Please fix or advise on what other information is needed to resolve. The app is no longer functional for me.

Share this post


Link to post
Share on other sites
I'm adding more info so Nick or someone can assist. Here is log snipit from OS X (10.10.3) Synergy 1.7.2: NOTE: disconnected from server NOTE: connecting to '192.168.89.186': 192.168.89.186:24800 NOTE: server fingerprint: 94:A9:BF:AF:8A:75:85:48:61:8B:54:03:EC:5F:84:1E:88:AD:92:DF INFO: connected to secure socket INFO: server ssl certificate info: /CN=Synergy WARNING: cursor may not be visible NOTE: connected to server INFO: entering screen WARNING: cursor may not be visible INFO: leaving screen INFO: entering screen INFO: leaving screen WARNING: cursor may not be visible WARNING: cursor may not be visible NOTE: disconnected from server NOTE: connecting to '192.168.89.186': 192.168.89.186:24800 NOTE: server fingerprint: 94:A9:BF:AF:8A:75:85:48:61:8B:54:03:EC:5F:84:1E:88:AD:92:DF INFO: connected to secure socket INFO: server ssl certificate info: /CN=Synergy NOTE: stopping synergy desktop process NOTE: starting client NOTE: config file: /var/folders/xc/w9jttq3x1qb5296y2n2mtt6m0000gn/T/Synergy.BM1506 NOTE: log level: INFO INFO: drag and drop enabled NOTE: started client NOTE: connecting to '192.168.89.186': 192.168.89.186:24800 NOTE: server fingerprint: 94:A9:BF:AF:8A:75:85:48:61:8B:54:03:EC:5F:84:1E:88:AD:92:DF 2015-05-14 09:09:45.389 synergyc[7734:665585] starting cocoa loop INFO: connected to secure socket INFO: server ssl certificate info: /CN=Synergy WARNING: cursor may not be visible NOTE: connected to server INFO: entering screen INFO: leaving screen INFO: entering screen INFO: leaving screen WARNING: cursor may not be visible Here is snipit from Server (latest ubuntu also running 1.7.2): INFO: switch from "Macbook" to "zippy-ssd" at 1,704 INFO: entering screen NOTE: client "MacBook" has disconnected NOTE: accepted client connection INFO: accepted secure socket NOTE: client "Macbook" has connected As my laptop is often closed and i'm using an external monitor every time it drops a connection I have to open laptop (which is not as easy as it sounds as it's not on top of the desk in front of me), then use the local mouse to click "Start" in the Synergy GUI, then close laptop and put it back in the drawer.

Share this post


Link to post
Share on other sites
Im having the same issue. My server is a Mac and client is Ubuntu. The moment I move the mouse to ubuntu, Synergy disconnects with this error on the server: [quote]ERROR: s[/quote]

Share this post


Link to post
Share on other sites
I solved this issue by turning off SSL, which is fine for me on my home network. However, if you are on a public network or even in an office environment, I would be afraid of plain text passwords if this is the case.

Share this post


Link to post
Share on other sites
I had this same issue; I would lose my connection whenever I moved my mouse from master to slave. Restart fixed it temporarily, but it came back. Turning off SSL seems to have fixed the issue.

Share this post


Link to post
Share on other sites
Just confirming the same problem -- and solution -- here with 1.7.2 Pro. Moving from PC (server) to Mac (client) would cause a momentary disconnection, causing my mouse cursor to bounce back to the center of my PC's screen. Turning off SSL on both boxes appears to have fixed it.

Share this post


Link to post
Share on other sites
Also confirming SSL issue and solution, using version 1.7.3 on Mac OSX 10.9.5

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now