SimonG

Mouse off-screen on windows client

3 posts in this topic

Hi, I am using Synergy with Ubuntu server and Windows client; I have dual screens on the Windows client. It works great for the most part, however there is a weirdness around the second Windows screen.

Screen layout is per attached image. Two issues:

  1. When I move the mouse to the top of screen 2, the cursor stays at the top of the screen however the mouse pointer has evidently gone higher because the cursor does not move until I move the mouse back down into the screen region. Horizontally this aligns with the top of screen 1.
  2. When I move the mouse to the bottom of screen 2, the cursor disappears off the bottom of the screen and I lose it until I move the mouse back up into the screen region. Horizontally this aligns with the bottom of screen 1, which is odd because the windows layout has screen 2 below screen 1.

Same behaviour if 'Use relative mouse moves' is enabled. Not sure whether it might be related to the scaling setting?

Everything works fine as long as I am pointing to part of the screen that I can see, more of an annoyance and wondering whether it might be fixable.

Any ideas?

synergy-screens.png

Share this post


Link to post
Share on other sites

Hi SimonG. We currently don't support this feature. Although it is onĀ our road map. There is an open GitHub issue for this specific problem.

Share this post


Link to post
Share on other sites

Thanks Paul, yep that's the issue. Would love to see a fix. I'll leave it with you!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now