Kevin Buterbaugh

Client can't connect because "already" connected

2 posts in this topic

Running Synergy 1.7.2 with an iMac as my Synergy server and a 13" Retina MBP as my client (both of which are running 10.10.3). Everything was working fine yesterday but today when the I start the client it fails to connect: NOTE: starting client NOTE: config file: /var/folders/d3/d8hgwzp52k39j_g0hxsx6rtm0000gn/T/Synergy.L13231 NOTE: log level: INFO 2015-05-13 17:21:54.816 synergyc[13238:324148] starting cocoa loop INFO: drag and drop enabled NOTE: started client NOTE: connecting to <IP's removed but were correct> NOTE: server fingerprint: 4D:17:5D:CD:B4:9C:BA:2F:77:84:7F:B2:59:AC:B9:5F:11:74:E0:40 INFO: connected to secure socket INFO: server ssl certificate info: /CN=Synergy ERROR: server already has a connected client with name "obscured.fqdn.com" WARNING: failed to connect to server: server already has a connected client with our name The server is throwing warnings that "a client with name "Laptop" is already connected". I've tried stopping and restarting Synergy on both. I've even rebooted both. Nothing helps. Any advice is appreciated. Thanks... Kevin

Share this post


Link to post
Share on other sites
Hi Kevin, Many users are experiencing problems with our new SSL feature. We are furiously working away on a bug fix release, which we plan to have ready by May 27th. You can track our progress here: https://github.com/synergy/synergy/mile ... 7.3-stable In the meantime, you can try any 1 of 3 workarounds: 1. Downgrade to 1.6 2. Delete the ns.dll plugin 3. Disable SSL from settings Thanks, Nick

Share this post


Link to post
Share on other sites
All, OK, I solved my own problem ... which is appropriate since I *caused* my own problem. :oops: The issue was that I also rsync my home directory from my client (the 13" MBP) to the server (the iMac). When I set up the rsync I forgot to exclude ~/Library. Ugh! Long story short, I ended up having to "nuke and pave" the iMac to get things straightened out. Kevin

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now