Jeremy

With VirtualBox VM in the foreground, cursor can't leave screen.

4 posts in this topic

When I have a VirtualBox VM in the foreground on my centos 6 synergy server, I can't move my cursor right to my windows 7 client. The cursor will remain invisible until I right-click.

If I minimize VirtualBox, everything goes back to working normally.

[2017-04-27T16:53:05] INFO: switch from "centos6jkl" to "Jlisenby-dtx" at 0,294

[2017-04-27T16:53:05] INFO: leaving screen

[2017-04-27T16:53:06] WARNING: can't leave screen

[2017-04-27T16:53:06] INFO: switch from "centos6jkl" to "Jlisenby-dtx" at 0,294

[2017-04-27T16:53:06] INFO: leaving screen

[2017-04-27T16:53:07] WARNING: can't leave screen

Share this post


Link to post
Share on other sites

With DEBUG2 enabled,  I see this:

[2017-04-28T12:40:21] DEBUG2: find neighbor on right of "centos6jkl"
[2017-04-28T12:40:21] DEBUG2: "Jlisenby-dtx" is on right of "centos6jkl" at 0.605093
[2017-04-28T12:40:21] DEBUG1: try to leave "centos6jkl" on right
[2017-04-28T12:40:21] DEBUG2: mapping state: 0
[2017-04-28T12:40:21] INFO: switch from "centos6jkl" to "Jlisenby-dtx" at 0,653
[2017-04-28T12:40:21] INFO: leaving screen
[2017-04-28T12:40:21] DEBUG2: waiting to grab keyboard (repeats several times)

...
[2017-04-28T12:40:22] DEBUG2: waiting to grab keyboard
[2017-04-28T12:40:22] DEBUG2: grab keyboard timed out
[2017-04-28T12:40:22] WARNING: can't leave screen

 

Share this post


Link to post
Share on other sites

Ugh. Problem "fixed". I disabled "Auto Capture Keyboard" in VirtualBox. I hated that feature of VirtualBox anyway.

Share this post


Link to post
Share on other sites

You will probably never see this, but THANK YOU!

For anyone else searching, disabling the Auto Capture Keyboard setting worked nicely.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now