reapur

Windows 10 / Centos 6.7

4 posts in this topic

I have had windows 7 running the free version 1.5 as server and centos 6.7 running free version 1.5 as client.

I had to upgrade to windows 10. That's when things broke. the SHIFT key stopped working on the client, the mouse would get trapped in the lower right corner.

So I bought a license yesterday and installed the new version on Windows 10. Now I can connect and type on both platforms

The problem now is copy/paste doesn't work.

I thought I would update the linux version also, but when I try to rpm install it, it get a very long list of dependencies related to libc.

Does anyone have an idea on what I really need to update?

rpm -Uvh synergy-v1.8.8-stable-25a8cb2-Linux-i686.rpm 
error: Failed dependencies:
    libICE.so.6 is needed by synergy-1.8.8-1.i686
    libQtCore.so.4 is needed by synergy-1.8.8-1.i686
    libQtGui.so.4 is needed by synergy-1.8.8-1.i686
    libQtNetwork.so.4 is needed by synergy-1.8.8-1.i686
    libSM.so.6 is needed by synergy-1.8.8-1.i686
    libX11.so.6 is needed by synergy-1.8.8-1.i686
    libXext.so.6 is needed by synergy-1.8.8-1.i686
    libXi.so.6 is needed by synergy-1.8.8-1.i686
    libXinerama.so.1 is needed by synergy-1.8.8-1.i686
    libXrandr.so.2 is needed by synergy-1.8.8-1.i686
    libXtst.so.6 is needed by synergy-1.8.8-1.i686
    libc.so.6 is needed by synergy-1.8.8-1.i686
    libc.so.6(GLIBC_2.0) is needed by synergy-1.8.8-1.i686
    libc.so.6(GLIBC_2.1.2) is needed by synergy-1.8.8-1.i686
    libc.so.6(GLIBC_2.1.3) is needed by synergy-1.8.8-1.i686
    libc.so.6(GLIBC_2.4) is needed by synergy-1.8.8-1.i686
    libcrypto.so.10 is needed by synergy-1.8.8-1.i686
    libcrypto.so.10(OPENSSL_1.0.1) is needed by synergy-1.8.8-1.i686
    libcrypto.so.10(libcrypto.so.10) is needed by synergy-1.8.8-1.i686
    libcurl.so.4 is needed by synergy-1.8.8-1.i686
    libdl.so.2 is needed by synergy-1.8.8-1.i686
    libdns_sd.so.1 is needed by synergy-1.8.8-1.i686
    libgcc_s.so.1 is needed by synergy-1.8.8-1.i686
    libgcc_s.so.1(GCC_3.0) is needed by synergy-1.8.8-1.i686
    libgcc_s.so.1(GLIBC_2.0) is needed by synergy-1.8.8-1.i686
    libm.so.6 is needed by synergy-1.8.8-1.i686
    libpthread.so.0 is needed by synergy-1.8.8-1.i686
    libpthread.so.0(GLIBC_2.0) is needed by synergy-1.8.8-1.i686
    libpthread.so.0(GLIBC_2.1) is needed by synergy-1.8.8-1.i686
    libpthread.so.0(GLIBC_2.3.2) is needed by synergy-1.8.8-1.i686
    libssl.so.10 is needed by synergy-1.8.8-1.i686
    libssl.so.10(libssl.so.10) is needed by synergy-1.8.8-1.i686
    libstdc++.so.6 is needed by synergy-1.8.8-1.i686
    libstdc++.so.6(CXXABI_1.3) is needed by synergy-1.8.8-1.i686
    libstdc++.so.6(CXXABI_1.3.1) is needed by synergy-1.8.8-1.i686
    libstdc++.so.6(GLIBCXX_3.4) is needed by synergy-1.8.8-1.i686
    libstdc++.so.6(GLIBCXX_3.4.11) is needed by synergy-1.8.8-1.i686
    libstdc++.so.6(GLIBCXX_3.4.9) is needed by synergy-1.8.8-1.i686
 

I don't really care about updating the linux side if I can get copy/paste to work

Thanks

Share this post


Link to post
Share on other sites

If I install the 64bit version, I see this dep needed:

libdns_sd.so.1()(64bit)

I will google this and see where to install this from.

If there is an official way to get this to work properly with synergy, I would appreciate the advice.

Thanks

Share this post


Link to post
Share on other sites

I managed to solve this

in my case I had to find this package and install it:

rpm -ivh avahi-compat-libdns_sd-0.6.25-17.el6.x86_64.rpm, I had 0.6.25-15 and that was no good. Before this tho I had to groupinstall Development tools, and avahi

Then I uninstalled synergy 1.5 and install 1.8.8

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now