StephenBerlin

Mouse pointer stays on Windows desktop

12 posts in this topic

This is more general discussion, but that option was grayed out when I posted... so maybe I have a configuration issue. =)

 

My server is running on an Ubuntu box, and I have a Windows 10 client.

 

Are these both normal behaviour...


1) When I move my mouse from Windows to Ubuntu, the mouse appears on Ubuntu and works fine, but 99% of the time a second frozen mouse cursor appears

in the center of the Windows desktop. When I move the mouse back to Windows, the center pointer disappears and the mouse is fine. I find the second pointer

irritating, because I sometimes look at my monitors and think the Windows pointer is live. Is this normal? Can I change it?

 

2) When using the Windows client, any time I need to do something that requires admin privileges (secure desktop I think), and Windows fills the screen asking

me yes or no, my mouse flies back to the server, and it take a few seconds before I can move it back to Windows. Normal?

 

Thanks.

 

Share this post


Link to post
Share on other sites

Had same problem.

Came here to find solution.

Only looked through about 10-12 search terms.

Found at least 3 other people asking similar/related questions, but no answers posted.

I decided to just try to stop and restart synergy on all the machines.

This solved it... for now.

I am expecting it to do it again when I reboot...

Edited by Draconious

Share this post


Link to post
Share on other sites

You had #1, #2, or both? Rebooting hasn't helped me... I've rebooted for other reasons several times on both machines, and both problems are still there. Thanks.

Share this post


Link to post
Share on other sites

Hi everyone! Sorry for the late reply on this.

For the 1st question, I'd say it would be normal to have a mouse cursor left in the middle when you are working on the client. That's because the client machine is still a different machine. When your active mouse cursor enters the server's screen, the client machine still knows that there's a mouse that can and will control it. It's just that it doesn't know where the cursor is once the actual cursor gets back to the server's screen. Also, leaving it in the middle is not totally a Synergy choice behavior. It is due to the fact that your OS doesn't see where the actual cursor is, thus, showing it in the middle.

For the 2nd question, it is also normal since Synergy still asks for permission on your client's system for it to have an elevated access. You can try setting the elevation level of Synergy on your client machine to "Always" for it to run with elevation at all times.

  1. Click Edit
  2. Click Settings
  3. Set Elevate to Always
  4. Click OK
  5. Click Apply or Start

Share this post


Link to post
Share on other sites

Regarding the first point... yikes, I really disagree. I think you mixed things up a bit, because the mouse stays in the middle of the client screen when working on the server (you said client). When I move the mouse from the server machine to the client, the mouse pointer on the server disappears (correct). The same should be true going the other direction. If there is a technical reason that prevents you from removing the mouse pointer from the client, then leave it on the edge of the screen where it left... putting it in the middle of the screen is the worst place for it. If you for example want to watch a video on your client while working on your server, then there is a mouse pointer in the middle of the client video screen, and there's no way to change that (without connecting a second mouse to the client, which is what this software is trying to avoid). Thanks.

Share this post


Link to post
Share on other sites

I think your first use of "client" should be server...

Well, that's a bummer. And yes, if synergy doesn't tell the client where the mouse should go, I can see how it ends up in the middle... maybe then there should be a setting for this... and we can pick a corner or something.

I'm really surprised that you don't seem to think this is a real pain. It's as though you think that you can't be making use of what's on a screen if the synergy mouse isn't active on it. I often have a PDF open on one screen to reference, while doing work on another. Or my other example of watching a movie, while doing something on another screen. Leaving the mouse in the middle seems like the worst solution. 

Thanks.

 

Share this post


Link to post
Share on other sites

When I solved it above, I had left the Client window minimized.

If it is left minimized on the task bar the mouse goes away much faster, if it even appears at all.

 

I am using this, on a 10 player Racing Simulator.
I need the mouse to go away as soon as possible, because as I move the mouse across the screens it pops it up right in the center of the drivers line of sight.

I have managed to get around it by having another monitor on the 2nd machine, and leaving the client on the task bar.

 

 

Share this post


Link to post
Share on other sites

Sorry for replying a bit late here @StephenBerlin. Further research with issue led me to an issue opened and still is on an open status in our GitHub page. This means that our developers are already aware of this and they're still on the hunt for a solution for this. Please bear with us as we try to make Synergy even better for everyone.

Share this post


Link to post
Share on other sites

Keep me posted too. Would be great to get the cursor to disappear (from the second screen) 

Share this post


Link to post
Share on other sites

Any update on this?  Running the latest version - 1.8.8-stable and I'm having this issue.

Thanks!

Share this post


Link to post
Share on other sites

Alright, guys - Anything yet? We are at seven months (and waiting) for a solution. 

Our office is getting ready to drop your service - as the arrow keeps starting distracting conversations during meetings. Due to the arrow creating a focal point for viewers - not good during demos as people are often looking at the wrong screen. Waiting on the mouse to move. 

arrow.jpg

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now