Karl Egas

macOS Sierra Client cannot move the cursor to the server Screen macOS El Capitan

22 posts in this topic

Recently I updated my iMac to macOS Sierra using the version 1.8.8, the connection is established but the cursor cannot move to the server screen, I tried cleaning the preferences and still the same problem.  I uninstalled the Synergy app with CleanmyMac and using the version 1.8.7 but happens the same.

The logs said is connected and the config server box see the iMac beside to it but there's not way to use the share screen feature.

Attached the screenshots.

Karl

synergyclient.jpg

synergyserver.jpg

Share this post


Link to post
Share on other sites

I have a late 2013 Mac Pro running the latest version of Sierra 10.12.4 and I'm also unable to change from my server to the client screen.  

I've also reconfigured Synergy (Pro), switching the server from the Mac to my new Windows 10 System but the results are the same :

(the log shows that the windows should be switching but I remain stuck in either the client or server I'm on when I try to change.

The section of the the log below shows that the screen should be changing from one to the other but it does not occur.

Synergy had been working perfectly until I changed to a new (client) monitor. (a BenQ sw320 which offers a "hockey puck" to change from input ports (I've got my Mac Pro connected to the BenQ using an HDMI port and the Windows system is plugged into the Mini HDMI port on the BenQ with the other end going to a Display port on the Windows system. - (previously I'd been using a Samsung SmartTV for the Windows system and My Mac Pro - both connected via HDMI ports 

___________________________________________________________________________________________________________

(Section of Log:)  

[2017-04-12T23:46:43] INFO: log level: DEBUG

[2017-04-12T23:46:43] DEBUG: opening configuration "/var/folders/3h/vg6qw0ms5_9_9x_gn6rpffmr0000gn/T/Synergy.G10684"

[2017-04-12T23:46:43] DEBUG: configuration read successfully

[2017-04-12T23:46:43] DEBUG: screen shape: center=0,0 size=3840x2160 on 1 display

[2017-04-12T23:46:43] DEBUG: starting watchSystemPowerThread

[2017-04-12T23:46:43] DEBUG: adopting new buffer

[2017-04-12T23:46:43] DEBUG: opened display

[2017-04-12T23:46:43] DEBUG: started watchSystemPowerThread

[2017-04-12T23:46:43] DEBUG: waiting for event loop

[2017-04-12T23:46:43] DEBUG: could not map hotkey id=ef14 mask=0000

[2017-04-12T23:46:43] NOTE: started server, waiting for clients

[2017-04-12T23:46:43] DEBUG: waiting for carbon loop

[2017-04-12T23:46:43] DEBUG: event queue is ready

[2017-04-12T23:46:43] DEBUG: signalling carbon loop ready

[2017-04-12T23:46:43] DEBUG: add pending events to buffer

[2017-04-12T23:46:43] DEBUG: starting carbon loop

[2017-04-12T23:46:43] DEBUG: carbon loop ready

[2017-04-12T23:46:43] DEBUG: add pending events to buffer

[2017-04-12T23:46:43] DEBUG: screen "Mac-Pro.local" shape changed

[2017-04-12T23:46:43] DEBUG: screen "Mac-Pro.local" shape changed

2017-04-12 23:46:43.359 synergys[14972:393270] starting cocoa loop

[2017-04-12T23:46:45] INFO: OpenSSL 1.0.2 22 Jan 2015

[2017-04-12T23:46:45] INFO: accepted secure socket

[2017-04-12T23:46:45] INFO: AES256-GCM-SHA384       TLSv1.2 Kx=RSA      Au=RSA  Enc=AESGCM(256) Mac=AEAD

[2017-04-12T23:46:45] NOTE: accepted client connection

[2017-04-12T23:46:45] DEBUG: received client "Rjjaf130759" info shape=0,0 2560x1440 at 5360,0

[2017-04-12T23:46:45] NOTE: client "Rjjaf130759" has connected

[2017-04-12T23:47:43] INFO: switch from "Mac-Pro.local" to "Rjjaf130759" at 2559,999

[2017-04-12T23:47:43] INFO: leaving screen

[2017-04-12T23:47:43] DEBUG: hiding cursor

[2017-04-12T23:47:43] DEBUG: opening clipboard

[2017-04-12T23:47:43] DEBUG: closing clipboard

[2017-04-12T23:47:43] INFO: screen "Mac-Pro.local" updated clipboard 0

[2017-04-12T23:47:43] DEBUG: opening clipboard

[2017-04-12T23:47:43] DEBUG: closing clipboard

[2017-04-12T23:47:43] INFO: screen "Mac-Pro.local" updated clipboard 1

[2017-04-12T23:47:43] DEBUG: sending clipboard 0 to "Rjjaf130759"

[2017-04-12T23:47:43] DEBUG: sent clipboard size=33

[2017-04-12T23:47:43] DEBUG: sending clipboard 1 to "Rjjaf130759"

[2017-04-12T23:47:43] DEBUG: sent clipboard size=33

[2017-04-12T23:48:02] INFO: switch from "Rjjaf130759" to "Mac-Pro.local" at 55,617

[2017-04-12T23:48:02] INFO: entering screen

[2017-04-12T23:48:02] DEBUG: showing cursor

[2017-04-12T23:48:04] INFO: switch from "Mac-Pro.local" to "Rjjaf130759" at 2559,975

[2017-04-12T23:48:04] INFO: leaving screen

[2017-04-12T23:48:04] DEBUG: hiding cursor

[2017-04-12T23:48:04] DEBUG: opening clipboard

______________________________________________________________________________

Any suggestions would be greatly appreciated!

Robert

Edited by rjj
(I'd left out the log file)

Share this post


Link to post
Share on other sites

I posted one week ago about this problem and not get any answer from Synergy, I saw other problems similar of connectivity with the app. Really you cannot be behind your app bugs?

Share this post


Link to post
Share on other sites

Hi Karl

 In my case, I think the problem is that Synergy does not work with a single monitor. I'd love to be wrong about this but I don't think it's possible to use it without twor monitors 

 

Robert

Share this post


Link to post
Share on other sites

Hi Robert

Yes the software is make to move the cursor to the other computer monitor, in your case maybe is get a video splitter and use the Synergy to take the cursor and keyboard control.

My case is more sad, I have 2 iMacs one beside the other and I cannot move to the cursor from the client screen to the server.  All the connections are working and the log did not show any problem but still cannot move to the other side. My only guess is that macOS Sierra is not working with the last version of Synergy. 

Is sad that the support is only give it to Enterprise accounts that pay $ 10K at year, and the forum is not supported by anyone from Symless. 

Share this post


Link to post
Share on other sites

Hi Karl,

 I  ended up ordering a second monitor which I expect will work though I don't appreciate the extra real estate on my desk it will take up.   As to the lack of support for anything except enterprise-level users,  to me, rather than "sad" I would say the situation is loathesome.  Unless Symless adopts a more responsible form of support for its other users I would have to highly recommend people finding a different solution. 

 But I am sad that you're stuck with that situation!   Robert 

 

 

 

Share this post


Link to post
Share on other sites

I recently installed the new version 1.9 RC3 and still have the same issue, the cursor cannot move to the other screen from the client side.

I don't know if this issue have that are running El Capitan in the Server and macOS Sierra in the client side.

Very frustrating.

Karl

Edited by Karl Egas

Share this post


Link to post
Share on other sites

Hi @Karl Egas. We apologize, for the late reply. Can you share a screen shot of your Server configuration box?

Share this post


Link to post
Share on other sites

This is the configuration box on the server.

 

2017-05-12_11-02-19.png

2017-05-12_11-03-53.png

Edited by Karl Egas

Share this post


Link to post
Share on other sites

Did you figure out what is wrong with my configuration?

Thanks

Karl

Share this post


Link to post
Share on other sites

Can you try renaming each machine and omitting .local from their screen names and update the server configuration box to the changes you made.

Share this post


Link to post
Share on other sites

Hi Paul,

I'm writing hoping that you're responding to Karl as I ended up purchasing a second monitor and now Symless is working as it should.

Thanks,

 

Robert

Share this post


Link to post
Share on other sites
7 minutes ago, rjj said:

Hi Paul,

I'm writing hoping that you're responding to Karl as I ended up purchasing a second monitor and now Symless is working as it should.

Thanks,

 

Robert

Thanks for the update @rjj.

Share this post


Link to post
Share on other sites
On 5/12/2017 at 10:53 AM, Karl Egas said:

I recently installed the new version 1.9 RC3 and still have the same issue, the cursor cannot move to the other screen from the client side.

I don't know if this issue have that are running El Capitan in the Server and macOS Sierra in the client side.

Very frustrating.

Karl

How I said several post before I updated to 1.9 RC3 and still have the same issue, also I changed the names of the Macs as you suggested, they appears as connected in the dialog boxes but still I cannot move the cursor to the other screen.

Another idea? Maybe you want access remotely to my Mac to see more details.

Karl

 

 

2017-05-16_08-48-32.png

2017-05-16_08-48-48.png

2017-05-16_08-52-44.png

2017-05-16_08-49-17.png

Edited by Karl Egas

Share this post


Link to post
Share on other sites

Today I update the macOS Sierra to 10.12.5 hoping it will fix the problem, my happiness was ephemera, I decide to try move the iMac position from the right to the server to the left maybe something won change, I can move the cursor to the server in this way but I  move to the original position and the Mac physical disposition, the cursor doesn't works again. 

My problem with this workaround are two, only works if I am connected to the TalleyServer via VNC Screen Sharing, if not the cursor movement not activate the TalleyServer screen, second cause I am lefty my brain have a big problem going to the right side.

Maybe you have now other perspective what is happening?

Thanks

Karl

2017-05-16_08-48-32.png

2017-05-17_09-38-55.png

Share this post


Link to post
Share on other sites

Some advance about fix my issue? I did not get any answer after while my last post.

Some new version RC come this June?

Karl

Edited by Karl Egas

Share this post


Link to post
Share on other sites

Well any update for the RC3?  I update my computer to MacOS Sierra so in both computer running the same macOS still not working.

The cursor never move to the other screen. So at less the new RC will fix it I will request a refund of my money. Not support at all.

Karl

Share this post


Link to post
Share on other sites

Hi @Karl Egas. Sorry for the late reply. What errors are you getting now while using v1.9? Can you post current screenshots of both machine's Synergy interface and the Server Configuration interface on your server machine?

Share this post


Link to post
Share on other sites

I posted the screenshots above time ago, nothing has changed in the logs, continues I cannot move the cursor from one screen to another.

I was thinking was the Server has El Capitan and the Client has Sierra but I updated this week to Sierra the Server and tested again with the same result, I disconnect and connect the client, the server add it but I cannot move the cursor to the other screen.

Let me know if you need something else.

Karl

 

 

Share this post


Link to post
Share on other sites

Hi @Karl Egas. Sorry for the late reply on this. Can you post a copy of your configuration file? I'll try to check if there's something wrong with it.

Share this post


Link to post
Share on other sites

i had this issue on 1.9rc btw windows and mac high sierra.

removed .local from server config and mac and got no cursor still,  i bumped the server and client port up by 1 and connected fine with cursor and everything is working (laggily still though)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now