nico fernandez

Mouse clicks not working.

9 posts in this topic

I have been using the software for a while now without any problems until now. Mouse clicking on the client does not seem to work. the mouse cursor does transfer, the keyboard works fine and copy-paste works on both side. It is just the mouse click that is unresponsive. there is a brief moment (2 sec)that it work when ever i press apply after that it is gone. Please is there any fix to this.

Share this post


Link to post
Share on other sites

I have this issue, but with a little more success.

On a window-windows install, running 1.8.8, my "client" machine stops responding to mouse clicks. This can happen several times a hour. The only way to correct the "client" is to travel the mouse back to the "server" machine. The "client" will work for a while, but the problem will reoccur ~10-20 mins later.

Share this post


Link to post
Share on other sites

If you are using a logitech mouse, with the logitech options software, the problem lies with the software. In my experience, closing the software on the server via the task manager will fix the mouse not clicking.

Share this post


Link to post
Share on other sites

I still having this issue.

I don't have any logitech mouse and any special software installed for it.

I'm using Synergy 1.8.8 in two machines with Windows 10.

Share this post


Link to post
Share on other sites

I have this issue.  Server is windows 10 laptop.  Client is Macbook Air.  Mouse clicks worked fine for a few days, then all of a sudden didn't work for like 20 minutes.  Now all of a sudden it's working again and I did nothing different.

Share this post


Link to post
Share on other sites

I'm having the same issue, it worked fine for some time then just stopped registering clicks, I tried killing Logitech options but it made no difference... both server and client are Windows 10 updated to the fall creators update

Share this post


Link to post
Share on other sites

Same problem, I have Logitech everything. I don't have any Logitech software installed but this still happens on my macOS client. In any case, no matter what mouse brand you use you should not be forced to uninstall or remove functions for Synergy to work. Should integrate nicely and simply with the remote pointer using "local" functions.

Share this post


Link to post
Share on other sites

I have this issue as well. Using Win 10 Server, MacOS client. Cursor moves across the screen, hovering over items has interaction, cannot click on anything. Closed Logitech stuck, reboots, still doesn't work. It used to work.

Share this post


Link to post
Share on other sites

Been seeing this for the last month or two so not sure what changed recently. Like other users who posted, the solution is to move the mouse to the Windows server and back, after which clicks start working again for a while.

I've also recently seen an error on the Mac that Synergy can't be started since it isn't installed. Closing it fully and reopening fixes it. Not sure if this is related.

Environment:

  • Client: Mac 10.12.6, Macbook Pro 15-inch, mid 2015.
  • Server: Windows 10 1703, Wired USB mouse (Dell laptop)
  • Synergy 1.10.1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now