Angela Zack

1.8.7 Stable Client times out and can't connect

16 posts in this topic

I've downloaded the latest version because 1.8.6 wasn't working (Windows Client didn't boot up on start, wouldn't connect unless I quit and restarted Mac Server). Unfortunately, Windows version (Synergy Pro) fails to connect to server (Synergy Basic) and I can't use the program at ALL anymore. I don't see where I can specify which version of Synergy to download; Basic or Pro. But it appears that Pro is automatic for Windows, and Basic is all there is for Mac. Is this the reason they don't talk to each other?

Share this post


Link to post
Share on other sites

I think I have the same problem. Since today after updating both my machines (windows as server and mac as client). I get the following at the server (Windows):

 

[2017-01-25T09:57:03] INFO: OpenSSL 1.0.2 22 Jan 2015

[2017-01-25T09:57:18] ERROR: ssl error occurred (system call failure)

[2017-01-25T09:57:18] ERROR: eof violates ssl protocol

[2017-01-25T09:57:18] ERROR: failed to accept secure socket

[2017-01-25T09:57:18] INFO: client connection may not be secure

 

I tried switching them around (mac as server and windows as client). I now get this at the client (windows):

[2017-01-25T09:59:13] ERROR: ssl error occurred (generic failure)

[2017-01-25T09:59:13] ERROR: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol

[2017-01-25T09:59:13] ERROR: failed to connect secure socket

Share this post


Link to post
Share on other sites

I have different messages. On the server (Mac):

 

INFO: starting server

[2017-01-25T09:37:52] INFO: config file: /var/folders/0n/wdvvyr813bbd7z_ry2z4cgqc0000gp/T/Synergy.HaQ341

[2017-01-25T09:37:52] INFO: log level: INFO

[2017-01-25T09:37:55] INFO: drag and drop enabled

[2017-01-25T09:37:58] NOTE: started server, waiting for clients

2017-01-25 09:37:59.858 synergys[401:4508] starting cocoa loop

 

I've blocked my IP address, but on the client, (Windows):

 

[2017-01-25T09:46:02] NOTE: connecting to '[XXIP ADDRESSXX]': 192.168.1.35:24800

[2017-01-25T09:46:18] WARNING: failed to connect to server: Timed out

 

It seems like nobody's home at Synergy. They used to be fairly prompt in responding to help requests. I've been offered a refund instead of help! Anybody know what's going on over there? Where's Nick Bolton?

Share this post


Link to post
Share on other sites

Also having connectivity issues with this latest version.

 

Mouse lags extremely when on my client computer.

 

Been a premium user for years and never was it this un-usable.

Share this post


Link to post
Share on other sites
I think I have the same problem. Since today after updating both my machines (windows as server and mac as client). I get the following at the server (Windows):

 

[2017-01-25T09:57:03] INFO: OpenSSL 1.0.2 22 Jan 2015

[2017-01-25T09:57:18] ERROR: ssl error occurred (system call failure)

[2017-01-25T09:57:18] ERROR: eof violates ssl protocol

[2017-01-25T09:57:18] ERROR: failed to accept secure socket

[2017-01-25T09:57:18] INFO: client connection may not be secure

 

I tried switching them around (mac as server and windows as client). I now get this at the client (windows):

[2017-01-25T09:59:13] ERROR: ssl error occurred (generic failure)

[2017-01-25T09:59:13] ERROR: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol

[2017-01-25T09:59:13] ERROR: failed to connect secure socket

 

I'm getting the same error on Mac:

 

[2017-01-30T10:57:57] INFO: OpenSSL 1.0.2 22 Jan 2015
[2017-01-30T10:58:12] ERROR: ssl error occurred (system call failure)
[2017-01-30T10:58:12] ERROR: eof violates ssl protocol
[2017-01-30T10:58:12] ERROR: failed to accept secure socket

Share this post


Link to post
Share on other sites

I got 1.8.7 working on my two Mac machines. I needed to remove the app, remove all associated config files, remove the SSL cert, and then re-install the app. After entering my pro license key into the app on both machines and unchecking "use SSL" and rechecking it (to make sure the cert was regenerated), everything seems to work OK.

Share this post


Link to post
Share on other sites

Thanks, Max, but can you be more specific? Did you remove the app on both machines? Where do you go to remove the SSL cert? Where do you go to remove all config files?

 

When I loaded the previous update, I was prompted for my license key into the app, but not on this version, which I found strange. And also strange is that when I download 1.8.7 Stable, on the Mac it is the basic version (not option otherwise, that I can see) and on the Windows (client) version it is the Pro version, again no option to choose.

Share this post


Link to post
Share on other sites

Buenas Amigos la solución a este problema radica en lo siguiente, no hay que desactivar el SSL hay que dar de alta la computadora como cliente en la maquina Servidor, en la maquina servidor en el icono configurar Servidor darle un click arrastrar la maquina cliente (ojo, no aparece con ningún nombre pero de todos maneras anexarlo después de anexarlo darle doble clic al icono y ahí ponerle el nombre de la pantalla cliente tal y como lo tienen en su computadora cliente aceptar y empezara a funcionar perfectamente el programa de Synergy

Share this post


Link to post
Share on other sites

Good Friends the solution to this problem lies in the following, you do not have to deactivate the SSL you have to register the computer as client in the machine Server, in the server machine in the icon configure Server give you a click drag the client machine (eye , It does not appear with any name but anyway attach it after attaching it double click the icon and there put the name of the client screen as they have it on their client computer accept and start working perfectly Synergy program

Share this post


Link to post
Share on other sites

I've been a Synergy user for 4+ years. My client computer gets configured every time I upgrade to the newest version. This is not the solution to the problem I'm having, unfortunately, since I configured it as usual as soon as I upgraded.

Share this post


Link to post
Share on other sites

Just purchased pro... getting the same thing...

On Windows 10...

 

[2017-02-03T09:08:50] ERROR: ssl error occurred (system call failure)
[2017-02-03T09:08:50] ERROR: eof violates ssl protocol
[2017-02-03T09:08:50] ERROR: failed to accept secure socket

 

over and over and over... not able to share mouse/keyboard...

 

Tried to follow the solution above... but my clients seem to be properly registered...

Share this post


Link to post
Share on other sites

If anybody figures out what the steps are to clear this situation, please post. To iterate some of my questions:

 

No Pro version for Mac shows up as an option to download, but Pro automatically downloaded for Windows. So I've got Pro on Windows trying to connect with Basic on Mac.

 

Mac (Server) sees Windows (Client), but Windows Synergy times out trying to connect with Server (same error messages as others have posted).

Share this post


Link to post
Share on other sites

I'm getting the same issue. (pc win10 server and macbook air client)

Getting the error: "failed to connect to server: Timed out"

I've tried multiple times, but nothing. Tried to contact support. Also nothing.

Still within 30 days so submitted a refund. If they can fix the issue I'll hang onto the software, but as it is, this is a bit sad.

If they do provide me with a solution that works, I'll gladly post it here.

Share this post


Link to post
Share on other sites

I too have been having this same problem.

 

I was contacted by support and told they will no longer be offering support to non-enterprise clients. They offered me a refund but I didn't take it because I was really hoping they would sort this out. I have not had a stable usable product since version 1.8.3!

 

I'm throwing in the towel. I just downloaded a freeware app called ShareMouse and so far it works absolutely seamlessly in either direction. Makes me wonder why I stuck it out with Synergy for so long.

 

I'm so sad. I even have a Synergy tee shirt! When this product worked, it was FANTASTIC. I'm sorry to see it die.

Share this post


Link to post
Share on other sites

I also downloaded Sharemouse. It is a Symless (Synergy) product, so no need to lament! I'm back to one keyboard and mouse again. Whew!

Share this post


Link to post
Share on other sites

I had the following errors

[2017-09-25T11:24:21] INFO: OpenSSL 1.0.2 22 Jan 2015
[2017-09-25T11:24:30] ERROR: ssl error occurred (system call failure)
[2017-09-25T11:24:30] ERROR: eof violates ssl protocol
[2017-09-25T11:24:30] ERROR: failed to accept secure socket
[2017-09-25T11:24:30] INFO: client connection may not be secure

Solution: Disable SSL in Synergy software.
Disabling SSL encryption is HIGHLY NOT RECOMMENDED if you're working in a network that has other users.
Anyone sniffing its traffic will be able to see your key presses in clear text.

In MacOS:
1. Open Preferences, COMMAND + COMMA : ⌘ + ,
2. Uncheck Use SSL encryption.

In Windows:
1. Go to Edit > Settings
2. Uncheck Use SSL encryption.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now