fgerdsme

How to set up @-symbol in synergy 1.8.5?

8 posts in this topic

Hey all,

 

using synergy and patching to newest version I found out that the above mentioned mapping doesn't work (server debian/client windows 7):

 

138 (000000a5) down <------ ALT LEFT

[2016-11-07T09:08:41] DEBUG1: recv key down id=0x00000040, mask=0x0020, button=0x0018 <---- @-symbol german layout / Q-key

[2016-11-07T09:08:41] DEBUG1: key down translated to id=0x00000040, mask=0x0004

[2016-11-07T09:08:41] DEBUG1: mapKey 0040 (64) with mask 0004, start state: 0004

[2016-11-07T09:08:41] DEBUG1: no mapping for key 0040 <------ ERROR

[2016-11-07T09:08:41] DEBUG1: recv key up id=0x00000040, mask=0x0020, button=0x0018

[2016-11-07T09:08:41] DEBUG1: key up translated to id=0x00000040, mask=0x0004

[2016-11-07T09:08:41] DEBUG1: recv key up id=0x0000ef7e, mask=0x0020, button=0x006c

[2016-11-07T09:08:41] DEBUG1: key up translated to id=0x0000efea, mask=0x0004

[2016-11-07T09:08:41] DEBUG1: new state 0000

[2016-11-07T09:08:41] DEBUG1: keystrokes:

[2016-11-07T09:08:41] DEBUG1: 138 (000000a5) up

 

Is there any way to manually add the missing key mapping by editing the synergy config?

Share this post


Link to post
Share on other sites

Hi,

I've got the same problem mentioned by fgerdsme and it's complicated to write an email address in the synergy client (Windows 10 - French keyboard) from the server (Ubuntu 16.04 - French keyboard).

The @-symbol in a french keyboard is a combination of the Alt Gr-key and 0-key.

All of the other symbols that is a combination with the Alt Gr-key doesn't work too.

I remember that this problem was resolved before this version 1.8.5 in adding this line in each client section in the configuration file : altgr = alt

It doesn't work anymore.

 

PS : Sorry for my broken english ! :mrgreen:

Share this post


Link to post
Share on other sites

I am having the same issue. Linux synergy server, windows synergy client.

 

All alt+key options don't work when switching to the windows client.

 

Changing the configuration file to altgr=alt or altgr=shift does not solve the problem. :cry:

Share this post


Link to post
Share on other sites
I FOUND A SOLUTION in:

viewtopic.php?f=9&t=1448&p=4287&hilit=alt#p4287

 

i can use ctrl+alt+q on a german keyboard to write a @ !

 

In fact, all alt+key combinations work if i use ctrl+alt+key.

Thanks Daniel for this workaround. It works for me too with ctrl+alt+key on a french keyboard and in version 1.8.6.

 

Another workaround has been found here > viewtopic.php?f=16&t=2080&p=6317&hilit=altgr#p6317

It's works for me too and it's much useful.

Share this post


Link to post
Share on other sites

Hello, sorry to reopen this thread, but I have the same problem.

I have synergy 1.8.8 both on my Windows 10 (server) and Ubuntu (32 bit, client), both in French layout (AZERTY).

I have only few AltGr keys working on the client "~[`\]" for the whole line instead of "~#{[|`\^@]}".

The links to the solution are broken and I can't find the linked threads.

Thank you.

Share this post


Link to post
Share on other sites

Sorry, I find the cause of this.
On my Ununtu, I have 2 key board selector (don't know why probably add in the upgrade from 14.04 to 16.04).

Now it's work fine.

Share this post


Link to post
Share on other sites

Does not work at windows client and putty, bash (WSL on win10) ... Can somebody fix the links?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now