Al Delgado

New Client Will Not Connect

4 posts in this topic

Have Synergy Pro 1.8.5

I have had my Asus laptop and desktop connected for quite awhile. I want to add a Surface Book, but it won't connect, after installation of client.

 

Error: ssl error occurred (generic failure)

Error: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol

Error: failed to connect to secure socket

Share this post


Link to post
Share on other sites

For years I have been accustomed to just running "synergys" on the command line and that worked. This is no longer the case. Now I have to run this:

 

synergys --enable-crypto --serial-key 

 

It should be noted that the

serial-key

isn't just a copy paste from your account page. To find the correct one I had to run synergy from the GUI and look up what key it was using. Just to clarify here are the steps:

 

Kill synergy

 

just run "synergy" instead of "synergys"

 

ps fax | grep synergys

 

There you should find the key.

 

I'm sure there are more elegant ways to figure this out but I haven't seen anybody with answers regarding this so hopefully it's helpful.

Share this post


Link to post
Share on other sites

I'm running a Windows 10 desktop as a server and tried to connect a new Windows 10 Client. I'm running version: 1.8.5-stable-a18eba7. I entered the key from my login on the client to activate it. However, the key had not been entered on the server to activate it. Once the server was activated, the client connected.

 

Hope this helps any Windows users out their looking for at least one answer.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now