James Chapman

1.8.4 server crashes on resume (Ubuntu 14.04)

0 posts in this topic

I am seeing the server crash when resuming after suspend/hibernate on Ubuntu 14.04. Synergy is configured to autostart at boot. I tried two methods: using Dash "Startup Applications" and configuring the Lightdm greeter. Both result in the same behaviour. Synergy will autostart with no problems at boot, but it crashes if the server is resumed after suspend or hibernate.

 

I am using 1.8.4 with 3 Ubuntu computers, all running 14.04.

 

greeter-setup-script=/usr/bin/synergys --debug DEBUG2 --name whoosh --enable-crypto --address :24800 -c /etc/synergy.conf

 

On resume, syslog has the following:-

 

Oct 26 08:54:25 whoosh kernel: [  780.169963] Restarting tasks ... done.
Oct 26 08:54:25 whoosh acpid: client 1813[0:0] has disconnected
Oct 26 08:54:25 whoosh Synergy 1.8.4: [2016-10-26T08:54:25] DEBUG2: writef(CALV)
Oct 26 08:54:25 whoosh Synergy 1.8.4: [2016-10-26T08:54:25] DEBUG2: wrote 4 bytes
Oct 26 08:54:25 whoosh Synergy 1.8.4: [2016-10-26T08:54:25] NOTE: client "bobbins" is dead
Oct 26 08:54:25 whoosh Synergy 1.8.4: [2016-10-26T08:54:25] DEBUG2: writing secure socket:0x1dba190
Oct 26 08:54:25 whoosh Synergy 1.8.4: [2016-10-26T08:54:25] ERROR: ssl error occurred (generic failure)
Oct 26 08:54:25 whoosh Synergy 1.8.4: [2016-10-26T08:54:25] ERROR: error:140D00CF:SSL routines:SSL_write:protocol is shutdown
Oct 26 08:54:25 whoosh Synergy 1.8.4: [2016-10-26T08:54:25] DEBUG1: registered event type stopRetry as 48
Oct 26 08:54:25 whoosh Synergy 1.8.4: [2016-10-26T08:54:25] DEBUG1: registered event type disconnected as 49
Oct 26 08:54:25 whoosh anacron[6146]: Anacron 2.3 started on 2016-10-26
Oct 26 08:54:25 whoosh anacron[6146]: Normal exit (0 jobs run)
Oct 26 08:54:25 whoosh acpid: client connected from 1813[0:0]
Oct 26 08:54:25 whoosh acpid: 1 client rule loaded
Oct 26 08:54:25 whoosh anacron[6220]: Anacron 2.3 started on 2016-10-26
Oct 26 08:54:25 whoosh anacron[6220]: Normal exit (0 jobs run)
Oct 26 08:54:26 whoosh kernel: [  781.185805] synergys[5300]: segfault at 2f1 ip 00000000000002f1 sp 00007ffc1efe7118 error 14 in synergys[400000+e0000]
Oct 26 08:54:27 whoosh kernel: [  781.861559] e1000e: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx

 

eth1 is the interface on which the server communicates with its clients, but this come up after synergy starts.Could this be the problem?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now