Sign in to follow this  
rajiv

Synergy 1.8.4 Crashes when Windows locks/unlocks

8 posts in this topic

Every time my client Windows locks, my Synergy server crashes such that the mouse is barely responsive until I can manage to kill the server.

 

Every time my server Windows is unlocked, the Synergy server crashes (or has already crashed, maybe?).

 

This started happening after I upgraded to 1.8.4. It did not happen in 1.8.3. It is a productivity sink.

Share this post


Link to post
Share on other sites

Same here. Tried uninstalling but IDK if I wiped the preferences/cache. When Synergy locks up the mouse is really jittery and Synergy has usually already relaunched(?).

 

Setup: Windows>Ubuntu>Ubuntu

 

It also seems to be keeping one of the Ubuntu machines from screensaver/auto-locking.

Share this post


Link to post
Share on other sites

And also over here. Mouse and Keyboard stop responding and system is showing an enormous load (endless loop?). System is W7x64 running as server, W10x64 Client doesn't show this behaviour. Both systems are domain members if this is any difference. If you've got a networked PC you can use taskkill to shutdown synergys.exe and the system returns back into a usable state.

 

synergys.exe, Code: 0xc0000005, Offset: 0x0000000001cdd6c0
synergys.exe, Code: 0xc0000374, Offset: 0x00000000000bf262
synergys.exe, Code: 0xc0000005, Offset: 0x0000000001cce2d0
synergys.exe, Code: 0xc0000005, Offset: 0x0000000001c7c2b0

Share this post


Link to post
Share on other sites

Same issue on macOS Sierra (Mac OS X 10.12 (16A323))

 

the crash log is :

 

Thread 4 Crashed:

0 libsystem_kernel.dylib 0x9f68949a __pthread_kill + 10

1 libsystem_pthread.dylib 0x9f76ced3 pthread_kill + 90

2 libsystem_c.dylib 0x9f5e9a5c abort + 141

3 libsystem_malloc.dylib 0x9f6e099b free + 529

4 synergys 0x00014aac ArchMultithreadPosix::closeCondVar(ArchCondImpl*) + 28

5 synergys 0x0002e1b2 CondVarBase::~CondVarBase() + 34

6 synergys 0x00034f25 TCPSocket::~TCPSocket() + 53

7 synergys 0x00034ff3 TCPSocket::~TCPSocket() + 19

8 synergys 0x0002fd68 SecureListenSocket::deleteSocket(void*) + 104

9 synergys 0x00045e2a ClientListener::deleteSocket(void*) + 26

10 synergys 0x00067169 Server::handleClientDisconnected(Event const&, void*) + 185

11 synergys 0x0006bbc6 TMethodEventJob::run(Event const&) + 54

12 synergys 0x0001ad62 EventQueue::dispatchEvent(Event const&) + 98

13 synergys 0x00019eec EventQueue::loop() + 348

14 synergys 0x0006cc64 App::runEventsLoop(void*) + 20

15 synergys 0x00083fee TMethodJob::run() + 46

16 synergys 0x0002e71c Thread::threadFunc(void*) + 140

17 synergys 0x0001591c ArchMultithreadPosix::doThreadFunc(ArchThreadImpl*) + 76

18 synergys 0x00014f6b ArchMultithreadPosix::threadFunc(void*) + 75

19 libsystem_pthread.dylib 0x9f76a11b _pthread_body + 184

20 libsystem_pthread.dylib 0x9f76a063 _pthread_start + 243

21 libsystem_pthread.dylib 0x9f76993e thread_start + 34

Share this post


Link to post
Share on other sites

Same problem on my Windows server, connected to a mac client. Started happening after the 1.8.4 update. Is help on the way?!

Share this post


Link to post
Share on other sites

I have the same problem after upgrading to 1.8.4.

 

My setup is:

 

Server: W7

Client: MacOS Sierra

 

It is recoverable, but it is a pain.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this