Timi Tuohenmaa

Possible solution for AltGr issue in 1.8.4

7 posts in this topic

I claim to be the one who originally found out that having altgr=alt in configuration helped (wrote it to ticket in old bug tracker).

Now I offer new (ridiculous) solution.

 

Write altgr=shift to the configuration instead of that altgr=alt. I seriously don't know why, but did help for my Finnish keyboard.

 

section: screens
  server:
     option1 = value
     option2 = value
     etc
  somewinclient:
     option1 = value
     option2 = value
     etc
     altgr=shift

 

But to be honest I find it quite insulting (and arrogant) that altgr issue haven't been solved. It is absolutely vital part of many European keyboard layouts, but I supposed some US people don't just give a s*** for that. No need to wonder if Synergy is not selling well in many parts in Europe.

Share this post


Link to post
Share on other sites

Thank you very much for this solution. I use a French keyboard, and I got pretty confused (and somewhat annoyed) when I noticed my Alt Gr key behaving randomly after upgrading to 1.8.4. Changing "altgr=alt" to "altgr=shift" fixed the issue and restored my Alt Gr key to its original behavior. It doesn't make a whole lot of sense, but it works. Hopefully it doesn't have any bad side effect.

 

That kind of regression honestly makes me feel wary of upgrading to newer versions. This isn't the first time an update broke my working setup, and that's really unfortunate, to say the least.

Share this post


Link to post
Share on other sites

First of all thank you very much for the solution (even though it sounds weird it should translate altgr to shift, and that makes it work?)

I am using arch linux (server-side) and a windows 7 machine (client-side) and everything is working between these machines with your solution.

 

What is not working is running virtual machines (virtualbox) on the windows 7 machine

Back when altgr=alt was the solution, this worked fine and altgr could be used inside virtual machines as well.

But now with the altgr=shift hack this is not working in the virtual machines.

 

Has anyone had any experience with this or any solutions making it work.

 

Is there anywhere to upvote a correct solution for this problem to the synergy team (so no .conf file hack is needed) ?

For now downgrading (an otherwise excellent product seems my only solution)

Share this post


Link to post
Share on other sites

Hello,

 

 

great tip.

For me its works also (with German Keyboard).

Some characters did not work (° `) but I use it very poor.

 

 

greetings

 

michael

Share this post


Link to post
Share on other sites

Thank you very mouch.

:D:D:D

Also for me (italian keyboard) it's working the strange solution with "altgr=shift",

this with:

  • client Windows10 synergy 1.8.5
    server Red Hat 6.6 synergy 1.8.5

 

Thank's a lot

 

Massimo.

Share this post


Link to post
Share on other sites

Hi,

For me altgr = shift doesn't work,
but with no config ctrl+shift it's ok

Serveur --> Unbuntu
Client --> Windows 10

With a french Keyboard (Azerty)

Synergy version 1.8.8-stable-25a8cb2

Alain,
 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now