Sign in to follow this  
Ricky Smiley

Mouse Scroll Wheel

4 posts in this topic

I have 3 machines. The mouse scroll wheel works on all 3 on web browsers etc. until I decide to enter a game where the mouse wheel acts as a camera zoom and chat scrolling function. The scroll wheel will work on 2/3 of the machines in game, leaving one without functionality in game. This has only started after the 1.8.4 release. Everything else works fine with Synergy on the machine that has no mouse scroll functionality. Not sure what is causing this? Also, I have tried troubleshooting and using the default keybinds in game to zoom in and out and they will not function while Synergy is active. My main client is the center PC with PC displays to my left and right. The left PC is the one having issues, although I'm sure positioning does not play a factor in the problem I am experiencing. I don't see a lot of questions being answered here on the forums so maybe I'm out of luck on getting any feedback. Any help or "This is a known issue" answer from the devs would be greatly appreciated. Thanks :)

 

Edit: I have also tried running the Synergy repair tool.

Share this post


Link to post
Share on other sites

The wheel for me works only if I spin the wheel quickly.

I think I know what the problem is - it is high-precision wheels.

I've got two mice here, a Microsoft Mobile Mouse 4000 (wireless) and Microsoft Optical Mouse 2 (wired).

The wired mouse works great, the wireless one I have to spin the wheel quickly to get any response.

I bet that the problem is that the 4000 reports very fine-grained wheel changes, while the older mouse doesn't.

Share this post


Link to post
Share on other sites

I've been having the same issue, but I think I found the problem and would love to know if this fixes the issue for you as well.

 

After going into the my Trackball M570 mouse settings (bluetooth mouse) I went to the "game settings" menu and change the "Speed & Acceleration" option to "SetPoint Implementation" ---> "Retain OS Settings". Once I made this change and turn on "Retain OS Settings" it seems to be working fine.

 

I'll continue to test, but things have been working fine all morning for me (so far".

Share this post


Link to post
Share on other sites

Looks like they found a fix, Joe.

 

1. Open Synergy on the Server.

 

2. Click on "Configure Server".

 

3. Select "Advanced Server Settings" tab.

 

4. Check the "Don't take foreground window in Windows Servers".

 

5. Click "okay" and apply the changes.

 

This worked for me and I'm using a Windows 10 PC as my server and a MacBook (Sierra OS) and another Windows 10 PC.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this