Sign in to follow this  
Jonathan Long

Windows 10 Server with Ubuntu Client won't connect

3 posts in this topic

Hello,

 

I can't see that I'm doing anything wrong for this to not work.

 

I setup my Windows 10 PC as the Server and another computer with Ubuntu as the Client. I've verified in my PC list on the router that the IP Addresses are correct, and I'm using the standard port of 24800, but the connecting always times out. I can ping the other computer from a command prompt no problem. I didn't think it would be an firewall issue since they're on the same network, but I went ahead and disabled the software firewall and even put the router in DMZ mode (briefly) to make sure that wasn't the issue.

 

Admittedly, I'm very new to Ubuntu, but I don't see what the issue is. Has anyone else run into this? Thank you.

 

Chris

Share this post


Link to post
Share on other sites

I've now tried two Windows 10 machines and get very bizarre behavior:

 

My main PC as server and secondary PC as client:

- main PC will tell me another PC is trying to connect and take me to the configuration screen to place it.

- Adds the secondary PC in the configuration, but server will SIT on 'waiting for clients' and 'watchdog status: ok' and WILL NOT CONNECT WITH CLIENT.

- Secondary PC will keep saying 'connecting' and 'failed to connect to server: Timed out'

 

My secondary PC as server and main PC as client:

- WORKS fine.

 

What I've tried:

- I've got the Windows Firewall set to allow the app on both machines (public AND private)

- Using the default port (24800)

- Reset the router to default settings

- Completely removed all registry and app settings for Synergy on main machine and reinstalled.

- Updated all drivers (network, etc) / Windows 10, etc.

 

Nothing has worked so far. Both the main PC (server) and the secondary PC (client) will constantly detect each other, but the client will never actually connect (unless I switch the client and server as I mentioned, but that won't work for me.)

 

Any more suggestions? Thank you.

Share this post


Link to post
Share on other sites

I figured out the issue.. and it wasn't with Synergy, it was with my main PC and a virtual network adapter getting in the way. I'll do a full write-up on how to best troubleshoot based on my experience sometime this week.

Share this post


Link to post
Share on other sites

I'm seeing exactly the same symptoms - it works with my Mac as a server and Windows 10 PC as client, but not the other way round - just sits there waiting and not connecting.

 

How did you fix it?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this