Kevin Chetty

Synergy 1.8.4 server not starting on Debian Stretch

6 posts in this topic

Hi,

 

I updated to Synergy 1.8.4 (Basic) today and the server doesn't start any longer. I'm running Debian Stretch 64Bit. Interestingly the error is related to SSL and crypto libraries, which I thought the basic version didn't use.

 

Error:

 

[2016-10-13T20:44:39] INFO: log level: INFO
/usr/bin/synergys: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory
[2016-10-13T20:44:39] ERROR: process exited with error code: 127
[2016-10-13T20:44:39] INFO: detected process not running, auto restarting

 

My distribution doesn't have "libssl.so.1.0.0" instead it has "libssl.so.1.0.2" as you can see here.

I tried adding a symlink:

sudo ln -s /usr/lib/x86_64-linux-gnu/libssl.so.1.0.2 /usr/lib/x86_64-linux-gnu/libssl.so.1.0.0

 

Then the error shifted to "libcrypto.so.1.0.0":

2016-10-13T20:51:22] INFO: log level: INFO
/usr/bin/synergys: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory
[2016-10-13T20:51:22] ERROR: process exited with error code: 127
[2016-10-13T20:51:22] INFO: detected process not running, auto restarting

 

Which I also created a symlink for:

sudo ln -s /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.2 /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0

 

After that the server failed with the following message:

[2016-10-13T20:53:12] INFO: log level: INFO
/usr/bin/synergys: /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0: version `OPENSSL_1.0.0' not found (required by /usr/bin/synergys)
/usr/bin/synergys: /usr/lib/x86_64-linux-gnu/libssl.so.1.0.0: version `OPENSSL_1.0.0' not found (required by /usr/bin/synergys)
[2016-10-13T20:53:12] ERROR: process exited with error code: 1

 

Which makes sense, as I'm running version 1.0.2.

 

I was going to compile Synergy myself, so it links to my current libraries, but the download link for the sources is dead (404).

 

I have made myself dependent on synergy some time ago. I have no input devices for my other PC. So this is quite a big problem for me. (Currently running around my desk to replug my mouse and keyboard is the only option.)

 

 

There doesn't seem to be an option to download the old versions on the website. Perhaps someone has the 1.8.3 Synergy (Basic) deb-package lying around and is willing to send it to me?

 

Or..... Any advice on this?

 

Edit: I also tried running the nightly version. It doesn't start.

Share this post


Link to post
Share on other sites
On 4/18/2017 at 10:04 AM, Tomasz Klicki said:

As a workaround in Debian Stretch you can install this package from Jessie. It worked for me:

https://packages.debian.org/jessie/amd64/libssl1.0.0/download

Thanks for the link  that worked for me as well  on stretch

 

http://security.debian.org/debian-security/pool/updates/main/o/openssl/libssl1.0.0_1.0.1t-1+deb8u7_amd64.deb

Edited by superdug

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now