Stephen Mann

Windows 10 pro, anniversary edition, firewall problem

8 posts in this topic

Previously I could get Synergy to work between Win 10 PC's by turning off the Private Profile firewall.

After the latest Windows 10 update, I no longer have that option because Windows turns the firewall back on a few seconds after I turn it off.

Any tips would be appreciated.

Share this post


Link to post
Share on other sites

Same issue here. Trying to connect to a Win7 box and it connects for about 3 seconds then the server dies.

Share this post


Link to post
Share on other sites

I found the problem and "fixed" it. You can go to Run>Services.msc then stop Windows Firewall, set startup to disabled and then restart the PC.

 

I hope M$ applies a proper fix soon.

Share this post


Link to post
Share on other sites
I found the problem and "fixed" it. You can go to Run>Services.msc then stop Windows Firewall, set startup to disabled and then restart the PC.

 

I hope M$ applies a proper fix soon.

 

 

Thanks for the tip, but turning off the firewall completely is hardly a solution.

Share this post


Link to post
Share on other sites

I got an actual fix for this and now synergy is working and Windows Firewall is now also working correctly.

 

I used powershell from command prompt admin to remove the Windows store, set windows firewall back to start automatically, stated the service, went into control panel and set firewall defaults, rebooted, and then reinstalled windows store via powershell. You will need to login to the app store and xbox(if you use it), and then check for updates within the store to get the store squared away.

 

Several reboots later and everything is working correctly, the firewall is on and I can use synergy with my other pcs unhindered.

 

Good luck.

Share this post


Link to post
Share on other sites
I got an actual fix for this and now synergy is working and Windows Firewall is now also working correctly.

 

I used powershell from command prompt admin to remove the Windows store, set windows firewall back to start automatically, stated the service, went into control panel and set firewall defaults, rebooted, and then reinstalled windows store via powershell. You will need to login to the app store and xbox(if you use it), and then check for updates within the store to get the store squared away.

 

Several reboots later and everything is working correctly, the firewall is on and I can use synergy with my other pcs unhindered.

 

Good luck.

 

So, you're saying that Windows Store is the reason my firewall stays on?

That sounds awfully convoluted. Is this on Version 1607? And while I've used PowerShell, how do you remove and restore the Windows Store?

Share this post


Link to post
Share on other sites

1607, anniversary ed, yes. Apparently windows store is tied to windows firewall. you can google the instructions on removing it. Here's the powershell command to reinstall it.

 

Get-AppxPackage -AllUsers| Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

Share this post


Link to post
Share on other sites
1607, anniversary ed, yes. Apparently windows store is tied to windows firewall. you can google the instructions on removing it. Here's the powershell command to reinstall it.

 

Get-AppxPackage -AllUsers| Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

 

Thanks, I'll give that a try shortly.

It almost seems easier to just disable the Windows Store...

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now