Sign in to follow this  
Antonio Perez Valencia

synergy won't run-upgraded to stable 1.7.1 in debian 64bits

2 posts in this topic

Hi, I was using synergy just fine but when upgraded to the stable 1.7.1 I can't get synergy starting/running on my server (debian wheezy 64bits). When I installed the version in my client running a debian 32bits it was installed without any problem and could register without any problem. I have tried to remove and install de version a few times with the same result. I also tried downoading the file a few times. I would appreciate that you give a hint to get it running.

Share this post


Link to post
Share on other sites
Moved this to the support forums, but left a shadow link in its place so it's not lost.

Share this post


Link to post
Share on other sites
The 32 vs. 64 bit thing is interesting. I installed stable 1.7.1 on Fedora 21 (server) and Red Hat EL6 (client), both 64bit. Also on a Vista 32 box that's dedicated to security cams. All 3 had been working happily with 1.5.1 with no setup issues at all. After 1.7.1, the Vista box kept reporting crashes of subprocesses and failures to connect. The Fedora box reported clients connecting and handshake failures over and over. The RHEL6 box just reported an invalid ELF header on libdns_sd.so.1 and: *** WARNING *** The program 'synergy' uses the Apple Bonjour compatibility layer of Avahi. *** WARNING *** Please fix your application to use the native API of Avahi! *** WARNING *** For more information see <http://0pointer.de/avahi-compat?s=libdns_sd&e=synergy> *** WARNING *** The program 'synergy' called 'DNSServiceRegister()' which is not supported (or only supported partially) in the Apple Bonjour compatibility layer of Avahi. *** WARNING *** Please fix your application to use the native API of Avahi! *** WARNING *** For more information see <http://0pointer.de/avahi-compat?s=libdns_sd&e=synergy&f=DNSServiceRegister> The "invalid ELF header" error is generally from some 32v64bit crossup in the build config, in my experience, but I'm just a Linux support engineer, not a developer. I turned off SSL on Vista and Fedora and reinstalled 1.5.1 on RHEL6 and all is well again.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this